Every CVE Search/ Get API key

CVE-2015-1077

WebKit, as used in Apple Safari before 6.2.4, 7.x before 7.1.4, and 8.x before 8.0.4, allows...

6.8 Medium

WebKit, as used in Apple Safari before 6.2.4, 7.x before 7.1.4, and 8.x before 8.0.4, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site, a different vulnerability than other CVEs listed in APPLE-SA-2015-03-17-1.

Exploit likelihood

2.69%Down 1.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

WebKit, as used in Apple Safari before 6.2.4, 7.x before 7.1.4, and 8.x before 8.0.4, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site, a different vulnerability than other CVEs listed in APPLE-SA-2015-03-17-1.

Record
CVE-2015-1077
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-399
Updated
2026-11-02
CVE List No score

WebKit, as used in Apple Safari before 6.2.4, 7.x before 7.1.4, and 8.x before 8.0.4, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site, a different vulnerability than other CVEs listed in APPLE-SA-2015-03-17-1.

Record
CVE-2015-1077
Updated
2026-11-02
EUVDEUVD-2015-1220 No score

WebKit, as used in Apple Safari before 6.2.4, 7.x before 7.1.4, and 8.x before 8.0.4, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site, a different vulnerability than other CVEs listed in APPLE-SA-2015-03-17-1.

Record
EUVD-2015-1220
Updated
2026-11-03
GitHub AdvisoriesGHSA-p842-3qhh-6hfp No score

WebKit, as used in Apple Safari before 6.2.4, 7.x before 7.1.4, and 8.x before 8.0.4, allows...

WebKit, as used in Apple Safari before 6.2.4, 7.x before 7.1.4, and 8.x before 8.0.4, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site, a different vulnerability than other CVEs listed in APPLE-SA-2015-03-17-1.

Record
GHSA-p842-3qhh-6hfp
Updated
2026-11-02
OSVMGASA-2016-0116 No score

Updated webkit2 packages fix security vulnerability

The webkit2 package has been updated to version 2.10.9, fixing several security issues and other bugs.

Record
MGASA-2016-0116
Updated
2026-11-02
OSVUBUNTU-CVE-2015-1077 No score

WebKit, as used in Apple Safari before 6.2.4, 7.x before 7.1.4, and 8.x before 8.0.4, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site, a different vulnerability than other CVEs listed in APPLE-SA-2015-03-17-1.

Record
UBUNTU-CVE-2015-1077
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
webkit2
Mageia:5
From an advisory covering 106 CVEs
before 2.10.9-1.mga5
2.10.9-1.mga5
qtwebkit-opensource-src
Ubuntu:16.04:LTS
All versions, plus listed versions
5.4.2+dfsg-1ubuntu2.15.5.1+dfsg-2ubuntu1
None known
qtwebkit-source
Ubuntu:16.04:LTS
All versions, plus listed versions
2.3.2-0ubuntu102.3.2-0ubuntu11
None known
webkitgtk
Ubuntu:16.04:LTS
All versions, plus listed versions
2.4.9-2ubuntu22.4.10-0ubuntu12.4.11-0ubuntu0.1
None known

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-1077 is a medium vulnerability (CVSS 6.8) in Apple Safari, published March 18, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.69%, the 85th percentile. No source names a fixed version.

References

Show 26 moreShow less
MoveEnter Open