CVE-2015-1332
The oxide::JavaScriptDialogManager function in oxide-qt before 1.9.1 as packaged in Ubuntu 15.04...
The oxide::JavaScriptDialogManager function in oxide-qt before 1.9.1 as packaged in Ubuntu 15.04 and Ubuntu 14.04 allows remote attackers to cause a denial of service (application crash) or execute arbitrary code via a crafted website.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
The oxide::JavaScriptDialogManager function in oxide-qt before 1.9.1 as packaged in Ubuntu 15.04 and Ubuntu 14.04 allows remote attackers to cause a denial of service (application crash) or execute arbitrary code via a crafted website.
- Record
CVE-2015-1332- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
The oxide::JavaScriptDialogManager function in oxide-qt before 1.9.1 as packaged in Ubuntu 15.04 and Ubuntu 14.04 allows remote attackers to cause a denial of service (application crash) or execute arbitrary code via a crafted website.
- Record
CVE-2015-1332- Updated
- 2026-11-02
EUVDEUVD-2015-1472 No score
The oxide::JavaScriptDialogManager function in oxide-qt before 1.9.1 as packaged in Ubuntu 15.04 and Ubuntu 14.04 allows remote attackers to cause a denial of service (application crash) or execute arbitrary code via a crafted website.
- Record
EUVD-2015-1472- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-m65r-r69v-hgpg
8.8
The oxide::JavaScriptDialogManager function in oxide-qt before 1.9.1 as packaged in Ubuntu 15.04...
The oxide::JavaScriptDialogManager function in oxide-qt before 1.9.1 as packaged in Ubuntu 15.04 and Ubuntu 14.04 allows remote attackers to cause a denial of service (application crash) or execute arbitrary code via a crafted website.
- Record
GHSA-m65r-r69v-hgpg- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-1332
8.8
The oxide::JavaScriptDialogManager function in oxide-qt before 1.9.1 as packaged in Ubuntu 15.04 and Ubuntu 14.04 allows remote attackers to cause a denial of service (application crash) or execute arbitrary code via a crafted website.
- Record
UBUNTU-CVE-2015-1332- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUSN-2735-1 No score
oxide-qt vulnerabilities
It was discovered that the DOM tree could be corrupted during parsing in some circumstances. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit this to bypass same-origin restrictions or cause a denial of service. (CVE-2015-1291)
An issue was discovered in NavigatorServiceWorker::serviceWorker in Blink. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit this to bypass same-origin restrictions. (CVE-2015-1292)
An issue was discovered in the DOM implementation in Blink. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit this to bypass same-origin restrictions. (CVE-2015-1293)
A use-after-free was discovered in Skia. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit this to cause a denial of service via renderer crash, or execute arbitrary code with the privileges of the sandboxed render process. (CVE-2015-1294)
A use-after-free was discovered in the shared-timer implementation in Blink. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit this to cause a denial of service via renderer crash, or execute arbitrary code with the privileges of the sandboxed render process. (CVE-2015-1299)
It was discovered that the availability of iframe Resource Timing API times was not properly restricted in some circumstances. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit this to obtain sensitive information. (CVE-2015-1300)
Multiple security issues were discovered in Chromium. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit these to read uninitialized memory, cause a denial of service via application crash or execute arbitrary code with the privileges of the user invoking the program. (CVE-2015-1301)
A heap corruption issue was discovered in oxide::JavaScriptDialogManager. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit this to cause a denial of service via application crash, or execute arbitrary code with the privileges of the user invoking the program. (CVE-2015-1332)
- Record
USN-2735-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
oxide-qtUbuntu:14.04:LTS |
before 1.9.1-0ubuntu0.14.04.2, plus listed versions 1.0.0~bzr437-0ubuntu11.0.0~bzr452-0ubuntu11.0.0~bzr475-0ubuntu11.0.0~bzr490-0ubuntu11.0.0~bzr501-0ubuntu1 Show 15 moreShow less1.0.0~bzr501-0ubuntu21.0.4-0ubuntu0.14.04.11.0.5-0ubuntu0.14.04.11.1.2-0ubuntu0.14.04.11.2.5-0ubuntu0.14.04.11.3.4-0ubuntu0.14.04.11.4.2-0ubuntu0.14.04.11.4.3-0ubuntu0.14.04.11.5.5-0ubuntu0.14.04.31.5.6-0ubuntu0.14.04.21.6.5-0ubuntu0.14.04.11.6.6-0ubuntu0.14.04.11.7.8-0ubuntu0.14.04.11.7.9-0ubuntu0.14.04.11.8.4-0ubuntu0.14.04.2 |
1.9.1-0ubuntu0.14.04.2 |
oxide-qtUbuntu:14.04:LTS From an advisory covering 8 CVEs |
before 1.9.1-0ubuntu0.14.04.2, plus listed versions 1.0.0~bzr437-0ubuntu11.0.0~bzr452-0ubuntu11.0.0~bzr475-0ubuntu11.0.0~bzr490-0ubuntu11.0.0~bzr501-0ubuntu1 Show 15 moreShow less1.0.0~bzr501-0ubuntu21.0.4-0ubuntu0.14.04.11.0.5-0ubuntu0.14.04.11.1.2-0ubuntu0.14.04.11.2.5-0ubuntu0.14.04.11.3.4-0ubuntu0.14.04.11.4.2-0ubuntu0.14.04.11.4.3-0ubuntu0.14.04.11.5.5-0ubuntu0.14.04.31.5.6-0ubuntu0.14.04.21.6.5-0ubuntu0.14.04.11.6.6-0ubuntu0.14.04.11.7.8-0ubuntu0.14.04.11.7.9-0ubuntu0.14.04.11.8.4-0ubuntu0.14.04.2 |
1.9.1-0ubuntu0.14.04.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-1332 is a high vulnerability (CVSS 8.8) in Oxide Project Oxide, published September 8, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.59%, the 85th percentile. Fixed in oxide-qt 1.9.1-0ubuntu0.14.04.2.
References
people.canonical.com/~ubuntu-security/cve/2015/CVE-2015-1332.html
launchpad.net/ubuntu/+source/oxide-qt/1.9.1-0ubuntu0.15.04.1
ubuntu.com/usn/USN-2735-1
securityfocus.com/bid/76710
nvd.nist.gov/vuln/detail/CVE-2015-1332
github.com/advisories/GHSA-m65r-r69v-hgpg
Show 11 moreShow less
ubuntu.com/security/CVE-2015-1332
ubuntu.com/security/notices/USN-2735-1
cve.org/CVERecord?id=CVE-2015-1332
ubuntu.com/security/CVE-2015-1291
ubuntu.com/security/CVE-2015-1292
ubuntu.com/security/CVE-2015-1293
ubuntu.com/security/CVE-2015-1294
ubuntu.com/security/CVE-2015-1299
ubuntu.com/security/CVE-2015-1300
ubuntu.com/security/CVE-2015-1301
launchpad.net/bugs/1470905