Every CVE Search/ Get API key

CVE-2015-1369

SQL Injection in sequelize

7.5 HighFix available

SQL injection vulnerability in Sequelize before 2.0.0-rc7 for Node.js allows remote attackers to execute arbitrary SQL commands via the order parameter.

Exploit likelihood

2.11%Up 1.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

SQL injection vulnerability in Sequelize before 2.0.0-rc7 for Node.js allows remote attackers to execute arbitrary SQL commands via the order parameter.

Record
CVE-2015-1369
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-89
Updated
2026-11-02
CVE List No score

SQL injection vulnerability in Sequelize before 2.0.0-rc7 for Node.js allows remote attackers to execute arbitrary SQL commands via the order parameter.

Record
CVE-2015-1369
Updated
2026-11-02
EUVDEUVD-2017-0332 No score

SQL injection vulnerability in Sequelize before 2.0.0-rc7 for Node.js allows remote attackers to execute arbitrary SQL commands via the order parameter.

Record
EUVD-2017-0332
Updated
2026-11-03
GitHub AdvisoriesGHSA-xqg8-cv3h-xppv No score

SQL Injection in sequelize

Versions 2.0.0-rc-7 and earlier of sequelize are affected by a SQL injection vulnerability when user input is passed into the order parameter.

Proof of Concept

Test.findAndCountAll({
where: { id :1 },
order : [['id', 'UNTRUSTED USER INPUT']]
})

Recommendation

Update to version 2.0.0-rc8 or later

Record
GHSA-xqg8-cv3h-xppv
Weakness
CWE-89
Updated
2026-11-02
OSVGHSA-xqg8-cv3h-xppv No score

SQL Injection in sequelize

Versions 2.0.0-rc-7 and earlier of sequelize are affected by a SQL injection vulnerability when user input is passed into the order parameter.

Proof of Concept

Test.findAndCountAll({
where: { id :1 },
order : [['id', 'UNTRUSTED USER INPUT']]
})

Recommendation

Update to version 2.0.0-rc8 or later

Record
GHSA-xqg8-cv3h-xppv
Weakness
CWE-89
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
sequelize
npm
through 2.0.0-rc7
2.0.0-rc8
sequelize
npm
before 2.0.0-rc8
2.0.0-rc8

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-1369 is a high vulnerability (CVSS 7.5) in Sequelize Project Sequelize, published January 27, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.11%, the 81st percentile. Fixed in sequelize 2.0.0-rc8.

References

MoveEnter Open