CVE-2015-1369
SQL Injection in sequelize
SQL injection vulnerability in Sequelize before 2.0.0-rc7 for Node.js allows remote attackers to execute arbitrary SQL commands via the order parameter.
Exploit likelihood
What each source reports
NVD Score used
7.5
SQL injection vulnerability in Sequelize before 2.0.0-rc7 for Node.js allows remote attackers to execute arbitrary SQL commands via the order parameter.
- Record
CVE-2015-1369- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-89
- Updated
- 2026-11-02
CVE List No score
SQL injection vulnerability in Sequelize before 2.0.0-rc7 for Node.js allows remote attackers to execute arbitrary SQL commands via the order parameter.
- Record
CVE-2015-1369- Updated
- 2026-11-02
EUVDEUVD-2017-0332 No score
SQL injection vulnerability in Sequelize before 2.0.0-rc7 for Node.js allows remote attackers to execute arbitrary SQL commands via the order parameter.
- Record
EUVD-2017-0332- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-xqg8-cv3h-xppv No score
SQL Injection in sequelize
Versions 2.0.0-rc-7 and earlier of sequelize are affected by a SQL injection vulnerability when user input is passed into the order parameter.
Proof of Concept
Test.findAndCountAll({
where: { id :1 },
order : [['id', 'UNTRUSTED USER INPUT']]
})
Recommendation
Update to version 2.0.0-rc8 or later
- Record
GHSA-xqg8-cv3h-xppv- Weakness
- CWE-89
- Updated
- 2026-11-02
OSVGHSA-xqg8-cv3h-xppv No score
SQL Injection in sequelize
Versions 2.0.0-rc-7 and earlier of sequelize are affected by a SQL injection vulnerability when user input is passed into the order parameter.
Proof of Concept
Test.findAndCountAll({
where: { id :1 },
order : [['id', 'UNTRUSTED USER INPUT']]
})
Recommendation
Update to version 2.0.0-rc8 or later
- Record
GHSA-xqg8-cv3h-xppv- Weakness
- CWE-89
- Updated
- 2026-11-02
Affected products
Affected packages
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-1369 is a high vulnerability (CVSS 7.5) in Sequelize Project Sequelize, published January 27, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.11%, the 81st percentile. Fixed in sequelize 2.0.0-rc8.
References
github.com/sequelize/sequelize/pull/2919
nodesecurity.io/advisories/sequelize-sql-injection-order
openwall.com/lists/oss-security/2015/01/23/2
nvd.nist.gov/vuln/detail/CVE-2015-1369
github.com/sequelize/sequelize/issues/2906
github.com/advisories/GHSA-xqg8-cv3h-xppv
npmjs.com/advisories/33
github.com/sequelize/sequelize