Every CVE Search/ Get API key

CVE-2015-1395

Directory traversal vulnerability in GNU patch versions which support Git-style patching before 2...

7.5 HighFix available

Directory traversal vulnerability in GNU patch versions which support Git-style patching before 2.7.3 allows remote attackers to write to arbitrary files with the permissions of the target user via a .. (dot dot) in a diff file name.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

11.3%Up 9.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Directory traversal vulnerability in GNU patch versions which support Git-style patching before 2.7.3 allows remote attackers to write to arbitrary files with the permissions of the target user via a .. (dot dot) in a diff file name.

Record
CVE-2015-1395
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
7.8 HighAV:N/AC:L/Au:N/C:N/I:C/A:N
Weakness
CWE-22
Updated
2026-11-02
CVE List No score

Directory traversal vulnerability in GNU patch versions which support Git-style patching before 2.7.3 allows remote attackers to write to arbitrary files with the permissions of the target user via a .. (dot dot) in a diff file name.

Record
CVE-2015-1395
Updated
2026-11-02
EUVDEUVD-2015-1532 No score

Directory traversal vulnerability in GNU patch versions which support Git-style patching before 2.7.3 allows remote attackers to write to arbitrary files with the permissions of the target user via a .. (dot dot) in a diff file name.

Record
EUVD-2015-1532
Updated
2026-11-03
GitHub AdvisoriesGHSA-97xh-wvxp-9m89 7.5

Directory traversal vulnerability in GNU patch versions which support Git-style patching before 2...

Directory traversal vulnerability in GNU patch versions which support Git-style patching before 2.7.3 allows remote attackers to write to arbitrary files with the permissions of the target user via a .. (dot dot) in a diff file name.

Record
GHSA-97xh-wvxp-9m89
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-22
Updated
2026-11-02
OSV 7.5

Directory traversal vulnerability in GNU patch versions which support Git-style patching before 2.7.3 allows remote attackers to write to arbitrary files with the permissions of the target user via a .. (dot dot) in a diff file name.

Record
CVE-2015-1395
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2015-1395 7.5

Directory traversal vulnerability in GNU patch versions which support Git-style patching before 2.7.3 allows remote attackers to write to arbitrary files with the permissions of the target user via a .. (dot dot) in a diff file name.

Record
DEBIAN-CVE-2015-1395
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2015-1395 7.5

Directory traversal vulnerability in GNU patch versions which support Git-style patching before 2.7.3 allows remote attackers to write to arbitrary files with the permissions of the target user via a .. (dot dot) in a diff file name.

Record
UBUNTU-CVE-2015-1395
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVMGASA-2015-0068 No score

Updated patch packages fix security vulnerabilities

Updated patch package fixes security vulnerabilities:

It was reported that a crafted diff file can make patch eat memory and later segfault (CVE-2014-9637).

It was reported that the versions of the patch utility that support Git-style patches are vulnerable to a directory traversal flaw. This could allow an attacker to overwrite arbitrary files by applying a specially crafted patch, with the privileges of the user running patch (CVE-2015-1395).

GNU patch before 2.7.4 allows remote attackers to write to arbitrary files via a symlink attack in a patch file (CVE-2015-1196).

Record
MGASA-2015-0068
Updated
2026-11-02
OSVSUSE-SU-2015:1019-1 No score

Security update for patch

The GNU patch utility was updated to 2.7.5 to fix three security issues and one non-security bug.

The following vulnerabilities were fixed:

  • CVE-2015-1196: directory traversal flaw when handling git-style patches. This could allow an attacker to overwrite arbitrary files by tricking the user into applying a specially crafted patch. (bsc#913678)
  • CVE-2015-1395: directory traversal flaw when handling patches which rename files. This could allow an attacker to overwrite arbitrary files by tricking the user into applying a specially crafted patch. (bsc#915328)
  • CVE-2015-1396: directory traversal flaw via symbolic links. This could allow an attacker to overwrite arbitrary files by tricking the user into applying a by applying a specially crafted patch. (bsc#915329)

The following bug was fixed:

  • bsc#904519: Function names in hunks (from diff -p) are now preserved in reject files.
Record
SUSE-SU-2015:1019-1
Updated
2026-11-02
OSVUSN-2651-1 No score

patch vulnerabilities

Jakub Wilk discovered that GNU patch did not correctly handle file paths in patch files. An attacker could specially craft a patch file that could overwrite arbitrary files with the privileges of the user invoking the program. This issue only affected Ubuntu 12.04 LTS. (CVE-2010-4651)

László Böszörményi discovered that GNU patch did not correctly handle some patch files. An attacker could specially craft a patch file that could cause a denial of service. (CVE-2014-9637)

Jakub Wilk discovered that GNU patch did not correctly handle symbolic links in git style patch files. An attacker could specially craft a patch file that could overwrite arbitrary files with the privileges of the user invoking the program. This issue only affected Ubuntu 14.04 LTS and Ubuntu 14.10. (CVE-2015-1196)

Jakub Wilk discovered that GNU patch did not correctly handle file renames in git style patch files. An attacker could specially craft a patch file that could overwrite arbitrary files with the privileges of the user invoking the program. This issue only affected Ubuntu 14.04 LTS and Ubuntu 14.10. (CVE-2015-1395)

Jakub Wilk discovered the fix for CVE-2015-1196 was incomplete for GNU patch. An attacker could specially craft a patch file that could overwrite arbitrary files with the privileges of the user invoking the program. This issue only affected Ubuntu 14.04 LTS and Ubuntu 14.10. (CVE-2015-1396)

Record
USN-2651-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
patch
Debian:12
before 2.7.3-1
2.7.3-1
patch
Debian:13
before 2.7.3-1
2.7.3-1
patch
Debian:14
before 2.7.3-1
2.7.3-1
patch
Mageia:4
before 2.7.4-1.mga4
2.7.4-1.mga4
patch
SUSE:Linux Enterprise Desktop 12
before 2.7.5-7.1
2.7.5-7.1
patch
SUSE:Linux Enterprise Server 12
before 2.7.5-7.1
2.7.5-7.1
patch
SUSE:Linux Enterprise Server for SAP Applications 12
before 2.7.5-7.1
2.7.5-7.1
patch
Ubuntu:14.04:LTS
before 2.7.1-4ubuntu2.3, plus listed versions
2.7.1-32.7.1-42.7.1-4ubuntu12.7.1-4ubuntu2
2.7.1-4ubuntu2.3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-1395 is a high vulnerability (CVSS 7.5) in Gnu Patch, published January 28, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 11.3%, the 95th percentile. Fixed in patch 2.7.3-1.

References

Show 24 moreShow less
MoveEnter Open