Every CVE Search/ Get API key

CVE-2014-9637

GNU patch 2.7.2 and earlier allows remote attackers to cause a denial of service (memory...

5.5 MediumFix available

GNU patch 2.7.2 and earlier allows remote attackers to cause a denial of service (memory consumption and segmentation fault) via a crafted diff file.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

2.36%Up 0.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.5

GNU patch 2.7.2 and earlier allows remote attackers to cause a denial of service (memory consumption and segmentation fault) via a crafted diff file.

Record
CVE-2014-9637
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
7.1 HighAV:N/AC:M/Au:N/C:N/I:N/A:C
Weakness
CWE-399
Updated
2026-11-02
CVE List No score

GNU patch 2.7.2 and earlier allows remote attackers to cause a denial of service (memory consumption and segmentation fault) via a crafted diff file.

Record
CVE-2014-9637
Updated
2026-11-02
EUVDEUVD-2014-9447 No score

GNU patch 2.7.2 and earlier allows remote attackers to cause a denial of service (memory consumption and segmentation fault) via a crafted diff file.

Record
EUVD-2014-9447
Updated
2026-11-03
GitHub AdvisoriesGHSA-wpf6-pr9h-p2gj 5.5

GNU patch 2.7.2 and earlier allows remote attackers to cause a denial of service (memory...

GNU patch 2.7.2 and earlier allows remote attackers to cause a denial of service (memory consumption and segmentation fault) via a crafted diff file.

Record
GHSA-wpf6-pr9h-p2gj
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV 5.5

GNU patch 2.7.2 and earlier allows remote attackers to cause a denial of service (memory consumption and segmentation fault) via a crafted diff file.

Record
CVE-2014-9637
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2014-9637 5.5

GNU patch 2.7.2 and earlier allows remote attackers to cause a denial of service (memory consumption and segmentation fault) via a crafted diff file.

Record
DEBIAN-CVE-2014-9637
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2014-9637 5.5

GNU patch 2.7.2 and earlier allows remote attackers to cause a denial of service (memory consumption and segmentation fault) via a crafted diff file.

Record
UBUNTU-CVE-2014-9637
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2015-0068 No score

Updated patch packages fix security vulnerabilities

Updated patch package fixes security vulnerabilities:

It was reported that a crafted diff file can make patch eat memory and later segfault (CVE-2014-9637).

It was reported that the versions of the patch utility that support Git-style patches are vulnerable to a directory traversal flaw. This could allow an attacker to overwrite arbitrary files by applying a specially crafted patch, with the privileges of the user running patch (CVE-2015-1395).

GNU patch before 2.7.4 allows remote attackers to write to arbitrary files via a symlink attack in a patch file (CVE-2015-1196).

Record
MGASA-2015-0068
Updated
2026-11-02
OSVSUSE-SU-2018:1162-1 No score

Security update for patch

This update for patch fixes several issues.

These security issues were fixed:

  • CVE-2018-1000156: patch: Malicious patch files cause ed to execute arbitrary commands (bsc#1088420).
  • CVE-2014-9637: Prevent DoS by remote attackers (memory consumption and segmentation fault) via a crafted diff file (bsc#914891).
  • CVE-2016-10713: Prevent out-of-bounds access within pch_write_line() that could have lead to DoS via a crafted input file (bsc#1080918).
  • CVE-2010-4651: Fixed a directory traversal bug (bsc#662957):
Record
SUSE-SU-2018:1162-1
Updated
2026-11-02
OSVUSN-2651-1 No score

patch vulnerabilities

Jakub Wilk discovered that GNU patch did not correctly handle file paths in patch files. An attacker could specially craft a patch file that could overwrite arbitrary files with the privileges of the user invoking the program. This issue only affected Ubuntu 12.04 LTS. (CVE-2010-4651)

László Böszörményi discovered that GNU patch did not correctly handle some patch files. An attacker could specially craft a patch file that could cause a denial of service. (CVE-2014-9637)

Jakub Wilk discovered that GNU patch did not correctly handle symbolic links in git style patch files. An attacker could specially craft a patch file that could overwrite arbitrary files with the privileges of the user invoking the program. This issue only affected Ubuntu 14.04 LTS and Ubuntu 14.10. (CVE-2015-1196)

Jakub Wilk discovered that GNU patch did not correctly handle file renames in git style patch files. An attacker could specially craft a patch file that could overwrite arbitrary files with the privileges of the user invoking the program. This issue only affected Ubuntu 14.04 LTS and Ubuntu 14.10. (CVE-2015-1395)

Jakub Wilk discovered the fix for CVE-2015-1196 was incomplete for GNU patch. An attacker could specially craft a patch file that could overwrite arbitrary files with the privileges of the user invoking the program. This issue only affected Ubuntu 14.04 LTS and Ubuntu 14.10. (CVE-2015-1396)

Record
USN-2651-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
patch
Debian:12
before 2.7.1-7
2.7.1-7
patch
Debian:13
before 2.7.1-7
2.7.1-7
patch
Debian:14
before 2.7.1-7
2.7.1-7
patch
Mageia:4
before 2.7.4-1.mga4
2.7.4-1.mga4
patch
SUSE:Linux Enterprise Point of Sale 11 SP3
before 2.5.9-252.22.7.1
2.5.9-252.22.7.1
patch
SUSE:Linux Enterprise Server 11 SP3-LTSS
before 2.5.9-252.22.7.1
2.5.9-252.22.7.1
patch
SUSE:Linux Enterprise Server 11 SP3-TERADATA
before 2.5.9-252.22.7.1
2.5.9-252.22.7.1
patch
SUSE:Linux Enterprise Server 11 SP4
before 2.5.9-252.22.7.1
2.5.9-252.22.7.1
patch
SUSE:Linux Enterprise Server for SAP Applications 11 SP4
before 2.5.9-252.22.7.1
2.5.9-252.22.7.1
patch
Ubuntu:14.04:LTS
before 2.7.1-4ubuntu2.3, plus listed versions
2.7.1-32.7.1-42.7.1-4ubuntu12.7.1-4ubuntu2
2.7.1-4ubuntu2.3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-9637 is a medium vulnerability (CVSS 5.5) in Gnu Patch, published December 31, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.36%, the 83rd percentile. Fixed in patch 2.7.1-7.

References

Show 25 moreShow less
MoveEnter Open