Every CVE Search/ Get API key

CVE-2015-2187

The dissect_atn_cpdlc_heur function in asn1/atn-cpdlc/packet-atn-cpdlc-template.c in the ATN...

5.0 MediumFix available

The dissect_atn_cpdlc_heur function in asn1/atn-cpdlc/packet-atn-cpdlc-template.c in the ATN-CPDLC dissector in Wireshark 1.12.x before 1.12.4 does not properly follow the TRY/ENDTRY code requirements, which allows remote attackers to cause a denial of service (stack memory corruption and application crash) via a crafted packet.

Exploit likelihood

2.62%Up 1.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

The dissect_atn_cpdlc_heur function in asn1/atn-cpdlc/packet-atn-cpdlc-template.c in the ATN-CPDLC dissector in Wireshark 1.12.x before 1.12.4 does not properly follow the TRY/ENDTRY code requirements, which allows remote attackers to cause a denial of service (stack memory corruption and application crash) via a crafted packet.

Record
CVE-2015-2187
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

The dissect_atn_cpdlc_heur function in asn1/atn-cpdlc/packet-atn-cpdlc-template.c in the ATN-CPDLC dissector in Wireshark 1.12.x before 1.12.4 does not properly follow the TRY/ENDTRY code requirements, which allows remote attackers to cause a denial of service (stack memory corruption and application crash) via a crafted packet.

Record
CVE-2015-2187
Updated
2026-11-02
EUVDEUVD-2015-2294 No score

The dissect_atn_cpdlc_heur function in asn1/atn-cpdlc/packet-atn-cpdlc-template.c in the ATN-CPDLC dissector in Wireshark 1.12.x before 1.12.4 does not properly follow the TRY/ENDTRY code requirements, which allows remote attackers to cause a denial of service (stack memory corruption and application crash) via a crafted packet.

Record
EUVD-2015-2294
Updated
2026-11-03
GitHub AdvisoriesGHSA-wmr5-x9pv-7xf7 No score

The dissect_atn_cpdlc_heur function in asn1/atn-cpdlc/packet-atn-cpdlc-template.c in the ATN...

The dissect_atn_cpdlc_heur function in asn1/atn-cpdlc/packet-atn-cpdlc-template.c in the ATN-CPDLC dissector in Wireshark 1.12.x before 1.12.4 does not properly follow the TRY/ENDTRY code requirements, which allows remote attackers to cause a denial of service (stack memory corruption and application crash) via a crafted packet.

Record
GHSA-wmr5-x9pv-7xf7
Weakness
CWE-20
Updated
2026-11-02
OSV No score

The dissect_atn_cpdlc_heur function in asn1/atn-cpdlc/packet-atn-cpdlc-template.c in the ATN-CPDLC dissector in Wireshark 1.12.x before 1.12.4 does not properly follow the TRY/ENDTRY code requirements, which allows remote attackers to cause a denial of service (stack memory corruption and application crash) via a crafted packet.

Record
CVE-2015-2187
Updated
2026-11-02
OSVDEBIAN-CVE-2015-2187 No score

The dissect_atn_cpdlc_heur function in asn1/atn-cpdlc/packet-atn-cpdlc-template.c in the ATN-CPDLC dissector in Wireshark 1.12.x before 1.12.4 does not properly follow the TRY/ENDTRY code requirements, which allows remote attackers to cause a denial of service (stack memory corruption and application crash) via a crafted packet.

Record
DEBIAN-CVE-2015-2187
Updated
2026-11-02
OSVopenSUSE-SU-2024:10199-1 No score

wireshark-2.2.2-1.1 on GA media

These are all security issues fixed in the wireshark-2.2.2-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10199-1
Updated
2026-11-02
OSVUBUNTU-CVE-2015-2187 No score

The dissect_atn_cpdlc_heur function in asn1/atn-cpdlc/packet-atn-cpdlc-template.c in the ATN-CPDLC dissector in Wireshark 1.12.x before 1.12.4 does not properly follow the TRY/ENDTRY code requirements, which allows remote attackers to cause a denial of service (stack memory corruption and application crash) via a crafted packet.

Record
UBUNTU-CVE-2015-2187
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wireshark
Debian:12
before 1.12.1+g01b65bf-4
1.12.1+g01b65bf-4
wireshark
Debian:13
before 1.12.1+g01b65bf-4
1.12.1+g01b65bf-4
wireshark
Debian:14
before 1.12.1+g01b65bf-4
1.12.1+g01b65bf-4
wireshark
openSUSE:Tumbleweed
before 2.2.2-1.1
2.2.2-1.1

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-2187 is a medium vulnerability (CVSS 5.0) in Wireshark, published March 8, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.62%, the 85th percentile. Fixed in wireshark 1.12.1+g01b65bf-4.

References

Show 194 moreShow less
This page doesn't list everything

Left out here: 75 references. The JSON record has them.

MoveEnter Open