Every CVE Search/ Get API key

CVE-2015-3226

activesupport Cross-site Scripting vulnerability

4.3 MediumFix available

Cross-site scripting (XSS) vulnerability in json/encoding.rb in Active Support in Ruby on Rails 3.x and 4.1.x before 4.1.11 and 4.2.x before 4.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted Hash that is mishandled during JSON encoding.

Exploit likelihood

2.76%Up 1.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in json/encoding.rb in Active Support in Ruby on Rails 3.x and 4.1.x before 4.1.11 and 4.2.x before 4.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted Hash that is mishandled during JSON encoding.

Record
CVE-2015-3226
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in json/encoding.rb in Active Support in Ruby on Rails 3.x and 4.1.x before 4.1.11 and 4.2.x before 4.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted Hash that is mishandled during JSON encoding.

Record
CVE-2015-3226
Updated
2026-11-02
EUVDEUVD-2017-0317 No score

Cross-site scripting (XSS) vulnerability in json/encoding.rb in Active Support in Ruby on Rails 3.x and 4.1.x before 4.1.11 and 4.2.x before 4.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted Hash that is mishandled during JSON encoding.

Record
EUVD-2017-0317
Updated
2026-11-03
GitHub AdvisoriesGHSA-vxvp-4xwc-jpp6 No score

activesupport Cross-site Scripting vulnerability

Cross-site scripting (XSS) vulnerability in json/encoding.rb in Active Support in Ruby on Rails 4.1.x before 4.1.11 and 4.2.x before 4.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted Hash that is mishandled during JSON encoding.

Record
GHSA-vxvp-4xwc-jpp6
Weakness
CWE-79
Updated
2026-11-02
OSV No score

Cross-site scripting (XSS) vulnerability in json/encoding.rb in Active Support in Ruby on Rails 3.x and 4.1.x before 4.1.11 and 4.2.x before 4.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted Hash that is mishandled during JSON encoding.

Record
CVE-2015-3226
Updated
2026-11-02
OSVDEBIAN-CVE-2015-3226 No score

Cross-site scripting (XSS) vulnerability in json/encoding.rb in Active Support in Ruby on Rails 3.x and 4.1.x before 4.1.11 and 4.2.x before 4.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted Hash that is mishandled during JSON encoding.

Record
DEBIAN-CVE-2015-3226
Updated
2026-11-02
Show 4 moreShow less
OSVGHSA-vxvp-4xwc-jpp6 No score

activesupport Cross-site Scripting vulnerability

Cross-site scripting (XSS) vulnerability in json/encoding.rb in Active Support in Ruby on Rails 4.1.x before 4.1.11 and 4.2.x before 4.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted Hash that is mishandled during JSON encoding.

Record
GHSA-vxvp-4xwc-jpp6
Weakness
CWE-79
Updated
2026-11-02
OSVopenSUSE-SU-2024:10574-1 No score

ruby2.2-rubygem-activesupport-4_2-4.2.7.1-1.1 on GA media

These are all security issues fixed in the ruby2.2-rubygem-activesupport-4_2-4.2.7.1-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10574-1
Updated
2026-11-02
OSVSUSE-SU-2016:0082-1 No score

Security update for rubygem-activesupport-4_1

This update fixes the following security issues:

  • CVE-2015-3227: Possible Denial of Service attack in Active Support (bnc#934800)

  • CVE-2015-3226: XSS Vulnerability in ActiveSupport::JSON (bnc#934799)

Record
SUSE-SU-2016:0082-1
Updated
2026-11-02
OSVUBUNTU-CVE-2015-3226 No score

Cross-site scripting (XSS) vulnerability in json/encoding.rb in Active Support in Ruby on Rails 3.x and 4.1.x before 4.1.11 and 4.2.x before 4.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted Hash that is mishandled during JSON encoding.

Record
UBUNTU-CVE-2015-3226
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
activesupport
RubyGems
4.1.0 up to 4.1.11
4.1.11
activesupport
RubyGems
4.2.0 up to 4.2.2
4.2.2
rails
Debian:12
before 2:4.2.4-2
2:4.2.4-2
rails
Debian:13
before 2:4.2.4-2
2:4.2.4-2
rails
Debian:14
before 2:4.2.4-2
2:4.2.4-2
rails
Debian:8
From an advisory covering 8 CVEs
before 2:4.1.8-1+deb8u1, plus listed versions
2:4.1.8-1
2:4.1.8-1+deb8u1
activesupport
RubyGems
4.1.0 up to 4.1.11, plus listed versions
4.1.14.1.104.1.10.rc14.1.10.rc24.1.10.rc3
Show 16 moreShow less
4.1.10.rc44.1.24.1.2.rc14.1.2.rc24.1.2.rc34.1.34.1.44.1.54.1.64.1.6.rc14.1.6.rc24.1.74.1.7.14.1.84.1.94.1.9.rc1
4.1.11
activesupport
RubyGems
4.2.0 up to 4.2.2, plus listed versions
4.2.14.2.1.rc14.2.1.rc24.2.1.rc34.2.1.rc4
4.2.2
rubygem-activesupport-4_1
SUSE:OpenStack Cloud 5
From an advisory covering 2 CVEs
before 4.1.9-9.2
4.1.9-9.2
rubygem-activesupport-4_2
openSUSE:Tumbleweed
From an advisory covering 2 CVEs
before 5.0.0.1-1.1
5.0.0.1-1.1

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-3226 is a medium vulnerability (CVSS 4.3) in Rubyonrails Rails, published July 26, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.76%, the 86th percentile. Fixed in activesupport 4.1.11.

References

Show 13 moreShow less
MoveEnter Open