CVE-2015-3226
activesupport Cross-site Scripting vulnerability
Cross-site scripting (XSS) vulnerability in json/encoding.rb in Active Support in Ruby on Rails 3.x and 4.1.x before 4.1.11 and 4.2.x before 4.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted Hash that is mishandled during JSON encoding.
Exploit likelihood
What each source reports
NVD Score used
4.3
Cross-site scripting (XSS) vulnerability in json/encoding.rb in Active Support in Ruby on Rails 3.x and 4.1.x before 4.1.11 and 4.2.x before 4.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted Hash that is mishandled during JSON encoding.
- Record
CVE-2015-3226- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in json/encoding.rb in Active Support in Ruby on Rails 3.x and 4.1.x before 4.1.11 and 4.2.x before 4.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted Hash that is mishandled during JSON encoding.
- Record
CVE-2015-3226- Updated
- 2026-11-02
EUVDEUVD-2017-0317 No score
Cross-site scripting (XSS) vulnerability in json/encoding.rb in Active Support in Ruby on Rails 3.x and 4.1.x before 4.1.11 and 4.2.x before 4.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted Hash that is mishandled during JSON encoding.
- Record
EUVD-2017-0317- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-vxvp-4xwc-jpp6 No score
activesupport Cross-site Scripting vulnerability
Cross-site scripting (XSS) vulnerability in json/encoding.rb in Active Support in Ruby on Rails 4.1.x before 4.1.11 and 4.2.x before 4.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted Hash that is mishandled during JSON encoding.
- Record
GHSA-vxvp-4xwc-jpp6- Weakness
- CWE-79
- Updated
- 2026-11-02
OSV No score
Cross-site scripting (XSS) vulnerability in json/encoding.rb in Active Support in Ruby on Rails 3.x and 4.1.x before 4.1.11 and 4.2.x before 4.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted Hash that is mishandled during JSON encoding.
- Record
CVE-2015-3226- Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-3226 No score
Cross-site scripting (XSS) vulnerability in json/encoding.rb in Active Support in Ruby on Rails 3.x and 4.1.x before 4.1.11 and 4.2.x before 4.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted Hash that is mishandled during JSON encoding.
- Record
DEBIAN-CVE-2015-3226- Updated
- 2026-11-02
Show 4 moreShow less
OSVGHSA-vxvp-4xwc-jpp6 No score
activesupport Cross-site Scripting vulnerability
Cross-site scripting (XSS) vulnerability in json/encoding.rb in Active Support in Ruby on Rails 4.1.x before 4.1.11 and 4.2.x before 4.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted Hash that is mishandled during JSON encoding.
- Record
GHSA-vxvp-4xwc-jpp6- Weakness
- CWE-79
- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10574-1 No score
ruby2.2-rubygem-activesupport-4_2-4.2.7.1-1.1 on GA media
These are all security issues fixed in the ruby2.2-rubygem-activesupport-4_2-4.2.7.1-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10574-1- Updated
- 2026-11-02
OSVSUSE-SU-2016:0082-1 No score
Security update for rubygem-activesupport-4_1
This update fixes the following security issues:
-
CVE-2015-3227: Possible Denial of Service attack in Active Support (bnc#934800)
-
CVE-2015-3226: XSS Vulnerability in ActiveSupport::JSON (bnc#934799)
- Record
SUSE-SU-2016:0082-1- Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-3226 No score
Cross-site scripting (XSS) vulnerability in json/encoding.rb in Active Support in Ruby on Rails 3.x and 4.1.x before 4.1.11 and 4.2.x before 4.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted Hash that is mishandled during JSON encoding.
- Record
UBUNTU-CVE-2015-3226- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
activesupportRubyGems |
4.1.0 up to 4.1.11 | 4.1.11 |
activesupportRubyGems |
4.2.0 up to 4.2.2 | 4.2.2 |
railsDebian:12 |
before 2:4.2.4-2 | 2:4.2.4-2 |
railsDebian:13 |
before 2:4.2.4-2 | 2:4.2.4-2 |
railsDebian:14 |
before 2:4.2.4-2 | 2:4.2.4-2 |
railsDebian:8 From an advisory covering 8 CVEs |
before 2:4.1.8-1+deb8u1, plus listed versions 2:4.1.8-1 |
2:4.1.8-1+deb8u1 |
activesupportRubyGems |
4.1.0 up to 4.1.11, plus listed versions 4.1.14.1.104.1.10.rc14.1.10.rc24.1.10.rc3 Show 16 moreShow less4.1.10.rc44.1.24.1.2.rc14.1.2.rc24.1.2.rc34.1.34.1.44.1.54.1.64.1.6.rc14.1.6.rc24.1.74.1.7.14.1.84.1.94.1.9.rc1 |
4.1.11 |
activesupportRubyGems |
4.2.0 up to 4.2.2, plus listed versions 4.2.14.2.1.rc14.2.1.rc24.2.1.rc34.2.1.rc4 |
4.2.2 |
rubygem-activesupport-4_1SUSE:OpenStack Cloud 5 From an advisory covering 2 CVEs |
before 4.1.9-9.2 | 4.1.9-9.2 |
rubygem-activesupport-4_2openSUSE:Tumbleweed From an advisory covering 2 CVEs |
before 5.0.0.1-1.1 | 5.0.0.1-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-3226 is a medium vulnerability (CVSS 4.3) in Rubyonrails Rails, published July 26, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.76%, the 86th percentile. Fixed in activesupport 4.1.11.
References
securitytracker.com/id/1033755
groups.google.com/forum/message/raw?msg=rubyonrails-security/7VlB_pck3hU/3QZrGIaQW6cJ
securityfocus.com/bid/75231
openwall.com/lists/oss-security/2015/06/16/17
debian.org/security/2016/dsa-3464
nvd.nist.gov/vuln/detail/CVE-2015-3226
Show 13 moreShow less
web.archive.org/web/20200228033946/http://www.securityfocus.com/bid/75231
web.archive.org/web/20200517005133/http://www.securitytracker.com/id/1033755
groups.google.com/g/rubyonrails-core/c/qBUqVlXERag/m/kuH3wQk1kxUJ
github.com/advisories/GHSA-vxvp-4xwc-jpp6
security-tracker.debian.org/tracker/CVE-2015-3226
github.com/rails/rails
suse.com/support/update/announcement/2016/suse-su-20160082-1
bugzilla.suse.com/934799
bugzilla.suse.com/934800
suse.com/security/cve/CVE-2015-3226
suse.com/security/cve/CVE-2015-3227
ubuntu.com/security/CVE-2015-3226
cve.org/CVERecord?id=CVE-2015-3226