Every CVE Search/ Get API key

CVE-2015-3308

Double free vulnerability in lib/x509/x509_ext.c in GnuTLS before 3.3.14 allows remote attackers...

7.5 HighFix available

Double free vulnerability in lib/x509/x509_ext.c in GnuTLS before 3.3.14 allows remote attackers to cause a denial of service or possibly have unspecified other impact via a crafted CRL distribution point.

Exploit likelihood

3.92%Up 1.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Double free vulnerability in lib/x509/x509_ext.c in GnuTLS before 3.3.14 allows remote attackers to cause a denial of service or possibly have unspecified other impact via a crafted CRL distribution point.

Record
CVE-2015-3308
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Double free vulnerability in lib/x509/x509_ext.c in GnuTLS before 3.3.14 allows remote attackers to cause a denial of service or possibly have unspecified other impact via a crafted CRL distribution point.

Record
CVE-2015-3308
Updated
2026-11-02
EUVDEUVD-2015-3354 No score

Double free vulnerability in lib/x509/x509_ext.c in GnuTLS before 3.3.14 allows remote attackers to cause a denial of service or possibly have unspecified other impact via a crafted CRL distribution point.

Record
EUVD-2015-3354
Updated
2026-11-03
GitHub AdvisoriesGHSA-f5vv-qq78-r728 No score

Double free vulnerability in lib/x509/x509_ext.c in GnuTLS before 3.3.14 allows remote attackers...

Double free vulnerability in lib/x509/x509_ext.c in GnuTLS before 3.3.14 allows remote attackers to cause a denial of service or possibly have unspecified other impact via a crafted CRL distribution point.

Record
GHSA-f5vv-qq78-r728
Updated
2026-11-02
OSV No score

Double free vulnerability in lib/x509/x509_ext.c in GnuTLS before 3.3.14 allows remote attackers to cause a denial of service or possibly have unspecified other impact via a crafted CRL distribution point.

Record
CVE-2015-3308
Updated
2026-11-02
OSVDEBIAN-CVE-2015-3308 No score

Double free vulnerability in lib/x509/x509_ext.c in GnuTLS before 3.3.14 allows remote attackers to cause a denial of service or possibly have unspecified other impact via a crafted CRL distribution point.

Record
DEBIAN-CVE-2015-3308
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gnutls28
Debian:12
before 3.3.8-7
3.3.8-7
gnutls28
Debian:13
before 3.3.8-7
3.3.8-7
gnutls28
Debian:14
before 3.3.8-7
3.3.8-7

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-3308 is a high vulnerability (CVSS 7.5) in Gnu Gnutls, published September 2, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.92%, the 90th percentile. Fixed in gnutls28 3.3.8-7.

References

Show 7 moreShow less
MoveEnter Open