Every CVE Search/ Get API key

CVE-2015-3440

Cross-site scripting (XSS) vulnerability in wp-includes/wp-db.php in WordPress before 4.2.1...

4.3 MediumPublic exploitFix available

Cross-site scripting (XSS) vulnerability in wp-includes/wp-db.php in WordPress before 4.2.1 allows remote attackers to inject arbitrary web script or HTML via a long comment that is improperly stored because of limitations on the MySQL TEXT data type.

Exploit likelihood

16.9%Down 2.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in wp-includes/wp-db.php in WordPress before 4.2.1 allows remote attackers to inject arbitrary web script or HTML via a long comment that is improperly stored because of limitations on the MySQL TEXT data type.

Record
CVE-2015-3440
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in wp-includes/wp-db.php in WordPress before 4.2.1 allows remote attackers to inject arbitrary web script or HTML via a long comment that is improperly stored because of limitations on the MySQL TEXT data type.

Record
CVE-2015-3440
Updated
2026-11-02
EUVDEUVD-2015-3484 No score

Cross-site scripting (XSS) vulnerability in wp-includes/wp-db.php in WordPress before 4.2.1 allows remote attackers to inject arbitrary web script or HTML via a long comment that is improperly stored because of limitations on the MySQL TEXT data type.

Record
EUVD-2015-3484
Updated
2026-11-03
GitHub AdvisoriesGHSA-xg6f-394q-j4f9 No score

Cross-site scripting (XSS) vulnerability in wp-includes/wp-db.php in WordPress before 4.2.1...

Cross-site scripting (XSS) vulnerability in wp-includes/wp-db.php in WordPress before 4.2.1 allows remote attackers to inject arbitrary web script or HTML via a long comment that is improperly stored because of limitations on the MySQL TEXT data type.

Record
GHSA-xg6f-394q-j4f9
Weakness
CWE-79
Updated
2026-11-02
OSV No score

Cross-site scripting (XSS) vulnerability in wp-includes/wp-db.php in WordPress before 4.2.1 allows remote attackers to inject arbitrary web script or HTML via a long comment that is improperly stored because of limitations on the MySQL TEXT data type.

Record
CVE-2015-3440
Updated
2026-11-02
OSVDEBIAN-CVE-2015-3440 No score

Cross-site scripting (XSS) vulnerability in wp-includes/wp-db.php in WordPress before 4.2.1 allows remote attackers to inject arbitrary web script or HTML via a long comment that is improperly stored because of limitations on the MySQL TEXT data type.

Record
DEBIAN-CVE-2015-3440
Updated
2026-11-02
OSVMGASA-2015-0202 No score

Updated wordpress packages fix security vulnerabilities

Updated wordpress packages fixes security vulnerabilities:

The wordpress package has been updated to version 3.9.6, which fixes multiple cross-site scripting issues, including CVE-2015-3440, and other bugs.

Note that upstream has advised us that WordPress 3.9.x is no longer supported. As this package is unmaintained, this may be the last update for this package. Downloading the latest version from upstream and using that, as well as making use of its aut-update capability, may be preferrable to using this package.

Record
MGASA-2015-0202
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wordpress
Debian:12
before 4.2.1+dfsg-1
4.2.1+dfsg-1
wordpress
Debian:13
before 4.2.1+dfsg-1
4.2.1+dfsg-1
wordpress
Debian:14
before 4.2.1+dfsg-1
4.2.1+dfsg-1
wordpress
Debian:6.0
before 3.6.1+dfsg-1~deb6u6, plus listed versions
3.0.4+dfsg-13.0.5+dfsg-0+squeeze13.0.5+dfsg-13.2.1+dfsg-13.2.1+dfsg-2
Show 22 moreShow less
3.2.1+dfsg-33.3+dfsg-13.3.1+dfsg-13.3.2+dfsg-13.3.2+dfsg-1~squeeze13.4+dfsg-13.4+dfsg-23.4+dfsg-33.4.1+dfsg-13.4.2+dfsg-13.5+dfsg-13.5.1+dfsg-13.5.1+dfsg-23.5.2+dfsg-13.5.2+dfsg-1~deb6u13.5.2+dfsg-1~deb7u13.6+dfsg-13.6.1+dfsg-1~deb6u13.6.1+dfsg-1~deb6u23.6.1+dfsg-1~deb6u33.6.1+dfsg-1~deb6u43.6.1+dfsg-1~deb6u5
3.6.1+dfsg-1~deb6u6
wordpress
Debian:7
before 3.6.1+dfsg-1~deb7u6, plus listed versions
3.5.1+dfsg-23.5.2+dfsg-13.5.2+dfsg-1~deb6u13.5.2+dfsg-1~deb7u13.6+dfsg-1
Show 14 moreShow less
3.6.1+dfsg-1~deb6u13.6.1+dfsg-1~deb6u23.6.1+dfsg-1~deb6u33.6.1+dfsg-1~deb6u43.6.1+dfsg-1~deb6u53.6.1+dfsg-1~deb6u63.6.1+dfsg-1~deb6u73.6.1+dfsg-1~deb6u83.6.1+dfsg-1~deb6u93.6.1+dfsg-1~deb7u13.6.1+dfsg-1~deb7u23.6.1+dfsg-1~deb7u33.6.1+dfsg-1~deb7u43.6.1+dfsg-1~deb7u5
3.6.1+dfsg-1~deb7u6
wordpress
Debian:8
before 4.1+dfsg-1+deb8u1, plus listed versions
4.1+dfsg-1
4.1+dfsg-1+deb8u1
wordpress
Mageia:4
before 3.9.6-1.mga4
3.9.6-1.mga4

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBWordPress Core 4.2 - Persistent Cross-Site Scripting2015-04-27

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-3440 is a medium vulnerability (CVSS 4.3) in Wordpress, published May 4, 2015. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 16.9%, the 97th percentile. Fixed in wordpress 4.2.1+dfsg-1.

References

Show 16 moreShow less
MoveEnter Open