CVE-2014-9031
Cross-site scripting (XSS) vulnerability in the wptexturize function in WordPress before 3.7.5, 3...
Cross-site scripting (XSS) vulnerability in the wptexturize function in WordPress before 3.7.5, 3.8.x before 3.8.5, and 3.9.x before 3.9.3 allows remote attackers to inject arbitrary web script or HTML via crafted use of shortcode brackets in a text field, as demonstrated by a comment or a post.
Exploit likelihood
What each source reports
NVD Score used
4.3
Cross-site scripting (XSS) vulnerability in the wptexturize function in WordPress before 3.7.5, 3.8.x before 3.8.5, and 3.9.x before 3.9.3 allows remote attackers to inject arbitrary web script or HTML via crafted use of shortcode brackets in a text field, as demonstrated by a comment or a post.
- Record
CVE-2014-9031- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in the wptexturize function in WordPress before 3.7.5, 3.8.x before 3.8.5, and 3.9.x before 3.9.3 allows remote attackers to inject arbitrary web script or HTML via crafted use of shortcode brackets in a text field, as demonstrated by a comment or a post.
- Record
CVE-2014-9031- Updated
- 2026-11-02
EUVDEUVD-2014-8859 No score
Cross-site scripting (XSS) vulnerability in the wptexturize function in WordPress before 3.7.5, 3.8.x before 3.8.5, and 3.9.x before 3.9.3 allows remote attackers to inject arbitrary web script or HTML via crafted use of shortcode brackets in a text field, as demonstrated by a comment or a post.
- Record
EUVD-2014-8859- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-66rv-hwf5-7jr5 No score
Cross-site scripting (XSS) vulnerability in the wptexturize function in WordPress before 3.7.5, 3...
Cross-site scripting (XSS) vulnerability in the wptexturize function in WordPress before 3.7.5, 3.8.x before 3.8.5, and 3.9.x before 3.9.3 allows remote attackers to inject arbitrary web script or HTML via crafted use of shortcode brackets in a text field, as demonstrated by a comment or a post.
- Record
GHSA-66rv-hwf5-7jr5- Weakness
- CWE-79
- Updated
- 2026-11-02
OSV No score
Cross-site scripting (XSS) vulnerability in the wptexturize function in WordPress before 3.7.5, 3.8.x before 3.8.5, and 3.9.x before 3.9.3 allows remote attackers to inject arbitrary web script or HTML via crafted use of shortcode brackets in a text field, as demonstrated by a comment or a post.
- Record
CVE-2014-9031- Updated
- 2026-11-02
OSVDEBIAN-CVE-2014-9031 No score
Cross-site scripting (XSS) vulnerability in the wptexturize function in WordPress before 3.7.5, 3.8.x before 3.8.5, and 3.9.x before 3.9.3 allows remote attackers to inject arbitrary web script or HTML via crafted use of shortcode brackets in a text field, as demonstrated by a comment or a post.
- Record
DEBIAN-CVE-2014-9031- Updated
- 2026-11-02
OSVMGASA-2014-0493 No score
Updated wordpress package fixes security vulnerabilities
XSS in wptexturize() via comments or posts, exploitable for unauthenticated users (CVE-2014-9031).
XSS in media playlists (CVE-2014-9032).
CSRF in the password reset process (CVE-2014-9033).
Denial of service for giant passwords. The phpass library by Solar Designer was used in both projects without setting a maximum password length, which can lead to CPU exhaustion upon hashing (CVE-2014-9034).
XSS in Press This (CVE-2014-9035).
XSS in HTML filtering of CSS in posts (CVE-2014-9036).
Hash comparison vulnerability in old-style MD5-stored passwords (CVE-2014-9037).
SSRF: Safe HTTP requests did not sufficiently block the loopback IP address space (CVE-2014-9038).
Previously an email address change would not invalidate a previous password reset email (CVE-2014-9039).
- Record
MGASA-2014-0493- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
wordpressDebian:12 |
before 4.0.1+dfsg-1 | 4.0.1+dfsg-1 |
wordpressDebian:13 |
before 4.0.1+dfsg-1 | 4.0.1+dfsg-1 |
wordpressDebian:14 |
before 4.0.1+dfsg-1 | 4.0.1+dfsg-1 |
wordpressDebian:6.0 |
before 3.6.1+dfsg-1~deb6u6, plus listed versions 3.0.4+dfsg-13.0.5+dfsg-0+squeeze13.0.5+dfsg-13.2.1+dfsg-13.2.1+dfsg-2 Show 22 moreShow less3.2.1+dfsg-33.3+dfsg-13.3.1+dfsg-13.3.2+dfsg-13.3.2+dfsg-1~squeeze13.4+dfsg-13.4+dfsg-23.4+dfsg-33.4.1+dfsg-13.4.2+dfsg-13.5+dfsg-13.5.1+dfsg-13.5.1+dfsg-23.5.2+dfsg-13.5.2+dfsg-1~deb6u13.5.2+dfsg-1~deb7u13.6+dfsg-13.6.1+dfsg-1~deb6u13.6.1+dfsg-1~deb6u23.6.1+dfsg-1~deb6u33.6.1+dfsg-1~deb6u43.6.1+dfsg-1~deb6u5 |
3.6.1+dfsg-1~deb6u6 |
wordpressDebian:7 |
before 3.6.1+dfsg-1~deb7u5, plus listed versions 3.5.1+dfsg-23.5.2+dfsg-13.5.2+dfsg-1~deb6u13.5.2+dfsg-1~deb7u13.6+dfsg-1 Show 13 moreShow less3.6.1+dfsg-1~deb6u13.6.1+dfsg-1~deb6u23.6.1+dfsg-1~deb6u33.6.1+dfsg-1~deb6u43.6.1+dfsg-1~deb6u53.6.1+dfsg-1~deb6u63.6.1+dfsg-1~deb6u73.6.1+dfsg-1~deb6u83.6.1+dfsg-1~deb6u93.6.1+dfsg-1~deb7u13.6.1+dfsg-1~deb7u23.6.1+dfsg-1~deb7u33.6.1+dfsg-1~deb7u4 |
3.6.1+dfsg-1~deb7u5 |
wordpressMageia:3 |
before 3.9.3-1.mga3 | 3.9.3-1.mga3 |
wordpressMageia:4 |
before 3.9.3-1.mga4 | 3.9.3-1.mga4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-9031 is a medium vulnerability (CVSS 4.3) in Wordpress, published November 25, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.16%, the 92nd percentile. Fixed in wordpress 4.0.1+dfsg-1.
References
seclists.org/fulldisclosure/2014/Nov/62
debian.org/security/2014/dsa-3085
openwall.com/lists/oss-security/2014/11/25/12
advisories.mageia.org/MGASA-2014-0493.html
klikki.fi/adv/wordpress.html
securitytracker.com/id/1031243