Every CVE Search/ Get API key

CVE-2015-5264

Moodle allows attackers to enter additional answer attempts

5.4 MediumFix available

The lesson module in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 allows remote authenticated users to bypass intended access restrictions and enter additional answer attempts by leveraging the student role.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.40%Up 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.4

The lesson module in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 allows remote authenticated users to bypass intended access restrictions and enter additional answer attempts by leveraging the student role.

Record
CVE-2015-5264
CVSS 3.0
5.4 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
CVSS 2.0
5.5 MediumAV:N/AC:L/Au:S/C:P/I:P/A:N
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

The lesson module in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 allows remote authenticated users to bypass intended access restrictions and enter additional answer attempts by leveraging the student role.

Record
CVE-2015-5264
Updated
2026-11-02
EUVDEUVD-2022-4589 No score

The lesson module in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 allows remote authenticated users to bypass intended access restrictions and enter additional answer attempts by leveraging the student role.

Record
EUVD-2022-4589
Updated
2026-11-03
GitHub AdvisoriesGHSA-mm9q-3847-m48x 5.4

Moodle allows attackers to enter additional answer attempts

The lesson module in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 allows remote authenticated users to bypass intended access restrictions and enter additional answer attempts by leveraging the student role.

Record
GHSA-mm9q-3847-m48x
CVSS 3.0
5.4 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-mm9q-3847-m48x 5.4

Moodle allows attackers to enter additional answer attempts

The lesson module in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 allows remote authenticated users to bypass intended access restrictions and enter additional answer attempts by leveraging the student role.

Record
GHSA-mm9q-3847-m48x
CVSS 3.0
5.4 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2015-5264 5.4

The lesson module in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 allows remote authenticated users to bypass intended access restrictions and enter additional answer attempts by leveraging the student role.

Record
UBUNTU-CVE-2015-5264
CVSS 3.0
5.4 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Updated
2026-11-02
OSVMGASA-2015-0381 No score

Updated moodle packages fix security vulnerabilities

Updated moodle package fixes security vulnerabilities:

In Moodle before 2.8.8, completed and graded lesson activity was not protected against making new attempts to answer some questions, so students could re-attempt answering questions in the lesson (CVE-2015-5264).

In Moodle before 2.8.8, users could delete files uploaded by other users in wiki (CVE-2015-5265).

In Moodle before 2.8.8, meta course synchronisation enrols suspended students as managers for a short period of time and causes large database growth. On large installations, when the sync script takes a long time, suspended students may get assigned a manager role in meta course for several minutes (CVE-2015-5266)

In Moodle before 2.8.8, password recovery tokens can be guessed because of php randomisation limitations (CVE-2015-5267).

In Moodle before 2.8.8, when viewing ratings, the group access was not properly checked, allowing users from other groups to view ratings (CVE-2015-5268).

In Moodle before 2.8.8, capability to manage groups does not have XSS risk, however it was possible to add XSS to the grouping description (CVE-2015-5269).

The moodle package has been updated to version 2.8.8, fixing these issues and several other bugs.

Additionally, the preg plugin has been updated to version 2.8, and the OU Multiple Response question type and UIkit theme have been added to the package.

Record
MGASA-2015-0381
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
2.7.0 up to 2.7.10
2.7.10
moodle/moodle
Packagist
2.8.0 up to 2.8.8
2.8.8
moodle/moodle
Packagist
2.9.0 up to 2.9.2
2.9.2
moodle/moodle
Packagist
2.7.0 up to 2.7.10, plus listed versions
v2.7.0v2.7.1v2.7.2v2.7.3v2.7.4
Show 5 moreShow less
v2.7.5v2.7.6v2.7.7v2.7.8v2.7.9
2.7.10
moodle/moodle
Packagist
2.8.0 up to 2.8.8, plus listed versions
v2.8.0v2.8.1v2.8.2v2.8.3v2.8.4v2.8.5v2.8.6v2.8.7
2.8.8
moodle/moodle
Packagist
2.9.0 up to 2.9.2, plus listed versions
v2.9.0v2.9.1
2.9.2
moodle
Mageia:5
From an advisory covering 6 CVEs
before 2.8.8-1.mga5
2.8.8-1.mga5

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-5264 is a medium vulnerability (CVSS 5.4) in Moodle, published September 23, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.40%, the 72nd percentile. Fixed in moodle/moodle 2.7.10.

References

Show 26 moreShow less
MoveEnter Open