CVE-2015-5265
Moodle allows attackers to delete files
The wiki component in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 does not consider the mod/wiki:managefiles capability before authorizing file management, which allows remote authenticated users to delete arbitrary files by using a manage-files button in a text editor.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
4.3
The wiki component in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 does not consider the mod/wiki:managefiles capability before authorizing file management, which allows remote authenticated users to delete arbitrary files by using a manage-files button in a text editor.
- Record
CVE-2015-5265- CVSS 3.0
- 4.3 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N - CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:N/I:P/A:N - Weakness
- CWE-264
- Updated
- 2026-11-02
CVE List No score
The wiki component in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 does not consider the mod/wiki:managefiles capability before authorizing file management, which allows remote authenticated users to delete arbitrary files by using a manage-files button in a text editor.
- Record
CVE-2015-5265- Updated
- 2026-11-02
EUVDEUVD-2022-2300 No score
The wiki component in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 does not consider the mod/wiki:managefiles capability before authorizing file management, which allows remote authenticated users to delete arbitrary files by using a manage-files button in a text editor.
- Record
EUVD-2022-2300- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-44xp-wj24-9xxj
4.3
Moodle allows attackers to delete files
The wiki component in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 does not consider the mod/wiki:managefiles capability before authorizing file management, which allows remote authenticated users to delete arbitrary files by using a manage-files button in a text editor.
- Record
GHSA-44xp-wj24-9xxj- CVSS 3.0
- 4.3 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-44xp-wj24-9xxj
4.3
Moodle allows attackers to delete files
The wiki component in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 does not consider the mod/wiki:managefiles capability before authorizing file management, which allows remote authenticated users to delete arbitrary files by using a manage-files button in a text editor.
- Record
GHSA-44xp-wj24-9xxj- CVSS 3.0
- 4.3 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-5265
4.3
The wiki component in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 does not consider the mod/wiki:managefiles capability before authorizing file management, which allows remote authenticated users to delete arbitrary files by using a manage-files button in a text editor.
- Record
UBUNTU-CVE-2015-5265- CVSS 3.0
- 4.3 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N - Updated
- 2026-11-02
OSVMGASA-2015-0381 No score
Updated moodle packages fix security vulnerabilities
Updated moodle package fixes security vulnerabilities:
In Moodle before 2.8.8, completed and graded lesson activity was not protected against making new attempts to answer some questions, so students could re-attempt answering questions in the lesson (CVE-2015-5264).
In Moodle before 2.8.8, users could delete files uploaded by other users in wiki (CVE-2015-5265).
In Moodle before 2.8.8, meta course synchronisation enrols suspended students as managers for a short period of time and causes large database growth. On large installations, when the sync script takes a long time, suspended students may get assigned a manager role in meta course for several minutes (CVE-2015-5266)
In Moodle before 2.8.8, password recovery tokens can be guessed because of php randomisation limitations (CVE-2015-5267).
In Moodle before 2.8.8, when viewing ratings, the group access was not properly checked, allowing users from other groups to view ratings (CVE-2015-5268).
In Moodle before 2.8.8, capability to manage groups does not have XSS risk, however it was possible to add XSS to the grouping description (CVE-2015-5269).
The moodle package has been updated to version 2.8.8, fixing these issues and several other bugs.
Additionally, the preg plugin has been updated to version 2.8, and the OU Multiple Response question type and UIkit theme have been added to the package.
- Record
MGASA-2015-0381- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
2.7.0 up to 2.7.10 | 2.7.10 |
moodle/moodlePackagist |
2.8.0 up to 2.8.8 | 2.8.8 |
moodle/moodlePackagist |
2.9.0 up to 2.9.2 | 2.9.2 |
moodle/moodlePackagist |
2.7.0 up to 2.7.10, plus listed versions v2.7.0v2.7.1v2.7.2v2.7.3v2.7.4 Show 5 moreShow lessv2.7.5v2.7.6v2.7.7v2.7.8v2.7.9 |
2.7.10 |
moodle/moodlePackagist |
2.8.0 up to 2.8.8, plus listed versions v2.8.0v2.8.1v2.8.2v2.8.3v2.8.4v2.8.5v2.8.6v2.8.7 |
2.8.8 |
moodle/moodlePackagist |
2.9.0 up to 2.9.2, plus listed versions v2.9.0v2.9.1 |
2.9.2 |
moodleMageia:5 From an advisory covering 6 CVEs |
before 2.8.8-1.mga5 | 2.8.8-1.mga5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-5265 is a medium vulnerability (CVSS 4.3) in Moodle, published September 23, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.50%, the 74th percentile. Fixed in moodle/moodle 2.7.10.
References
git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-48371
openwall.com/lists/oss-security/2015/09/21/1
moodle.org/mod/forum/discuss.php?d=320289
securitytracker.com/id/1033619
nvd.nist.gov/vuln/detail/CVE-2015-5265
github.com/moodle/moodle/commit/037e05e8b266bff4835f0d2eea33ef86fb71d585
Show 20 moreShow less
github.com/moodle/moodle/commit/1d70050f33edb79b974de2509f18c943969589ea
github.com/moodle/moodle/commit/40a154551fcdf0b9ea906f4d1313df29754f1fa1
github.com/moodle/moodle/commit/78de2e86e8506222cf49b1cc6dc58467750ae83d
web.archive.org/web/20160323063809/http://www.securitytracker.com/id/1033619
github.com/advisories/GHSA-44xp-wj24-9xxj
github.com/moodle/moodle
advisories.mageia.org/MGASA-2015-0381.html
bugs.mageia.org/show_bug.cgi?id=16767
moodle.org/mod/forum/discuss.php?d=320287
moodle.org/mod/forum/discuss.php?d=320290
moodle.org/mod/forum/discuss.php?d=320291
moodle.org/mod/forum/discuss.php?d=320292
moodle.org/mod/forum/discuss.php?d=320293
docs.moodle.org/dev/Moodle_2.8.8_release_notes
moodle.org/mod/forum/discuss.php?d=319884
bitbucket.org/oasychev/moodle-plugins
moodle.org/plugins/view/qtype_oumultiresponse
moodle.org/plugins/view/theme_uikit
ubuntu.com/security/CVE-2015-5265
cve.org/CVERecord?id=CVE-2015-5265