CVE-2015-5266
Moodle allows attackers to obtain manager privileges
The enrol_meta_sync function in enrol/meta/locallib.php in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 allows remote authenticated users to obtain manager privileges in opportunistic circumstances by leveraging incorrect role processing during a long-running sync script.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.8
The enrol_meta_sync function in enrol/meta/locallib.php in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 allows remote authenticated users to obtain manager privileges in opportunistic circumstances by leveraging incorrect role processing during a long-running sync script.
- Record
CVE-2015-5266- CVSS 3.0
- 6.8 Medium
CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N - CVSS 2.0
- 4.9 Medium
AV:N/AC:M/Au:S/C:P/I:P/A:N - Weakness
- CWE-264
- Updated
- 2026-11-02
CVE List No score
The enrol_meta_sync function in enrol/meta/locallib.php in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 allows remote authenticated users to obtain manager privileges in opportunistic circumstances by leveraging incorrect role processing during a long-running sync script.
- Record
CVE-2015-5266- Updated
- 2026-11-02
EUVDEUVD-2022-2301 No score
The enrol_meta_sync function in enrol/meta/locallib.php in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 allows remote authenticated users to obtain manager privileges in opportunistic circumstances by leveraging incorrect role processing during a long-running sync script.
- Record
EUVD-2022-2301- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-454r-4cjv-vc9h
6.8
Moodle allows attackers to obtain manager privileges
The enrol_meta_sync function in enrol/meta/locallib.php in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 allows remote authenticated users to obtain manager privileges in opportunistic circumstances by leveraging incorrect role processing during a long-running sync script.
- Record
GHSA-454r-4cjv-vc9h- CVSS 3.0
- 6.8 Medium
CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N - Updated
- 2026-11-02
OSVGHSA-454r-4cjv-vc9h
6.8
Moodle allows attackers to obtain manager privileges
The enrol_meta_sync function in enrol/meta/locallib.php in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 allows remote authenticated users to obtain manager privileges in opportunistic circumstances by leveraging incorrect role processing during a long-running sync script.
- Record
GHSA-454r-4cjv-vc9h- CVSS 3.0
- 6.8 Medium
CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-5266
6.8
The enrol_meta_sync function in enrol/meta/locallib.php in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 allows remote authenticated users to obtain manager privileges in opportunistic circumstances by leveraging incorrect role processing during a long-running sync script.
- Record
UBUNTU-CVE-2015-5266- CVSS 3.0
- 6.8 Medium
CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N - Updated
- 2026-11-02
OSVMGASA-2015-0381 No score
Updated moodle packages fix security vulnerabilities
Updated moodle package fixes security vulnerabilities:
In Moodle before 2.8.8, completed and graded lesson activity was not protected against making new attempts to answer some questions, so students could re-attempt answering questions in the lesson (CVE-2015-5264).
In Moodle before 2.8.8, users could delete files uploaded by other users in wiki (CVE-2015-5265).
In Moodle before 2.8.8, meta course synchronisation enrols suspended students as managers for a short period of time and causes large database growth. On large installations, when the sync script takes a long time, suspended students may get assigned a manager role in meta course for several minutes (CVE-2015-5266)
In Moodle before 2.8.8, password recovery tokens can be guessed because of php randomisation limitations (CVE-2015-5267).
In Moodle before 2.8.8, when viewing ratings, the group access was not properly checked, allowing users from other groups to view ratings (CVE-2015-5268).
In Moodle before 2.8.8, capability to manage groups does not have XSS risk, however it was possible to add XSS to the grouping description (CVE-2015-5269).
The moodle package has been updated to version 2.8.8, fixing these issues and several other bugs.
Additionally, the preg plugin has been updated to version 2.8, and the OU Multiple Response question type and UIkit theme have been added to the package.
- Record
MGASA-2015-0381- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
2.7.0 up to 2.7.10 | 2.7.10 |
moodle/moodlePackagist |
2.8.0 up to 2.8.8 | 2.8.8 |
moodle/moodlePackagist |
2.9.0 up to 2.9.2 | 2.9.2 |
moodle/moodlePackagist |
2.7.0 up to 2.7.10, plus listed versions v2.7.0v2.7.1v2.7.2v2.7.3v2.7.4 Show 5 moreShow lessv2.7.5v2.7.6v2.7.7v2.7.8v2.7.9 |
2.7.10 |
moodle/moodlePackagist |
2.8.0 up to 2.8.8, plus listed versions v2.8.0v2.8.1v2.8.2v2.8.3v2.8.4v2.8.5v2.8.6v2.8.7 |
2.8.8 |
moodle/moodlePackagist |
2.9.0 up to 2.9.2, plus listed versions v2.9.0v2.9.1 |
2.9.2 |
moodleMageia:5 From an advisory covering 6 CVEs |
before 2.8.8-1.mga5 | 2.8.8-1.mga5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-5266 is a medium vulnerability (CVSS 6.8) in Moodle, published September 23, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.57%, the 75th percentile. Fixed in moodle/moodle 2.7.10.
References
git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-50744
moodle.org/mod/forum/discuss.php?d=320290
openwall.com/lists/oss-security/2015/09/21/1
securitytracker.com/id/1033619
nvd.nist.gov/vuln/detail/CVE-2015-5266
github.com/moodle/moodle/commit/936facab28d8d8bd03f38da42cb80fafba1a06db
Show 20 moreShow less
github.com/moodle/moodle/commit/ab006d43e48add8e5495141d4d750c1531772ca2
github.com/moodle/moodle/commit/dff6cdc88355f22ebaaf8f00c44a1ad51d272344
github.com/moodle/moodle/commit/f7fbc80766b72ed1c9915698edd443ee8f6eafbd
web.archive.org/web/20160323063809/http://www.securitytracker.com/id/1033619
github.com/advisories/GHSA-454r-4cjv-vc9h
github.com/moodle/moodle
advisories.mageia.org/MGASA-2015-0381.html
bugs.mageia.org/show_bug.cgi?id=16767
moodle.org/mod/forum/discuss.php?d=320287
moodle.org/mod/forum/discuss.php?d=320289
moodle.org/mod/forum/discuss.php?d=320291
moodle.org/mod/forum/discuss.php?d=320292
moodle.org/mod/forum/discuss.php?d=320293
docs.moodle.org/dev/Moodle_2.8.8_release_notes
moodle.org/mod/forum/discuss.php?d=319884
bitbucket.org/oasychev/moodle-plugins
moodle.org/plugins/view/qtype_oumultiresponse
moodle.org/plugins/view/theme_uikit
ubuntu.com/security/CVE-2015-5266
cve.org/CVERecord?id=CVE-2015-5266