Every CVE Search/ Get API key

CVE-2015-5268

Moodle mishandles group-based authorization checks

4.3 MediumFix available

The rating component in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 mishandles group-based authorization checks, which allows remote authenticated users to obtain sensitive information by reading a rating value.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
None

Exploit likelihood

1.58%Up 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

The rating component in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 mishandles group-based authorization checks, which allows remote authenticated users to obtain sensitive information by reading a rating value.

Record
CVE-2015-5268
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:P/I:N/A:N
Weakness
CWE-200, CWE-264
Updated
2026-11-02
CVE List No score

The rating component in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 mishandles group-based authorization checks, which allows remote authenticated users to obtain sensitive information by reading a rating value.

Record
CVE-2015-5268
Updated
2026-11-02
EUVDEUVD-2022-4048 No score

The rating component in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 mishandles group-based authorization checks, which allows remote authenticated users to obtain sensitive information by reading a rating value.

Record
EUVD-2022-4048
Updated
2026-11-03
GitHub AdvisoriesGHSA-h34c-px28-rjgw 4.3

Moodle mishandles group-based authorization checks

The rating component in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 mishandles group-based authorization checks, which allows remote authenticated users to obtain sensitive information by reading a rating value.

Record
GHSA-h34c-px28-rjgw
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
OSVGHSA-h34c-px28-rjgw 4.3

Moodle mishandles group-based authorization checks

The rating component in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 mishandles group-based authorization checks, which allows remote authenticated users to obtain sensitive information by reading a rating value.

Record
GHSA-h34c-px28-rjgw
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2015-5268 4.3

The rating component in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 mishandles group-based authorization checks, which allows remote authenticated users to obtain sensitive information by reading a rating value.

Record
UBUNTU-CVE-2015-5268
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
OSVMGASA-2015-0381 No score

Updated moodle packages fix security vulnerabilities

Updated moodle package fixes security vulnerabilities:

In Moodle before 2.8.8, completed and graded lesson activity was not protected against making new attempts to answer some questions, so students could re-attempt answering questions in the lesson (CVE-2015-5264).

In Moodle before 2.8.8, users could delete files uploaded by other users in wiki (CVE-2015-5265).

In Moodle before 2.8.8, meta course synchronisation enrols suspended students as managers for a short period of time and causes large database growth. On large installations, when the sync script takes a long time, suspended students may get assigned a manager role in meta course for several minutes (CVE-2015-5266)

In Moodle before 2.8.8, password recovery tokens can be guessed because of php randomisation limitations (CVE-2015-5267).

In Moodle before 2.8.8, when viewing ratings, the group access was not properly checked, allowing users from other groups to view ratings (CVE-2015-5268).

In Moodle before 2.8.8, capability to manage groups does not have XSS risk, however it was possible to add XSS to the grouping description (CVE-2015-5269).

The moodle package has been updated to version 2.8.8, fixing these issues and several other bugs.

Additionally, the preg plugin has been updated to version 2.8, and the OU Multiple Response question type and UIkit theme have been added to the package.

Record
MGASA-2015-0381
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
before 2.7.10
2.7.10
moodle/moodle
Packagist
2.8.0 up to 2.8.8
2.8.8
moodle/moodle
Packagist
2.9.0 up to 2.9.2
2.9.2
moodle/moodle
Packagist
before 2.7.10, plus listed versions
v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6
Show 45 moreShow less
v2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-betav2.6.0-rc1v2.6.1v2.6.10v2.6.11v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.6.7v2.6.8v2.6.9v2.7.0v2.7.0-betav2.7.0-rc1
2.7.10
moodle/moodle
Packagist
2.8.0 up to 2.8.8, plus listed versions
v2.8.0v2.8.1v2.8.2v2.8.3v2.8.4v2.8.5v2.8.6v2.8.7
2.8.8
moodle/moodle
Packagist
2.9.0 up to 2.9.2, plus listed versions
v2.9.0v2.9.1
2.9.2
moodle
Mageia:5
From an advisory covering 6 CVEs
before 2.8.8-1.mga5
2.8.8-1.mga5

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-5268 is a medium vulnerability (CVSS 4.3) in Moodle, published September 23, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.58%, the 75th percentile. Fixed in moodle/moodle 2.7.10.

References

Show 19 moreShow less
This page doesn't list everything

Left out here: 10 versions. The JSON record has them.

MoveEnter Open