CVE-2015-5704
scripts/licensecheck.pl in devscripts before 2.15.7 allows local users to execute arbitrary shell...
scripts/licensecheck.pl in devscripts before 2.15.7 allows local users to execute arbitrary shell commands.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
scripts/licensecheck.pl in devscripts before 2.15.7 allows local users to execute arbitrary shell commands.
- Record
CVE-2015-5704- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.2 High
AV:L/AC:L/Au:N/C:C/I:C/A:C - Weakness
- CWE-77
- Updated
- 2026-11-02
CVE List No score
scripts/licensecheck.pl in devscripts before 2.15.7 allows local users to execute arbitrary shell commands.
- Record
CVE-2015-5704- Updated
- 2026-11-02
EUVDEUVD-2015-5651 No score
scripts/licensecheck.pl in devscripts before 2.15.7 allows local users to execute arbitrary shell commands.
- Record
EUVD-2015-5651- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4fg8-6wmq-2r6x
7.8
scripts/licensecheck.pl in devscripts before 2.15.7 allows local users to execute arbitrary shell...
scripts/licensecheck.pl in devscripts before 2.15.7 allows local users to execute arbitrary shell commands.
- Record
GHSA-4fg8-6wmq-2r6x- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-77
- Updated
- 2026-11-02
OSV
7.8
scripts/licensecheck.pl in devscripts before 2.15.7 allows local users to execute arbitrary shell commands.
- Record
CVE-2015-5704- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-5704
7.8
scripts/licensecheck.pl in devscripts before 2.15.7 allows local users to execute arbitrary shell commands.
- Record
DEBIAN-CVE-2015-5704- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
devscriptsDebian:12 |
before 2.15.7 | 2.15.7 |
devscriptsDebian:13 |
before 2.15.7 | 2.15.7 |
devscriptsDebian:14 |
before 2.15.7 | 2.15.7 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-5704 is a high vulnerability (CVSS 7.8) in Devscripts Devel Team Devscripts, published September 25, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.53%, the 44th percentile. Fixed in devscripts 2.15.7.
References
lists.fedoraproject.org/pipermail/package-announce/2015-August/163710.html
bugs.debian.org/cgi-bin/bugreport.cgi?bug=794260
lists.fedoraproject.org/pipermail/package-announce/2015-August/163705.html
securityfocus.com/bid/76143
bugzilla.redhat.com/show_bug.cgi?id=1249635
openwall.com/lists/oss-security/2015/08/01/7