Every CVE Search/ Get API key

CVE-2015-5986

openpgpkey_61.c in named in ISC BIND 9.9.7 before 9.9.7-P3 and 9.10.x before 9.10.2-P4 allows...

7.1 High

openpgpkey_61.c in named in ISC BIND 9.9.7 before 9.9.7-P3 and 9.10.x before 9.10.2-P4 allows remote attackers to cause a denial of service (REQUIRE assertion failure and daemon exit) via a crafted DNS response.

Exploit likelihood

26.9%Up 3.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.1

openpgpkey_61.c in named in ISC BIND 9.9.7 before 9.9.7-P3 and 9.10.x before 9.10.2-P4 allows remote attackers to cause a denial of service (REQUIRE assertion failure and daemon exit) via a crafted DNS response.

Record
CVE-2015-5986
CVSS 2.0
7.1 HighAV:N/AC:M/Au:N/C:N/I:N/A:C
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

openpgpkey_61.c in named in ISC BIND 9.9.7 before 9.9.7-P3 and 9.10.x before 9.10.2-P4 allows remote attackers to cause a denial of service (REQUIRE assertion failure and daemon exit) via a crafted DNS response.

Record
CVE-2015-5986
Updated
2026-11-02
EUVDEUVD-2015-5929 No score

openpgpkey_61.c in named in ISC BIND 9.9.7 before 9.9.7-P3 and 9.10.x before 9.10.2-P4 allows remote attackers to cause a denial of service (REQUIRE assertion failure and daemon exit) via a crafted DNS response.

Record
EUVD-2015-5929
Updated
2026-11-03
GitHub AdvisoriesGHSA-q676-ggwg-j7vx No score

openpgpkey_61.c in named in ISC BIND 9.9.7 before 9.9.7-P3 and 9.10.x before 9.10.2-P4 allows...

openpgpkey_61.c in named in ISC BIND 9.9.7 before 9.9.7-P3 and 9.10.x before 9.10.2-P4 allows remote attackers to cause a denial of service (REQUIRE assertion failure and daemon exit) via a crafted DNS response.

Record
GHSA-q676-ggwg-j7vx
Weakness
CWE-20
Updated
2026-11-02
OSVMGASA-2015-0341 No score

Updated bind packages fix security vulnerabilities

Updated bind packages fix security vulnerability:

Parsing a malformed DNSSEC key can cause a validating resolver to exit due to a failed assertion in buffer.c. It is possible for a remote attacker to deliberately trigger this condition, for example by using a query which requires a response from a zone containing a deliberately malformed key (CVE-2015-5722).

An incorrect boundary check in openpgpkey_61.c can cause named to terminate due to a REQUIRE assertion failure. This defect can be deliberately exploited by an attacker who can provide a maliciously constructed response in answer to a query (CVE-2015-5986).

Record
MGASA-2015-0341
Updated
2026-11-02
OSVopenSUSE-SU-2024:10467-1 No score

bind-9.10.3P4-21.1 on GA media

These are all security issues fixed in the bind-9.10.3P4-21.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10467-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
bind
Mageia:4
From an advisory covering 2 CVEs
before 9.9.7.P3-1.mga4
9.9.7.P3-1.mga4
bind
Mageia:5
From an advisory covering 2 CVEs
before 9.10.2.P4-1.mga5
9.10.2.P4-1.mga5
bind
openSUSE:Tumbleweed
From an advisory covering 37 CVEs
before 9.10.3P4-21.1
9.10.3P4-21.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-5986 is a high vulnerability (CVSS 7.1) in Isc Bind, published September 5, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 26.9%, the 98th percentile. No source names a fixed version.

References

Show 52 moreShow less
MoveEnter Open