CVE-2015-6584
DataTable Vulnerable to Cross-Site Scripting
Cross-site scripting (XSS) vulnerability in the DataTables plugin 1.10.8 and earlier for jQuery allows remote attackers to inject arbitrary web script or HTML via the scripts parameter to media/unit_testing/templates/6776.php.
Exploit likelihood
What each source reports
NVD Score used
4.3
Cross-site scripting (XSS) vulnerability in the DataTables plugin 1.10.8 and earlier for jQuery allows remote attackers to inject arbitrary web script or HTML via the scripts parameter to media/unit_testing/templates/6776.php.
- Record
CVE-2015-6584- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in the DataTables plugin 1.10.8 and earlier for jQuery allows remote attackers to inject arbitrary web script or HTML via the scripts parameter to media/unit_testing/templates/6776.php.
- Record
CVE-2015-6584- Updated
- 2026-11-02
EUVDEUVD-2020-0590 No score
Cross-site scripting (XSS) vulnerability in the DataTables plugin 1.10.8 and earlier for jQuery allows remote attackers to inject arbitrary web script or HTML via the scripts parameter to media/unit_testing/templates/6776.php.
- Record
EUVD-2020-0590- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4mv4-gmmf-q382 No score
DataTable Vulnerable to Cross-Site Scripting
Cross-site scripting (XSS) vulnerability in the DataTables plugin 1.10.8 and earlier for jQuery allows remote attackers to inject arbitrary web script or HTML via the scripts parameter to media/unit_testing/templates/6776.php.
Recommendation
Update to a version greater than 1.10.8. A fix appears in version 1.10.10.
- Record
GHSA-4mv4-gmmf-q382- Weakness
- CWE-79
- Updated
- 2026-11-02
OSV No score
Cross-site scripting (XSS) vulnerability in the DataTables plugin 1.10.8 and earlier for jQuery allows remote attackers to inject arbitrary web script or HTML via the scripts parameter to media/unit_testing/templates/6776.php.
- Record
CVE-2015-6584- Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-6584 No score
Cross-site scripting (XSS) vulnerability in the DataTables plugin 1.10.8 and earlier for jQuery allows remote attackers to inject arbitrary web script or HTML via the scripts parameter to media/unit_testing/templates/6776.php.
- Record
DEBIAN-CVE-2015-6584- Updated
- 2026-11-02
OSVGHSA-4mv4-gmmf-q382 No score
DataTable Vulnerable to Cross-Site Scripting
Cross-site scripting (XSS) vulnerability in the DataTables plugin 1.10.8 and earlier for jQuery allows remote attackers to inject arbitrary web script or HTML via the scripts parameter to media/unit_testing/templates/6776.php.
Recommendation
Update to a version greater than 1.10.8. A fix appears in version 1.10.10.
- Record
GHSA-4mv4-gmmf-q382- Weakness
- CWE-79
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-6584 No score
Cross-site scripting (XSS) vulnerability in the DataTables plugin 1.10.8 and earlier for jQuery allows remote attackers to inject arbitrary web script or HTML via the scripts parameter to media/unit_testing/templates/6776.php.
- Record
UBUNTU-CVE-2015-6584- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
datatablesnpm |
before 1.10.10 | 1.10.10 |
datatables/datatablesPackagist |
before 1.10.10 | 1.10.10 |
datatables.jsDebian:12 |
before 1.10.9+dfsg-1 | 1.10.9+dfsg-1 |
datatables.jsDebian:13 |
before 1.10.9+dfsg-1 | 1.10.9+dfsg-1 |
datatables.jsDebian:14 |
before 1.10.9+dfsg-1 | 1.10.9+dfsg-1 |
datatables/datatablesPackagist |
before 1.10.10, plus listed versions 1.10.01.10.0-beta.11.10.0-beta.21.10.0-rc.11.10.1 Show 8 moreShow less1.10.21.10.31.10.41.10.51.10.61.10.71.10.81.10.9 |
1.10.10 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-6584 is a medium vulnerability (CVSS 4.3) in Sprymedia Datatables, published September 11, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.68%, the 85th percentile. Fixed in datatables 1.10.10.
References
packetstormsecurity.com/files/133555/DataTables-1.10.8-Cross-Site-Scripting.html
securityfocus.com/archive/1/536437/100/0/threaded
netsparker.com/cve-2015-6384-xss-vulnerability-identified-in-datatables
seclists.org/fulldisclosure/2015/Sep/37
github.com/DataTables/DataTables/issues/602
github.com/DataTables/DataTablesSrc/commit/ccf86dc5982bd8e16d
Show 10 moreShow less
npmjs.com/advisories/5
securityfocus.com/archive/1/archive/1/536437/100/0/threaded
nvd.nist.gov/vuln/detail/CVE-2015-6584
github.com/DataTables/DataTablesSrc/commits/1.10.10?after=9780a3693572757d87bf70e48bd7555faf974f28+34&branch=1.10.10&qualified_name=refs%2Ftags%2F1.10.10
github.com/advisories/GHSA-4mv4-gmmf-q382
security-tracker.debian.org/tracker/CVE-2015-6584
github.com/DataTables/DataTables
ubuntu.com/security/CVE-2015-6584
nodesecurity.io/advisories/5
cve.org/CVERecord?id=CVE-2015-6584