Every CVE Search/ Get API key

CVE-2015-6749

Buffer overflow in the aiff_open function in oggenc/audio.c in vorbis-tools 1.4.0 and earlier...

4.3 MediumFix available

Buffer overflow in the aiff_open function in oggenc/audio.c in vorbis-tools 1.4.0 and earlier allows remote attackers to cause a denial of service (crash) via a crafted AIFF file.

Exploit likelihood

4.37%Up 2.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Buffer overflow in the aiff_open function in oggenc/audio.c in vorbis-tools 1.4.0 and earlier allows remote attackers to cause a denial of service (crash) via a crafted AIFF file.

Record
CVE-2015-6749
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Buffer overflow in the aiff_open function in oggenc/audio.c in vorbis-tools 1.4.0 and earlier allows remote attackers to cause a denial of service (crash) via a crafted AIFF file.

Record
CVE-2015-6749
Updated
2026-11-02
EUVDEUVD-2015-6686 No score

Buffer overflow in the aiff_open function in oggenc/audio.c in vorbis-tools 1.4.0 and earlier allows remote attackers to cause a denial of service (crash) via a crafted AIFF file.

Record
EUVD-2015-6686
Updated
2026-11-03
GitHub AdvisoriesGHSA-8v83-gwwh-26pr No score

Buffer overflow in the aiff_open function in oggenc/audio.c in vorbis-tools 1.4.0 and earlier...

Buffer overflow in the aiff_open function in oggenc/audio.c in vorbis-tools 1.4.0 and earlier allows remote attackers to cause a denial of service (crash) via a crafted AIFF file.

Record
GHSA-8v83-gwwh-26pr
Weakness
CWE-119
Updated
2026-11-02
OSVAZL-6955 No score

CVE-2015-6749 affecting package vorbis-tools for versions less than 1.4.0-35

Buffer overflow in the aiff_open function in oggenc/audio.c in vorbis-tools 1.4.0 and earlier allows remote attackers to cause a denial of service (crash) via a crafted AIFF file.

Record
AZL-6955
Updated
2026-11-02
OSVAZL-7403 No score

CVE-2015-6749 affecting package vorbis-tools for versions less than 1.4.0-35

Buffer overflow in the aiff_open function in oggenc/audio.c in vorbis-tools 1.4.0 and earlier allows remote attackers to cause a denial of service (crash) via a crafted AIFF file.

Record
AZL-7403
Updated
2026-11-02
Show 7 moreShow less
OSV No score

Buffer overflow in the aiff_open function in oggenc/audio.c in vorbis-tools 1.4.0 and earlier allows remote attackers to cause a denial of service (crash) via a crafted AIFF file.

Record
CVE-2015-6749
Updated
2026-11-02
OSVDEBIAN-CVE-2015-6749 No score

Buffer overflow in the aiff_open function in oggenc/audio.c in vorbis-tools 1.4.0 and earlier allows remote attackers to cause a denial of service (crash) via a crafted AIFF file.

Record
DEBIAN-CVE-2015-6749
Updated
2026-11-02
OSVMGASA-2015-0353 No score

Updated vorbis-tools packages fix CVE-2015-6749

Updated vorbis-tools package fixes security vulnerability:

A buffer overread is possible in vorbis-tools in oggenc/audio.c when opening a specially crafted AIFF file (CVE-2015-6749).

Record
MGASA-2015-0353
Updated
2026-11-02
OSVopenSUSE-SU-2024:10259-1 No score

vorbis-tools-1.4.0-22.6 on GA media

These are all security issues fixed in the vorbis-tools-1.4.0-22.6 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10259-1
Updated
2026-11-02
OSVSUSE-SU-2015:1765-1 No score

Security update for vorbis-tools

vorbis-tools was updated to fix a buffer overflow in aiff_open() that could be triggered by opening prepared malicious files. (CVE-2015-6749, bsc#943795).

Record
SUSE-SU-2015:1765-1
Updated
2026-11-02
OSVSUSE-SU-2015:1775-1 No score

Security update for vorbis-tools

vorbis-tools was updated to fix several security issues.

  • A buffer overflow in aiff_open() that could be triggered by opening prepared malicious files (CVE-2015-6749, bsc#943795).

  • A division by zero and integer overflow by crafted WAV files was fixed (CVE-2014-9638, CVE-2014-9639, bnc#914439, bnc#914441).

Record
SUSE-SU-2015:1775-1
Updated
2026-11-02
OSVUBUNTU-CVE-2015-6749 No score

Buffer overflow in the aiff_open function in oggenc/audio.c in vorbis-tools 1.4.0 and earlier allows remote attackers to cause a denial of service (crash) via a crafted AIFF file.

Record
UBUNTU-CVE-2015-6749
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
vorbis-tools
Azure Linux:2
before 1.4.0-35
1.4.0-35
vorbis-tools
Debian:12
before 1.4.0-7
1.4.0-7
vorbis-tools
Debian:13
before 1.4.0-7
1.4.0-7
vorbis-tools
Debian:14
before 1.4.0-7
1.4.0-7
vorbis-tools
Debian:7
before 1.4.0-1+deb7u1, plus listed versions
1.4.0-1
1.4.0-1+deb7u1
vorbis-tools
Debian:6.0
before 1.4.0-1+deb6u1, plus listed versions
1.4.0-1
1.4.0-1+deb6u1
vorbis-tools
Mageia:4
before 1.4.0-6.3.mga4
1.4.0-6.3.mga4
vorbis-tools
Mageia:5
before 1.4.0-10.1.mga5
1.4.0-10.1.mga5
vorbis-tools
SUSE:Linux Enterprise Desktop 12
before 1.4.0-26.1
1.4.0-26.1
vorbis-tools
SUSE:Linux Enterprise Server 12
before 1.4.0-26.1
1.4.0-26.1
Show 4 moreShow less
Affected packages
PackageAffectedFixed
vorbis-tools
SUSE:Linux Enterprise Server for SAP Applications 12
before 1.4.0-26.1
1.4.0-26.1
vorbis-tools
SUSE:Linux Enterprise Desktop 11 SP3
before 1.1.1-174.1
1.1.1-174.1
vorbis-tools
SUSE:Linux Enterprise Desktop 11 SP4
before 1.1.1-174.1
1.1.1-174.1
vorbis-tools
openSUSE:Tumbleweed
before 1.4.0-22.6
1.4.0-22.6

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-6749 is a medium vulnerability (CVSS 4.3) in Xiph Vorbis-tools, published September 8, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.37%, the 91st percentile. Fixed in vorbis-tools 1.4.0-35.

References

Show 22 moreShow less
MoveEnter Open