CVE-2015-6816
ganglia-web before 3.7.1 allows remote attackers to bypass authentication.
ganglia-web before 3.7.1 allows remote attackers to bypass authentication.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
ganglia-web before 3.7.1 allows remote attackers to bypass authentication.
- Record
CVE-2015-6816- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-287
- Updated
- 2026-11-02
CVE List No score
ganglia-web before 3.7.1 allows remote attackers to bypass authentication.
- Record
CVE-2015-6816- Updated
- 2026-11-02
EUVDEUVD-2015-6753 No score
ganglia-web before 3.7.1 allows remote attackers to bypass authentication.
- Record
EUVD-2015-6753- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-mgrr-7c88-34fm
9.8
ganglia-web before 3.7.1 allows remote attackers to bypass authentication.
ganglia-web before 3.7.1 allows remote attackers to bypass authentication.
- Record
GHSA-mgrr-7c88-34fm- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-287
- Updated
- 2026-11-02
OSV
9.8
ganglia-web before 3.7.1 allows remote attackers to bypass authentication.
- Record
CVE-2015-6816- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-6816
9.8
ganglia-web before 3.7.1 allows remote attackers to bypass authentication.
- Record
DEBIAN-CVE-2015-6816- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-6816
9.8
ganglia-web before 3.7.1 allows remote attackers to bypass authentication.
- Record
UBUNTU-CVE-2015-6816- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2015-0375 No score
Updated ganglia-web packages fix CVE-2015-6816
An issue with the use of unserialize() in ganglia-web allows authentication to be bypassed (CVE-2015-6816).
- Record
MGASA-2015-0375- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gangliaDebian:12 |
before 3.6.0-1 | 3.6.0-1 |
gangliaDebian:14 |
before 3.6.0-1, plus listed versions 3.1.0-13.1.1-13.1.1-23.1.1-33.1.2-1 Show 12 moreShow less3.1.2-23.1.2-2.13.1.2-33.1.2-3.13.1.7-13.1.7-1+squeeze13.1.7-23.1.7-2.13.3.5-13.3.5-23.3.8-13.3.8-1+nmu1 |
3.6.0-1 |
ganglia-webDebian:12 |
before 3.7.5+debian-1, plus listed versions 3.5.2-13.5.2-23.5.8-13.5.8-23.5.8-3 Show 6 moreShow less3.5.8-3.13.5.8-43.6.1-13.6.1-23.6.1-33.6.1-3.1 |
3.7.5+debian-1 |
ganglia-webDebian:13 |
before 3.7.5+debian-1, plus listed versions 3.5.2-13.5.2-23.5.8-13.5.8-23.5.8-3 Show 6 moreShow less3.5.8-3.13.5.8-43.6.1-13.6.1-23.6.1-33.6.1-3.1 |
3.7.5+debian-1 |
ganglia-webDebian:14 |
before 3.7.5+debian-1, plus listed versions 3.5.2-13.5.2-23.5.8-13.5.8-23.5.8-3 Show 6 moreShow less3.5.8-3.13.5.8-43.6.1-13.6.1-23.6.1-33.6.1-3.1 |
3.7.5+debian-1 |
ganglia-webMageia:4 |
before 3.5.10-3.1.mga4 | 3.5.10-3.1.mga4 |
ganglia-webMageia:5 |
before 3.6.2-4.2.mga5 | 3.6.2-4.2.mga5 |
ganglia-webUbuntu:16.04:LTS |
All versions, plus listed versions 3.6.1-13.6.1-1ubuntu13.6.1-1ubuntu1.1 |
None known |
ganglia-webUbuntu:18.04:LTS |
All versions, plus listed versions 3.6.1-3 |
None known |
ganglia-webUbuntu:20.04:LTS |
All versions, plus listed versions 3.6.1-3 |
None known |
gangliaUbuntu:26.10 |
All versions, plus listed versions 3.7.2-7ubuntu1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-6816 is a critical vulnerability (CVSS 9.8) in Ganglia Ganglia-web, published September 17, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.56%, the 89th percentile. Fixed in ganglia 3.6.0-1.
References
bugzilla.redhat.com/show_bug.cgi?id=1260562
github.com/ganglia/ganglia-web/issues/267
lists.fedoraproject.org/pipermail/package-announce/2015-October/169641.html
lists.fedoraproject.org/pipermail/package-announce/2015-November/170362.html
lists.fedoraproject.org/pipermail/package-announce/2015-October/169788.html
freshports.org/sysutils/ganglia-webfrontend
Show 11 moreShow less
openwall.com/lists/oss-security/2015/09/05/6
securityfocus.com/bid/92146
nvd.nist.gov/vuln/detail/CVE-2015-6816
github.com/advisories/GHSA-mgrr-7c88-34fm
security-tracker.debian.org/tracker/CVE-2015-6816
advisories.mageia.org/MGASA-2015-0375.html
bugs.mageia.org/show_bug.cgi?id=16715
cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6816
ubuntu.com/security/CVE-2015-6816
openwall.com/lists/oss-security/2015/09/04/2
cve.org/CVERecord?id=CVE-2015-6816