Every CVE Search/ Get API key

CVE-2015-7558

librsvg DoS via Cyclic References

7.5 HighFix available

librsvg before 2.40.12 allows context-dependent attackers to cause a denial of service (infinite loop, stack consumption, and application crash) via cyclic references in an SVG document.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

2.39%Up 1.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

librsvg before 2.40.12 allows context-dependent attackers to cause a denial of service (infinite loop, stack consumption, and application crash) via cyclic references in an SVG document.

Record
CVE-2015-7558
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

librsvg before 2.40.12 allows context-dependent attackers to cause a denial of service (infinite loop, stack consumption, and application crash) via cyclic references in an SVG document.

Record
CVE-2015-7558
Updated
2026-11-02
EUVDEUVD-2022-4321 No score

librsvg before 2.40.12 allows context-dependent attackers to cause a denial of service (infinite loop, stack consumption, and application crash) via cyclic references in an SVG document.

Record
EUVD-2022-4321
Updated
2026-11-03
GitHub AdvisoriesGHSA-j984-q4qc-6qxf 7.5

librsvg DoS via Cyclic References

librsvg before 2.40.12 allows context-dependent attackers to cause a denial of service (infinite loop, stack consumption, and application crash) via cyclic references in an SVG document.

Record
GHSA-j984-q4qc-6qxf
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-20
Updated
2026-11-02
OSV 7.5

librsvg before 2.40.12 allows context-dependent attackers to cause a denial of service (infinite loop, stack consumption, and application crash) via cyclic references in an SVG document.

Record
CVE-2015-7558
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2015-7558 7.5

librsvg before 2.40.12 allows context-dependent attackers to cause a denial of service (infinite loop, stack consumption, and application crash) via cyclic references in an SVG document.

Record
DEBIAN-CVE-2015-7558
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVGHSA-j984-q4qc-6qxf 7.5

librsvg DoS via Cyclic References

librsvg before 2.40.12 allows context-dependent attackers to cause a denial of service (infinite loop, stack consumption, and application crash) via cyclic references in an SVG document.

Record
GHSA-j984-q4qc-6qxf
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-20
Updated
2026-11-02
OSVUBUNTU-CVE-2015-7558 7.5

librsvg before 2.40.12 allows context-dependent attackers to cause a denial of service (infinite loop, stack consumption, and application crash) via cyclic references in an SVG document.

Record
UBUNTU-CVE-2015-7558
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2016-0021 No score

Updated librsvg packages fix security vulnerability

Out-of-bounds heap read in librsvg2 was found when parsing SVG file (CVE-2015-7557).

Stack exhaustion due to cyclic dependency causing to crash an application was found in librsvg2 while parsing SVG file (CVE-2015-7558).

The librsvg package has been updated to version 2.40.13, fixing these issues and several other bugs. See the upstream NEWS file for details.

Record
MGASA-2016-0021
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
librsvg
crates.io
before 2.40.12
2.40.12
librsvg
Debian:12
before 2.40.12-1
2.40.12-1
librsvg
Debian:13
before 2.40.12-1
2.40.12-1
librsvg
Debian:14
before 2.40.12-1
2.40.12-1
librsvg
Debian:7
before 2.36.1-2+deb7u2, plus listed versions
2.36.1-12.36.1-22.36.1-2+deb7u1
2.36.1-2+deb7u2
librsvg
Debian:8
before 2.40.5-1+deb8u2, plus listed versions
2.40.5-12.40.5-1+deb8u1
2.40.5-1+deb8u2
librsvg
Mageia:5
before 2.40.13-1.mga5
2.40.13-1.mga5

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-7558 is a high vulnerability (CVSS 7.5) in Gnome Librsvg, published January 15, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.39%, the 84th percentile. Fixed in librsvg 2.40.12.

References

Show 8 moreShow less
MoveEnter Open