CVE-2015-8012
lldpd before 0.8.0 allows remote attackers to cause a denial of service (assertion failure and...
lldpd before 0.8.0 allows remote attackers to cause a denial of service (assertion failure and daemon crash) via a malformed packet.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
lldpd before 0.8.0 allows remote attackers to cause a denial of service (assertion failure and daemon crash) via a malformed packet.
- Record
CVE-2015-8012- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-617
- Updated
- 2026-11-02
CVE List No score
lldpd before 0.8.0 allows remote attackers to cause a denial of service (assertion failure and daemon crash) via a malformed packet.
- Record
CVE-2015-8012- Updated
- 2026-11-02
EUVDEUVD-2015-7908 No score
lldpd before 0.8.0 allows remote attackers to cause a denial of service (assertion failure and daemon crash) via a malformed packet.
- Record
EUVD-2015-7908- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-26h8-43q7-4r2w No score
lldpd before 0.8.0 allows remote attackers to cause a denial of service (assertion failure and...
lldpd before 0.8.0 allows remote attackers to cause a denial of service (assertion failure and daemon crash) via a malformed packet.
- Record
GHSA-26h8-43q7-4r2w- Updated
- 2026-11-02
OSV
7.5
lldpd before 0.8.0 allows remote attackers to cause a denial of service (assertion failure and daemon crash) via a malformed packet.
- Record
CVE-2015-8012- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-8012
7.5
lldpd before 0.8.0 allows remote attackers to cause a denial of service (assertion failure and daemon crash) via a malformed packet.
- Record
DEBIAN-CVE-2015-8012- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-8012
7.5
lldpd before 0.8.0 allows remote attackers to cause a denial of service (assertion failure and daemon crash) via a malformed packet.
- Record
UBUNTU-CVE-2015-8012- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-8012 is a high vulnerability (CVSS 7.5) in Lldpd Project Lldpd, published January 28, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.00%, the 87th percentile. Fixed in lldpd 0.7.19-1.
References
github.com/vincentbernat/lldpd/commit/793526f8884455f43daecd0a2c46772388417a00
openwall.com/lists/oss-security/2015/10/30/2
openwall.com/lists/oss-security/2015/10/18/2
github.com/vincentbernat/lldpd/commit/9221b5c249f9e4843f77c7f888d5705348d179c0
nvd.nist.gov/vuln/detail/CVE-2015-8012
github.com/advisories/GHSA-26h8-43q7-4r2w
security-tracker.debian.org/tracker/CVE-2015-8012
ubuntu.com/security/CVE-2015-8012
cve.org/CVERecord?id=CVE-2015-8012