Every CVE Search/ Get API key

CVE-2015-8604

SQL injection vulnerability in the host_new_graphs function in graphs_new.php in Cacti 0.8.8f and...

8.8 HighFix available

SQL injection vulnerability in the host_new_graphs function in graphs_new.php in Cacti 0.8.8f and earlier allows remote authenticated users to execute arbitrary SQL commands via the cg_g parameter in a save action.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.31%Up 1.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 8.8

SQL injection vulnerability in the host_new_graphs function in graphs_new.php in Cacti 0.8.8f and earlier allows remote authenticated users to execute arbitrary SQL commands via the cg_g parameter in a save action.

Record
CVE-2015-8604
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.5 MediumAV:N/AC:L/Au:S/C:P/I:P/A:P
Weakness
CWE-89
Updated
2026-11-02
CVE List No score

SQL injection vulnerability in the host_new_graphs function in graphs_new.php in Cacti 0.8.8f and earlier allows remote authenticated users to execute arbitrary SQL commands via the cg_g parameter in a save action.

Record
CVE-2015-8604
Updated
2026-11-02
EUVDEUVD-2015-8482 No score

SQL injection vulnerability in the host_new_graphs function in graphs_new.php in Cacti 0.8.8f and earlier allows remote authenticated users to execute arbitrary SQL commands via the cg_g parameter in a save action.

Record
EUVD-2015-8482
Updated
2026-11-03
GitHub AdvisoriesGHSA-4frf-q9p9-gg69 8.8

SQL injection vulnerability in the host_new_graphs function in graphs_new.php in Cacti 0.8.8f and...

SQL injection vulnerability in the host_new_graphs function in graphs_new.php in Cacti 0.8.8f and earlier allows remote authenticated users to execute arbitrary SQL commands via the cg_g parameter in a save action.

Record
GHSA-4frf-q9p9-gg69
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-89
Updated
2026-11-02
OSV 8.8

SQL injection vulnerability in the host_new_graphs function in graphs_new.php in Cacti 0.8.8f and earlier allows remote authenticated users to execute arbitrary SQL commands via the cg_g parameter in a save action.

Record
CVE-2015-8604
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2015-8604 8.8

SQL injection vulnerability in the host_new_graphs function in graphs_new.php in Cacti 0.8.8f and earlier allows remote authenticated users to execute arbitrary SQL commands via the cg_g parameter in a save action.

Record
DEBIAN-CVE-2015-8604
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2015-8604 8.8

SQL injection vulnerability in the host_new_graphs function in graphs_new.php in Cacti 0.8.8f and earlier allows remote authenticated users to execute arbitrary SQL commands via the cg_g parameter in a save action.

Record
UBUNTU-CVE-2015-8604
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2016-0025 No score

Updated cacti packages fix security vulnerability

Several SQL injection vulnerabilities have been discovered in Cacti. Specially crafted input can be used by an attacker in the rra_id value of the graph.php script to execute arbitrary SQL commands on the database (CVE-2015-8369).

Record
MGASA-2016-0025
Updated
2026-11-02
OSVopenSUSE-SU-2024:10084-1 No score

cacti-0.8.8h-1.2 on GA media

These are all security issues fixed in the cacti-0.8.8h-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10084-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
cacti
Debian:12
before 0.8.8f+ds1-4
0.8.8f+ds1-4
cacti
Debian:13
before 0.8.8f+ds1-4
0.8.8f+ds1-4
cacti
Debian:14
before 0.8.8f+ds1-4
0.8.8f+ds1-4
cacti
Debian:6.0
before 0.8.7g-1+squeeze9+deb6u14, plus listed versions
0.8.7g-10.8.7g-1+squeeze10.8.7g-1+squeeze20.8.7g-1+squeeze30.8.7g-1+squeeze4
Show 5 moreShow less
0.8.7g-1+squeeze50.8.7g-1+squeeze60.8.7g-1+squeeze70.8.7g-1+squeeze80.8.7g-1+squeeze9
0.8.7g-1+squeeze9+deb6u14
cacti
Debian:7
From an advisory covering 2 CVEs
before 0.8.8a+dfsg-5+deb7u8, plus listed versions
0.8.8a+dfsg-50.8.8a+dfsg-5+deb7u10.8.8a+dfsg-5+deb7u20.8.8a+dfsg-5+deb7u30.8.8a+dfsg-5+deb7u40.8.8a+dfsg-5+deb7u50.8.8a+dfsg-5+deb7u60.8.8a+dfsg-5+deb7u7
0.8.8a+dfsg-5+deb7u8
cacti
Debian:8
From an advisory covering 2 CVEs
before 0.8.8b+dfsg-8+deb8u4, plus listed versions
0.8.8b+dfsg-80.8.8b+dfsg-8+deb8u10.8.8b+dfsg-8+deb8u20.8.8b+dfsg-8+deb8u3
0.8.8b+dfsg-8+deb8u4
cacti
Mageia:5
From an advisory covering 3 CVEs
before 0.8.8f-1.2.mga5
0.8.8f-1.2.mga5
cacti
Ubuntu:14.04:LTS
before 0.8.8b+dfsg-5ubuntu0.2, plus listed versions
0.8.8b+dfsg-30.8.8b+dfsg-50.8.8b+dfsg-5ubuntu0.1
0.8.8b+dfsg-5ubuntu0.2
cacti
openSUSE:Tumbleweed
From an advisory covering 18 CVEs
before 0.8.8h-1.2
0.8.8h-1.2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-8604 is a high vulnerability (CVSS 8.8) in Cacti, published January 14, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.31%, the 83rd percentile. Fixed in cacti 0.8.8f+ds1-4.

References

Show 30 moreShow less
MoveEnter Open