CVE-2015-8688
Gajim before 0.16.5 allows remote attackers to modify the roster and intercept messages via a...
Gajim before 0.16.5 allows remote attackers to modify the roster and intercept messages via a crafted roster-push IQ stanza.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.4
Gajim before 0.16.5 allows remote attackers to modify the roster and intercept messages via a crafted roster-push IQ stanza.
- Record
CVE-2015-8688- CVSS 3.0
- 5.4 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N - CVSS 2.0
- 5.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
Gajim before 0.16.5 allows remote attackers to modify the roster and intercept messages via a crafted roster-push IQ stanza.
- Record
CVE-2015-8688- Updated
- 2026-11-02
EUVDEUVD-2015-8565 No score
Gajim before 0.16.5 allows remote attackers to modify the roster and intercept messages via a crafted roster-push IQ stanza.
- Record
EUVD-2015-8565- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-fg7g-52r5-p6wj
5.4
Gajim before 0.16.5 allows remote attackers to modify the roster and intercept messages via a...
Gajim before 0.16.5 allows remote attackers to modify the roster and intercept messages via a crafted roster-push IQ stanza.
- Record
GHSA-fg7g-52r5-p6wj- CVSS 3.0
- 5.4 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
OSV
5.4
Gajim before 0.16.5 allows remote attackers to modify the roster and intercept messages via a crafted roster-push IQ stanza.
- Record
CVE-2015-8688- CVSS 3.0
- 5.4 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-8688
5.4
Gajim before 0.16.5 allows remote attackers to modify the roster and intercept messages via a crafted roster-push IQ stanza.
- Record
DEBIAN-CVE-2015-8688- CVSS 3.0
- 5.4 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N - Updated
- 2026-11-02
Show 5 moreShow less
OSVUBUNTU-CVE-2015-8688
5.4
Gajim before 0.16.5 allows remote attackers to modify the roster and intercept messages via a crafted roster-push IQ stanza.
- Record
UBUNTU-CVE-2015-8688- CVSS 3.0
- 5.4 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N - Updated
- 2026-11-02
OSVMGASA-2016-0046 No score
Updated gajim packages fix security vulnerability
Gajim before 0.16.5 doesn't verify the origin of roster pushes thus allowing third parties to modify the roster via a man-in-the-middle attack (CVE-2015-8688).
- Record
MGASA-2016-0046- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10007-1 No score
mcabber-1.0.4-1.1 on GA media
These are all security issues fixed in the mcabber-1.0.4-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10007-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10547-1 No score
gajim-0.16.6-1.1 on GA media
These are all security issues fixed in the gajim-0.16.6-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10547-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11273-1 No score
python36-sleekxmpp-1.3.3-4.18 on GA media
These are all security issues fixed in the python36-sleekxmpp-1.3.3-4.18 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11273-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gajimDebian:12 |
before 0.16.5-0.1 | 0.16.5-0.1 |
gajimDebian:13 |
before 0.16.5-0.1 | 0.16.5-0.1 |
gajimDebian:14 |
before 0.16.5-0.1 | 0.16.5-0.1 |
gajimDebian:6.0 |
before 0.13.4-3+squeeze4, plus listed versions 0.13.4-30.13.4-3+squeeze10.13.4-3+squeeze20.13.4-3+squeeze3 |
0.13.4-3+squeeze4 |
gajimDebian:7 |
before 0.15.1-4.1+deb7u1, plus listed versions 0.15.1-40.15.1-4.1 |
0.15.1-4.1+deb7u1 |
gajimDebian:8 |
before 0.16-1+deb8u1, plus listed versions 0.16-1 |
0.16-1+deb8u1 |
gajimMageia:5 |
before 0.16.5-1.mga5 | 0.16.5-1.mga5 |
python-nbxmppMageia:5 |
before 0.5.3-1.mga5 | 0.5.3-1.mga5 |
mcabberopenSUSE:Tumbleweed |
before 1.0.4-1.1 | 1.0.4-1.1 |
gajimopenSUSE:Tumbleweed |
before 0.16.6-1.1 | 0.16.6-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-8688 is a medium vulnerability (CVSS 5.4) in Gajim, published January 15, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.72%, the 77th percentile. Fixed in gajim 0.16.5-0.1.
References
lists.opensuse.org/opensuse-updates/2016-01/msg00027.html
debian.org/security/2016/dsa-3492
lists.fedoraproject.org/pipermail/package-announce/2016-January/175503.html
hg.gajim.org/gajim/file/gajim-0.16.5/ChangeLog
gultsch.de/gajim_roster_push_and_message_interception.html
lists.fedoraproject.org/pipermail/package-announce/2016-January/175526.html
Show 11 moreShow less
nvd.nist.gov/vuln/detail/CVE-2015-8688
github.com/advisories/GHSA-fg7g-52r5-p6wj
security-tracker.debian.org/tracker/CVE-2015-8688
advisories.mageia.org/MGASA-2016-0046.html
bugs.mageia.org/show_bug.cgi?id=17474
ubuntu.com/security/CVE-2015-8688
trac.gajim.org/changeset/af78b7c068904d78c5dfb802826aae99f26a8947
cve.org/CVERecord?id=CVE-2015-8688
suse.com/security/cve/CVE-2015-8688
suse.com/security/cve/CVE-2012-2093
suse.com/security/cve/CVE-2017-5589