CVE-2015-8852
Varnish 3.x before 3.0.7, when used in certain stacked installations, allows remote attackers to...
Varnish 3.x before 3.0.7, when used in certain stacked installations, allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via a header line terminated by a \r (carriage return) character in conjunction with multiple Content-Length headers in an HTTP request.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.5
Varnish 3.x before 3.0.7, when used in certain stacked installations, allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via a header line terminated by a \r (carriage return) character in conjunction with multiple Content-Length headers in an HTTP request.
- Record
CVE-2015-8852- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:P/A:N - Updated
- 2026-11-02
CVE List No score
Varnish 3.x before 3.0.7, when used in certain stacked installations, allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via a header line terminated by a \r (carriage return) character in conjunction with multiple Content-Length headers in an HTTP request.
- Record
CVE-2015-8852- Updated
- 2026-11-02
EUVDEUVD-2015-8717 No score
Varnish 3.x before 3.0.7, when used in certain stacked installations, allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via a header line terminated by a \r (carriage return) character in conjunction with multiple Content-Length headers in an HTTP request.
- Record
EUVD-2015-8717- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-rgw4-jfff-qx3m
7.5
Varnish 3.x before 3.0.7, when used in certain stacked installations, allows remote attackers to...
Varnish 3.x before 3.0.7, when used in certain stacked installations, allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via a header line terminated by a \r (carriage return) character in conjunction with multiple Content-Length headers in an HTTP request.
- Record
GHSA-rgw4-jfff-qx3m- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSV
7.5
Varnish 3.x before 3.0.7, when used in certain stacked installations, allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via a header line terminated by a \r (carriage return) character in conjunction with multiple Content-Length headers in an HTTP request.
- Record
CVE-2015-8852- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-8852
7.5
Varnish 3.x before 3.0.7, when used in certain stacked installations, allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via a header line terminated by a \r (carriage return) character in conjunction with multiple Content-Length headers in an HTTP request.
- Record
DEBIAN-CVE-2015-8852- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-8852
7.5
Varnish 3.x before 3.0.7, when used in certain stacked installations, allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via a header line terminated by a \r (carriage return) character in conjunction with multiple Content-Length headers in an HTTP request.
- Record
UBUNTU-CVE-2015-8852- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVMGASA-2016-0150 No score
Updated varnish packages fix CVE-2015-8852
Updated varnish packages fix security vulnerabilities:
Régis Leroy from Makina Corpus discovered that varnish, a caching HTTP reverse proxy, is vulnerable to HTTP smuggling issues, potentially resulting in cache poisoning or bypassing of access control policies (CVE-2015-8852).
- Record
MGASA-2016-0150- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
varnishDebian:12 |
before 4.0.0-1 | 4.0.0-1 |
varnishDebian:13 |
before 4.0.0-1 | 4.0.0-1 |
varnishDebian:7 |
before 3.0.2-2+deb7u2, plus listed versions 3.0.2-23.0.2-2+deb7u1 |
3.0.2-2+deb7u2 |
varnishMageia:5 |
before 3.0.3-19.1.mga5 | 3.0.3-19.1.mga5 |
varnishUbuntu:14.04:LTS |
before 3.0.5-2ubuntu0.1, plus listed versions 3.0.4-1ubuntu13.0.4-1ubuntu23.0.5-1ubuntu23.0.5-2 |
3.0.5-2ubuntu0.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-8852 is a high vulnerability (CVSS 7.5) in Debian Linux, published April 21, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.52%, the 89th percentile. Fixed in varnish 4.0.0-1.
References
debian.org/security/2016/dsa-3553
varnish-cache.org/lists/pipermail/varnish-announce/2015-March/000701.html
openwall.com/lists/oss-security/2016/04/18/7
security.gentoo.org/glsa/201607-10
github.com/varnish/Varnish-Cache/commit/29870c8fe95e4e8a672f6f28c5fbe692bea09e9c
github.com/varnish/Varnish-Cache/commit/85e8468bec9416bd7e16b0d80cb820ecd2b330c3
Show 9 moreShow less
openwall.com/lists/oss-security/2016/04/16/1
lists.opensuse.org/opensuse-updates/2016-05/msg00064.html
nvd.nist.gov/vuln/detail/CVE-2015-8852
github.com/advisories/GHSA-rgw4-jfff-qx3m
security-tracker.debian.org/tracker/CVE-2015-8852
advisories.mageia.org/MGASA-2016-0150.html
bugs.mageia.org/show_bug.cgi?id=18244
ubuntu.com/security/CVE-2015-8852
cve.org/CVERecord?id=CVE-2015-8852