Every CVE Search/ Get API key

CVE-2015-8852

Varnish 3.x before 3.0.7, when used in certain stacked installations, allows remote attackers to...

7.5 HighFix available

Varnish 3.x before 3.0.7, when used in certain stacked installations, allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via a header line terminated by a \r (carriage return) character in conjunction with multiple Content-Length headers in an HTTP request.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

3.52%Up 2.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Varnish 3.x before 3.0.7, when used in certain stacked installations, allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via a header line terminated by a \r (carriage return) character in conjunction with multiple Content-Length headers in an HTTP request.

Record
CVE-2015-8852
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Updated
2026-11-02
CVE List No score

Varnish 3.x before 3.0.7, when used in certain stacked installations, allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via a header line terminated by a \r (carriage return) character in conjunction with multiple Content-Length headers in an HTTP request.

Record
CVE-2015-8852
Updated
2026-11-02
EUVDEUVD-2015-8717 No score

Varnish 3.x before 3.0.7, when used in certain stacked installations, allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via a header line terminated by a \r (carriage return) character in conjunction with multiple Content-Length headers in an HTTP request.

Record
EUVD-2015-8717
Updated
2026-11-03
GitHub AdvisoriesGHSA-rgw4-jfff-qx3m 7.5

Varnish 3.x before 3.0.7, when used in certain stacked installations, allows remote attackers to...

Varnish 3.x before 3.0.7, when used in certain stacked installations, allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via a header line terminated by a \r (carriage return) character in conjunction with multiple Content-Length headers in an HTTP request.

Record
GHSA-rgw4-jfff-qx3m
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSV 7.5

Varnish 3.x before 3.0.7, when used in certain stacked installations, allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via a header line terminated by a \r (carriage return) character in conjunction with multiple Content-Length headers in an HTTP request.

Record
CVE-2015-8852
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2015-8852 7.5

Varnish 3.x before 3.0.7, when used in certain stacked installations, allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via a header line terminated by a \r (carriage return) character in conjunction with multiple Content-Length headers in an HTTP request.

Record
DEBIAN-CVE-2015-8852
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2015-8852 7.5

Varnish 3.x before 3.0.7, when used in certain stacked installations, allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via a header line terminated by a \r (carriage return) character in conjunction with multiple Content-Length headers in an HTTP request.

Record
UBUNTU-CVE-2015-8852
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVMGASA-2016-0150 No score

Updated varnish packages fix CVE-2015-8852

Updated varnish packages fix security vulnerabilities:

Régis Leroy from Makina Corpus discovered that varnish, a caching HTTP reverse proxy, is vulnerable to HTTP smuggling issues, potentially resulting in cache poisoning or bypassing of access control policies (CVE-2015-8852).

Record
MGASA-2016-0150
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
varnish
Debian:12
before 4.0.0-1
4.0.0-1
varnish
Debian:13
before 4.0.0-1
4.0.0-1
varnish
Debian:7
before 3.0.2-2+deb7u2, plus listed versions
3.0.2-23.0.2-2+deb7u1
3.0.2-2+deb7u2
varnish
Mageia:5
before 3.0.3-19.1.mga5
3.0.3-19.1.mga5
varnish
Ubuntu:14.04:LTS
before 3.0.5-2ubuntu0.1, plus listed versions
3.0.4-1ubuntu13.0.4-1ubuntu23.0.5-1ubuntu23.0.5-2
3.0.5-2ubuntu0.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-8852 is a high vulnerability (CVSS 7.5) in Debian Linux, published April 21, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.52%, the 89th percentile. Fixed in varnish 4.0.0-1.

References

Show 9 moreShow less
MoveEnter Open