Every CVE Search/ Get API key

CVE-2016-0725

Moodle Cross-site scripting (XSS) vulnerability in course management search

6.1 MediumFix available

Cross-site scripting (XSS) vulnerability in the search_pagination function in course/classes/management_renderer.php in Moodle 2.8.x before 2.8.10, 2.9.x before 2.9.4, and 3.0.x before 3.0.2 allows remote attackers to inject arbitrary web script or HTML via a crafted search string.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.57%Up 0.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.1

Cross-site scripting (XSS) vulnerability in the search_pagination function in course/classes/management_renderer.php in Moodle 2.8.x before 2.8.10, 2.9.x before 2.9.4, and 3.0.x before 3.0.2 allows remote attackers to inject arbitrary web script or HTML via a crafted search string.

Record
CVE-2016-0725
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in the search_pagination function in course/classes/management_renderer.php in Moodle 2.8.x before 2.8.10, 2.9.x before 2.9.4, and 3.0.x before 3.0.2 allows remote attackers to inject arbitrary web script or HTML via a crafted search string.

Record
CVE-2016-0725
Updated
2026-11-02
EUVDEUVD-2022-3962 No score

Cross-site scripting (XSS) vulnerability in the search_pagination function in course/classes/management_renderer.php in Moodle 2.8.x before 2.8.10, 2.9.x before 2.9.4, and 3.0.x before 3.0.2 allows remote attackers to inject arbitrary web script or HTML via a crafted search string.

Record
EUVD-2022-3962
Updated
2026-11-03
GitHub AdvisoriesGHSA-gj2j-ppjq-9pjg 6.1

Moodle Cross-site scripting (XSS) vulnerability in course management search

Cross-site scripting (XSS) vulnerability in the search_pagination function in course/classes/management_renderer.php in Moodle 2.8.x before 2.8.10, 2.9.x before 2.9.4, and 3.0.x before 3.0.2 allows remote attackers to inject arbitrary web script or HTML via a crafted search string.

Record
GHSA-gj2j-ppjq-9pjg
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

Cross-site scripting (XSS) vulnerability in the search_pagination function in course/classes/management_renderer.php in Moodle 2.8.x before 2.8.10, 2.9.x before 2.9.4, and 3.0.x before 3.0.2 allows remote attackers to inject arbitrary web script or HTML via a crafted search string.

Record
CVE-2016-0725
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-gj2j-ppjq-9pjg 6.1

Moodle Cross-site scripting (XSS) vulnerability in course management search

Cross-site scripting (XSS) vulnerability in the search_pagination function in course/classes/management_renderer.php in Moodle 2.8.x before 2.8.10, 2.9.x before 2.9.4, and 3.0.x before 3.0.2 allows remote attackers to inject arbitrary web script or HTML via a crafted search string.

Record
GHSA-gj2j-ppjq-9pjg
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVMGASA-2016-0029 No score

Updated moodle packages fix security vulnerability

In Moodle before 2.8.10, web services core_enrol_get_course_enrolment_methods and enrol_self_get_instance_info did not check user permission to access hidden courses (CVE-2016-0724).

In Moodle before 2.8.10, search string in course management interface was not escaped when being output creating potential for XSS attack (CVE-2016-0725).

Record
MGASA-2016-0029
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
2.8 up to 2.8.10
2.8.10
moodle/moodle
Packagist
2.9 up to 2.9.4
2.9.4
moodle/moodle
Packagist
3.0 up to 3.0.2
3.0.2
moodle/moodle
Packagist
2.8 up to 2.8.10, plus listed versions
v2.8.0v2.8.0-betav2.8.0-rc1v2.8.0-rc2v2.8.1
Show 8 moreShow less
v2.8.2v2.8.3v2.8.4v2.8.5v2.8.6v2.8.7v2.8.8v2.8.9
2.8.10
moodle/moodle
Packagist
2.9 up to 2.9.4, plus listed versions
v2.9.0v2.9.0-betav2.9.0-rc1v2.9.0-rc2v2.9.1v2.9.2v2.9.3
2.9.4
moodle/moodle
Packagist
3.0 up to 3.0.2, plus listed versions
v3.0.0v3.0.0-betav3.0.0-rc1v3.0.0-rc2v3.0.0-rc3v3.0.0-rc4v3.0.1
3.0.2
moodle
Mageia:5
From an advisory covering 2 CVEs
before 2.8.10-1.mga5
2.8.10-1.mga5

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-0725 is a medium vulnerability (CVSS 6.1) in Moodle, published January 20, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.57%, the 75th percentile. Fixed in moodle/moodle 2.8.10.

References

Show 8 moreShow less
MoveEnter Open