Every CVE Search/ Get API key

CVE-2016-10057

Buffer overflow in the WriteGROUP4Image function in coders/tiff.c in ImageMagick before 6.9.5-8...

7.8 HighFix available

Buffer overflow in the WriteGROUP4Image function in coders/tiff.c in ImageMagick before 6.9.5-8 allows remote attackers to cause a denial of service (application crash) or have other unspecified impact via a crafted file.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.73%Up 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.8

Buffer overflow in the WriteGROUP4Image function in coders/tiff.c in ImageMagick before 6.9.5-8 allows remote attackers to cause a denial of service (application crash) or have other unspecified impact via a crafted file.

Record
CVE-2016-10057
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Buffer overflow in the WriteGROUP4Image function in coders/tiff.c in ImageMagick before 6.9.5-8 allows remote attackers to cause a denial of service (application crash) or have other unspecified impact via a crafted file.

Record
CVE-2016-10057
Updated
2026-11-02
EUVDEUVD-2016-1251 No score

Buffer overflow in the WriteGROUP4Image function in coders/tiff.c in ImageMagick before 6.9.5-8 allows remote attackers to cause a denial of service (application crash) or have other unspecified impact via a crafted file.

Record
EUVD-2016-1251
Updated
2026-11-03
GitHub AdvisoriesGHSA-vr37-3xj8-x3wp 7.8

Buffer overflow in the WriteGROUP4Image function in coders/tiff.c in ImageMagick before 6.9.5-8...

Buffer overflow in the WriteGROUP4Image function in coders/tiff.c in ImageMagick before 6.9.5-8 allows remote attackers to cause a denial of service (application crash) or have other unspecified impact via a crafted file.

Record
GHSA-vr37-3xj8-x3wp
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-119
Updated
2026-11-02
OSV 7.8

Buffer overflow in the WriteGROUP4Image function in coders/tiff.c in ImageMagick before 6.9.5-8 allows remote attackers to cause a denial of service (application crash) or have other unspecified impact via a crafted file.

Record
CVE-2016-10057
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-10057 7.8

Buffer overflow in the WriteGROUP4Image function in coders/tiff.c in ImageMagick before 6.9.5-8 allows remote attackers to cause a denial of service (application crash) or have other unspecified impact via a crafted file.

Record
DEBIAN-CVE-2016-10057
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-10057 7.8

Buffer overflow in the WriteGROUP4Image function in coders/tiff.c in ImageMagick before 6.9.5-8 allows remote attackers to cause a denial of service (application crash) or have other unspecified impact via a crafted file.

Record
UBUNTU-CVE-2016-10057
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2018-0229 No score

Updated imagemagick packages fix security vulnerabilities

The imagemagick package has been updated to version 6.9.9.41 which fixes several unspecified security vulnerabilities. This update fixes several vulnerabilities in imagemagick, including: Various memory handling problems and cases of missing or incomplete input sanitising may result in denial of service, memory disclosure or the execution of arbitrary code if malformed GIF, TTF, SVG, TIFF, PCX, JPG or SFW files are processed.

Several packages have been rebuilt for the updated ImageMagick.

Record
MGASA-2018-0229
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
imagemagick
Debian:12
before 8:6.9.6.2+dfsg-2
8:6.9.6.2+dfsg-2
imagemagick
Debian:13
before 8:6.9.6.2+dfsg-2
8:6.9.6.2+dfsg-2
imagemagick
Debian:14
before 8:6.9.6.2+dfsg-2
8:6.9.6.2+dfsg-2
imagemagick
Debian:7
before 8:6.7.7.10-5+deb7u8, plus listed versions
8:6.7.7.10-58:6.7.7.10-5+deb7u28:6.7.7.10-5+deb7u38:6.7.7.10-5+deb7u48:6.7.7.10-5+deb7u58:6.7.7.10-5+deb7u68:6.7.7.10-5+deb7u7
8:6.7.7.10-5+deb7u8
imagemagick
Debian:8
before 8:6.8.9.9-5+deb8u5, plus listed versions
8:6.8.9.9-58:6.8.9.9-5+deb8u18:6.8.9.9-5+deb8u28:6.8.9.9-5+deb8u38:6.8.9.9-5+deb8u4
8:6.8.9.9-5+deb8u5
converseen
Mageia:6
before 0.9.6.2-1.3.mga6
0.9.6.2-1.3.mga6
cuneiform-linux
Mageia:6
before 1.1.0-9.2.mga6
1.1.0-9.2.mga6
dvdauthor
Mageia:6
before 0.7.2-2.2.mga6
0.7.2-2.2.mga6
emacs
Mageia:6
before 24.5-8.3.mga6
24.5-8.3.mga6
imagemagick
Mageia:6
before 6.9.9.41-1.mga6
6.9.9.41-1.mga6
Show 17 moreShow less
Affected packages
PackageAffectedFixed
inkscape
Mageia:6
before 0.92.1-2.2.mga6
0.92.1-2.2.mga6
k3d
Mageia:6
before 0.8.0.5-5.2.mga6
0.8.0.5-5.2.mga6
kxstitch
Mageia:6
before 2.0.0-2.2.mga6
2.0.0-2.2.mga6
libopenshot
Mageia:6
before 0.1.8-1.2.mga6
0.1.8-1.2.mga6
ocaml-glmlite
Mageia:6
before 0.03.51-17.2.mga6
0.03.51-17.2.mga6
perl-Image-SubImageFind
Mageia:6
before 0.30.0-6.2.mga6
0.30.0-6.2.mga6
pfstools
Mageia:6
before 2.0.6-3.2.mga6
2.0.6-3.2.mga6
php-imagick
Mageia:6
before 3.4.1-6.2.mga6
3.4.1-6.2.mga6
php-magickwand
Mageia:6
before 1.0.9.2-10.2.mga6
1.0.9.2-10.2.mga6
psiconv
Mageia:6
before 0.9.8-26.2.mga6
0.9.8-26.2.mga6
pythonmagick
Mageia:6
before 0.9.12-7.2.mga6
0.9.12-7.2.mga6
ruby-rmagick
Mageia:6
before 2.15.4-12.2.mga6
2.15.4-12.2.mga6
synfig
Mageia:6
before 1.2.1-2.2.mga6
1.2.1-2.2.mga6
vdr-plugin-skinelchi
Mageia:6
before 0.2.8-8.2.mga6
0.2.8-8.2.mga6
vdr-plugin-skinenigmang
Mageia:6
before 0.1.2-10.2.mga6
0.1.2-10.2.mga6
imagemagick
Ubuntu:14.04:LTS
before 8:6.7.7.10-6ubuntu3.2, plus listed versions
8:6.7.7.10-5ubuntu38:6.7.7.10-5ubuntu48:6.7.7.10-6ubuntu18:6.7.7.10-6ubuntu28:6.7.7.10-6ubuntu38:6.7.7.10-6ubuntu3.1
8:6.7.7.10-6ubuntu3.2
imagemagick
Ubuntu:16.04:LTS
before 8:6.8.9.9-7ubuntu5.2, plus listed versions
8:6.8.9.9-5ubuntu28:6.8.9.9-68:6.8.9.9-6build18:6.8.9.9-78:6.8.9.9-7ubuntu1
Show 5 moreShow less
8:6.8.9.9-7ubuntu28:6.8.9.9-7ubuntu38:6.8.9.9-7ubuntu48:6.8.9.9-7ubuntu58:6.8.9.9-7ubuntu5.1
8:6.8.9.9-7ubuntu5.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-10057 is a high vulnerability (CVSS 7.8) in Imagemagick, published September 23, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.73%, the 77th percentile. Fixed in imagemagick 8:6.9.6.2+dfsg-2.

References

Show 8 moreShow less
MoveEnter Open