CVE-2016-10053
The WriteTIFFImage function in coders/tiff.c in ImageMagick before 6.9.5-8 allows remote...
The WriteTIFFImage function in coders/tiff.c in ImageMagick before 6.9.5-8 allows remote attackers to cause a denial of service (divide-by-zero error and application crash) via a crafted file.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
5.5
The WriteTIFFImage function in coders/tiff.c in ImageMagick before 6.9.5-8 allows remote attackers to cause a denial of service (divide-by-zero error and application crash) via a crafted file.
- Record
CVE-2016-10053- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-369
- Updated
- 2026-11-02
CVE List No score
The WriteTIFFImage function in coders/tiff.c in ImageMagick before 6.9.5-8 allows remote attackers to cause a denial of service (divide-by-zero error and application crash) via a crafted file.
- Record
CVE-2016-10053- Updated
- 2026-11-02
EUVDEUVD-2016-1247 No score
The WriteTIFFImage function in coders/tiff.c in ImageMagick before 6.9.5-8 allows remote attackers to cause a denial of service (divide-by-zero error and application crash) via a crafted file.
- Record
EUVD-2016-1247- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-f2ph-29cp-7gx9
5.5
The WriteTIFFImage function in coders/tiff.c in ImageMagick before 6.9.5-8 allows remote...
The WriteTIFFImage function in coders/tiff.c in ImageMagick before 6.9.5-8 allows remote attackers to cause a denial of service (divide-by-zero error and application crash) via a crafted file.
- Record
GHSA-f2ph-29cp-7gx9- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-369
- Updated
- 2026-11-02
OSV
5.5
The WriteTIFFImage function in coders/tiff.c in ImageMagick before 6.9.5-8 allows remote attackers to cause a denial of service (divide-by-zero error and application crash) via a crafted file.
- Record
CVE-2016-10053- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2016-10053
5.5
The WriteTIFFImage function in coders/tiff.c in ImageMagick before 6.9.5-8 allows remote attackers to cause a denial of service (divide-by-zero error and application crash) via a crafted file.
- Record
DEBIAN-CVE-2016-10053- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-10053
5.5
The WriteTIFFImage function in coders/tiff.c in ImageMagick before 6.9.5-8 allows remote attackers to cause a denial of service (divide-by-zero error and application crash) via a crafted file.
- Record
UBUNTU-CVE-2016-10053- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVMGASA-2018-0229 No score
Updated imagemagick packages fix security vulnerabilities
The imagemagick package has been updated to version 6.9.9.41 which fixes several unspecified security vulnerabilities. This update fixes several vulnerabilities in imagemagick, including: Various memory handling problems and cases of missing or incomplete input sanitising may result in denial of service, memory disclosure or the execution of arbitrary code if malformed GIF, TTF, SVG, TIFF, PCX, JPG or SFW files are processed.
Several packages have been rebuilt for the updated ImageMagick.
- Record
MGASA-2018-0229- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
imagemagickDebian:12 |
before 8:6.9.6.2+dfsg-2 | 8:6.9.6.2+dfsg-2 |
imagemagickDebian:13 |
before 8:6.9.6.2+dfsg-2 | 8:6.9.6.2+dfsg-2 |
imagemagickDebian:14 |
before 8:6.9.6.2+dfsg-2 | 8:6.9.6.2+dfsg-2 |
imagemagickDebian:8 |
before 8:6.8.9.9-5+deb8u5, plus listed versions 8:6.8.9.9-58:6.8.9.9-5+deb8u18:6.8.9.9-5+deb8u28:6.8.9.9-5+deb8u38:6.8.9.9-5+deb8u4 |
8:6.8.9.9-5+deb8u5 |
converseenMageia:6 |
before 0.9.6.2-1.3.mga6 | 0.9.6.2-1.3.mga6 |
cuneiform-linuxMageia:6 |
before 1.1.0-9.2.mga6 | 1.1.0-9.2.mga6 |
dvdauthorMageia:6 |
before 0.7.2-2.2.mga6 | 0.7.2-2.2.mga6 |
emacsMageia:6 |
before 24.5-8.3.mga6 | 24.5-8.3.mga6 |
imagemagickMageia:6 |
before 6.9.9.41-1.mga6 | 6.9.9.41-1.mga6 |
inkscapeMageia:6 |
before 0.92.1-2.2.mga6 | 0.92.1-2.2.mga6 |
Show 15 moreShow less
| Package | Affected | Fixed |
|---|---|---|
k3dMageia:6 |
before 0.8.0.5-5.2.mga6 | 0.8.0.5-5.2.mga6 |
kxstitchMageia:6 |
before 2.0.0-2.2.mga6 | 2.0.0-2.2.mga6 |
libopenshotMageia:6 |
before 0.1.8-1.2.mga6 | 0.1.8-1.2.mga6 |
ocaml-glmliteMageia:6 |
before 0.03.51-17.2.mga6 | 0.03.51-17.2.mga6 |
perl-Image-SubImageFindMageia:6 |
before 0.30.0-6.2.mga6 | 0.30.0-6.2.mga6 |
pfstoolsMageia:6 |
before 2.0.6-3.2.mga6 | 2.0.6-3.2.mga6 |
php-imagickMageia:6 |
before 3.4.1-6.2.mga6 | 3.4.1-6.2.mga6 |
php-magickwandMageia:6 |
before 1.0.9.2-10.2.mga6 | 1.0.9.2-10.2.mga6 |
psiconvMageia:6 |
before 0.9.8-26.2.mga6 | 0.9.8-26.2.mga6 |
pythonmagickMageia:6 |
before 0.9.12-7.2.mga6 | 0.9.12-7.2.mga6 |
ruby-rmagickMageia:6 |
before 2.15.4-12.2.mga6 | 2.15.4-12.2.mga6 |
synfigMageia:6 |
before 1.2.1-2.2.mga6 | 1.2.1-2.2.mga6 |
vdr-plugin-skinelchiMageia:6 |
before 0.2.8-8.2.mga6 | 0.2.8-8.2.mga6 |
vdr-plugin-skinenigmangMageia:6 |
before 0.1.2-10.2.mga6 | 0.1.2-10.2.mga6 |
imagemagickUbuntu:16.04:LTS |
before 8:6.8.9.9-7ubuntu5.2, plus listed versions 8:6.8.9.9-5ubuntu28:6.8.9.9-68:6.8.9.9-6build18:6.8.9.9-78:6.8.9.9-7ubuntu1 Show 5 moreShow less8:6.8.9.9-7ubuntu28:6.8.9.9-7ubuntu38:6.8.9.9-7ubuntu48:6.8.9.9-7ubuntu58:6.8.9.9-7ubuntu5.1 |
8:6.8.9.9-7ubuntu5.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-10053 is a medium vulnerability (CVSS 5.5) in Imagemagick, published September 23, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.65%, the 76th percentile. Fixed in imagemagick 8:6.9.6.2+dfsg-2.
References
github.com/ImageMagick/ImageMagick/commit/f983dcdf9c178e0cbc49608a78713c5669aa1bb5
bugzilla.redhat.com/show_bug.cgi?id=1410461
securityfocus.com/bid/95179
openwall.com/lists/oss-security/2016/12/26/9
github.com/ImageMagick/ImageMagick/commit/728dc6a600cf4cbdac846964c85cc04339db8ac1
nvd.nist.gov/vuln/detail/CVE-2016-10053
Show 8 moreShow less
github.com/advisories/GHSA-f2ph-29cp-7gx9
security-tracker.debian.org/tracker/CVE-2016-10053
advisories.mageia.org/MGASA-2018-0229.html
bugs.mageia.org/show_bug.cgi?id=19078
git.imagemagick.org/repos/ImageMagick/blob/ImageMagick-6/ChangeLog
ubuntu.com/security/CVE-2016-10053
openwall.com/lists/oss-security/2016/12/20/3
cve.org/CVERecord?id=CVE-2016-10053