Every CVE Search/ Get API key

CVE-2016-10189

BitlBee before 3.5 allows remote attackers to cause a denial of service (NULL pointer dereference...

7.5 HighFix available

CVE-2016-10189 is a high vulnerability (CVSS 7.5) in Bitlbee, published February 20, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.04%, the 90th percentile. Fixed in bitlbee 3.5-1.

BitlBee before 3.5 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) and possibly execute arbitrary code via a file transfer request for a contact that is not in the contact list.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

4.04%Down 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

BitlBee before 3.5 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) and possibly execute arbitrary code via a file transfer request for a contact that is not in the contact list.

Record
CVE-2016-10189
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-476
Updated
2026-11-02
CVE List No score

BitlBee before 3.5 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) and possibly execute arbitrary code via a file transfer request for a contact that is not in the contact list.

Record
CVE-2016-10189
Updated
2026-11-02
EUVDEUVD-2016-1376 No score

BitlBee before 3.5 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) and possibly execute arbitrary code via a file transfer request for a contact that is not in the contact list.

Record
EUVD-2016-1376
Updated
2026-11-03
GitHub AdvisoriesGHSA-f3fv-7pqw-59cx 7.5

BitlBee before 3.5 allows remote attackers to cause a denial of service (NULL pointer dereference...

BitlBee before 3.5 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) and possibly execute arbitrary code via a file transfer request for a contact that is not in the contact list.

Record
GHSA-f3fv-7pqw-59cx
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-476
Updated
2026-11-02
OSV 7.5

BitlBee before 3.5 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) and possibly execute arbitrary code via a file transfer request for a contact that is not in the contact list.

Record
CVE-2016-10189
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-03
OSVDEBIAN-CVE-2016-10189 7.5

BitlBee before 3.5 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) and possibly execute arbitrary code via a file transfer request for a contact that is not in the contact list.

Record
DEBIAN-CVE-2016-10189
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-10189 7.5

BitlBee before 3.5 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) and possibly execute arbitrary code via a file transfer request for a contact that is not in the contact list.

Record
UBUNTU-CVE-2016-10189
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-03
OSVMGASA-2017-0200 No score

Updated bitlbee packages fix security vulnerability

It was discovered that bitlbee contained issues that allowed a remote attacker to cause a denial of service (via application crash), or potentially execute arbitrary commands (CVE-2016-10188, CVE-2016-10189).

Record
MGASA-2017-0200
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
bitlbee
Debian:12
before 3.5-1
3.5-1
bitlbee
Debian:13
before 3.5-1
3.5-1
bitlbee
Debian:7
before 3.0.5-1.2+deb7u1, plus listed versions
3.0.5-1.2
3.0.5-1.2+deb7u1
bitlbee
Debian:8
before 3.2.2-2+deb8u1, plus listed versions
3.2.2-2
3.2.2-2+deb8u1
bitlbee
Mageia:5
before 3.2.2-4.1.mga5
3.2.2-4.1.mga5
bitlbee
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
3.4.1-13.4.1-1build13.4.2-0ubuntu13.4.2-0ubuntu1+esm1
None known

History

History
WhenChangedSources
2026-11-03affected, factsOSV
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 8 moreShow less
MoveEnter Open