CVE-2016-10189
BitlBee before 3.5 allows remote attackers to cause a denial of service (NULL pointer dereference...
CVE-2016-10189 is a high vulnerability (CVSS 7.5) in Bitlbee, published February 20, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.04%, the 90th percentile. Fixed in bitlbee 3.5-1.
BitlBee before 3.5 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) and possibly execute arbitrary code via a file transfer request for a contact that is not in the contact list.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
BitlBee before 3.5 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) and possibly execute arbitrary code via a file transfer request for a contact that is not in the contact list.
- Record
CVE-2016-10189- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-476
- Updated
- 2026-11-02
CVE List No score
BitlBee before 3.5 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) and possibly execute arbitrary code via a file transfer request for a contact that is not in the contact list.
- Record
CVE-2016-10189- Updated
- 2026-11-02
EUVDEUVD-2016-1376 No score
BitlBee before 3.5 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) and possibly execute arbitrary code via a file transfer request for a contact that is not in the contact list.
- Record
EUVD-2016-1376- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-f3fv-7pqw-59cx
7.5
BitlBee before 3.5 allows remote attackers to cause a denial of service (NULL pointer dereference...
BitlBee before 3.5 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) and possibly execute arbitrary code via a file transfer request for a contact that is not in the contact list.
- Record
GHSA-f3fv-7pqw-59cx- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-476
- Updated
- 2026-11-02
OSV
7.5
BitlBee before 3.5 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) and possibly execute arbitrary code via a file transfer request for a contact that is not in the contact list.
- Record
CVE-2016-10189- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-03
OSVDEBIAN-CVE-2016-10189
7.5
BitlBee before 3.5 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) and possibly execute arbitrary code via a file transfer request for a contact that is not in the contact list.
- Record
DEBIAN-CVE-2016-10189- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-10189
7.5
BitlBee before 3.5 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) and possibly execute arbitrary code via a file transfer request for a contact that is not in the contact list.
- Record
UBUNTU-CVE-2016-10189- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-04
OSVMGASA-2017-0200 No score
Updated bitlbee packages fix security vulnerability
It was discovered that bitlbee contained issues that allowed a remote attacker to cause a denial of service (via application crash), or potentially execute arbitrary commands (CVE-2016-10188, CVE-2016-10189).
- Record
MGASA-2017-0200- Updated
- 2026-11-02
OSVUSN-8977-1 No score
bitlbee vulnerabilities
It was discovered that BitlBee incorrectly handled file transfer connections that expired when built with libpurple. A remote attacker could possibly use this issue to cause BitlBee to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2016-10188)
It was discovered that BitlBee incorrectly handled file transfer requests for contacts that were not in the contact list. A remote attacker could possibly use this issue to cause BitlBee to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2016-10189)
- Record
USN-8977-1- Updated
- 2026-11-04
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
bitlbeeDebian:12 |
before 3.5-1 | 3.5-1 |
bitlbeeDebian:13 |
before 3.5-1 | 3.5-1 |
bitlbeeDebian:7 |
before 3.0.5-1.2+deb7u1, plus listed versions 3.0.5-1.2 |
3.0.5-1.2+deb7u1 |
bitlbeeDebian:8 |
before 3.2.2-2+deb8u1, plus listed versions 3.2.2-2 |
3.2.2-2+deb8u1 |
bitlbeeMageia:5 |
before 3.2.2-4.1.mga5 | 3.2.2-4.1.mga5 |
bitlbeeUbuntu:Pro:16.04:LTS |
before 3.4.2-0ubuntu1+esm1, plus listed versions 3.4.1-13.4.1-1build13.4.2-0ubuntu1 |
3.4.2-0ubuntu1+esm1 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-04 | affected, aliases, references | OSV |
| 2026-11-03 | affected, facts | OSV |
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
securityfocus.com/bid/95931
bugs.bitlbee.org/ticket/1282
debian.org/security/2017/dsa-3853
github.com/bitlbee/bitlbee/commit/701ab8129ba9ea64f569daedca9a8603abad740f
openwall.com/lists/oss-security/2017/01/31/11
openwall.com/lists/oss-security/2017/01/30/4
Show 10 moreShow less
nvd.nist.gov/vuln/detail/CVE-2016-10189
github.com/advisories/GHSA-f3fv-7pqw-59cx
security-tracker.debian.org/tracker/CVE-2016-10189
advisories.mageia.org/MGASA-2017-0200.html
bugs.mageia.org/show_bug.cgi?id=20226
ubuntu.com/security/CVE-2016-10189
github.com/bitlbee/bitlbee/commit/30d598ce7cd3f136ee9d7097f39fa9818a272441
cve.org/CVERecord?id=CVE-2016-10189
ubuntu.com/security/notices/USN-8977-1
ubuntu.com/security/CVE-2016-10188