CVE-2016-10188
Use-after-free vulnerability in bitlbee-libpurple before 3.5 allows remote servers to cause a...
Use-after-free vulnerability in bitlbee-libpurple before 3.5 allows remote servers to cause a denial of service (crash) or possibly execute arbitrary code by causing a file transfer connection to expire.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Use-after-free vulnerability in bitlbee-libpurple before 3.5 allows remote servers to cause a denial of service (crash) or possibly execute arbitrary code by causing a file transfer connection to expire.
- Record
CVE-2016-10188- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-416
- Updated
- 2026-11-02
CVE List No score
Use-after-free vulnerability in bitlbee-libpurple before 3.5 allows remote servers to cause a denial of service (crash) or possibly execute arbitrary code by causing a file transfer connection to expire.
- Record
CVE-2016-10188- Updated
- 2026-11-02
EUVDEUVD-2016-1375 No score
Use-after-free vulnerability in bitlbee-libpurple before 3.5 allows remote servers to cause a denial of service (crash) or possibly execute arbitrary code by causing a file transfer connection to expire.
- Record
EUVD-2016-1375- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5m6p-94pg-48mf
9.8
Use-after-free vulnerability in bitlbee-libpurple before 3.5 allows remote servers to cause a...
Use-after-free vulnerability in bitlbee-libpurple before 3.5 allows remote servers to cause a denial of service (crash) or possibly execute arbitrary code by causing a file transfer connection to expire.
- Record
GHSA-5m6p-94pg-48mf- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-416
- Updated
- 2026-11-02
OSV
9.8
Use-after-free vulnerability in bitlbee-libpurple before 3.5 allows remote servers to cause a denial of service (crash) or possibly execute arbitrary code by causing a file transfer connection to expire.
- Record
CVE-2016-10188- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
OSVDEBIAN-CVE-2016-10188
9.8
Use-after-free vulnerability in bitlbee-libpurple before 3.5 allows remote servers to cause a denial of service (crash) or possibly execute arbitrary code by causing a file transfer connection to expire.
- Record
DEBIAN-CVE-2016-10188- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-10188
9.8
Use-after-free vulnerability in bitlbee-libpurple before 3.5 allows remote servers to cause a denial of service (crash) or possibly execute arbitrary code by causing a file transfer connection to expire.
- Record
UBUNTU-CVE-2016-10188- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-04
OSVMGASA-2017-0200 No score
Updated bitlbee packages fix security vulnerability
It was discovered that bitlbee contained issues that allowed a remote attacker to cause a denial of service (via application crash), or potentially execute arbitrary commands (CVE-2016-10188, CVE-2016-10189).
- Record
MGASA-2017-0200- Updated
- 2026-11-02
OSVUSN-8977-1 No score
bitlbee vulnerabilities
It was discovered that BitlBee incorrectly handled file transfer connections that expired when built with libpurple. A remote attacker could possibly use this issue to cause BitlBee to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2016-10188)
It was discovered that BitlBee incorrectly handled file transfer requests for contacts that were not in the contact list. A remote attacker could possibly use this issue to cause BitlBee to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2016-10189)
- Record
USN-8977-1- Updated
- 2026-11-04
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
bitlbeeDebian:12 |
before 3.5-1 | 3.5-1 |
bitlbeeDebian:13 |
before 3.5-1 | 3.5-1 |
bitlbeeDebian:7 |
before 3.0.5-1.2+deb7u1, plus listed versions 3.0.5-1.2 |
3.0.5-1.2+deb7u1 |
bitlbeeDebian:8 |
before 3.2.2-2+deb8u1, plus listed versions 3.2.2-2 |
3.2.2-2+deb8u1 |
bitlbeeMageia:5 |
before 3.2.2-4.1.mga5 | 3.2.2-4.1.mga5 |
bitlbeeUbuntu:Pro:16.04:LTS |
before 3.4.2-0ubuntu1+esm1, plus listed versions 3.4.1-13.4.1-1build13.4.2-0ubuntu1 |
3.4.2-0ubuntu1+esm1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, aliases, references | OSV | |
| affected, facts | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-10188 is a critical vulnerability (CVSS 9.8) in Bitlbee, published February 20, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.94%, the 87th percentile. Fixed in bitlbee 3.5-1.
References
debian.org/security/2017/dsa-3853
securityfocus.com/bid/95935
bugs.bitlbee.org/ticket/1281
openwall.com/lists/oss-security/2017/01/31/11
openwall.com/lists/oss-security/2017/01/30/4
nvd.nist.gov/vuln/detail/CVE-2016-10188
Show 8 moreShow less
github.com/advisories/GHSA-5m6p-94pg-48mf
security-tracker.debian.org/tracker/CVE-2016-10188
advisories.mageia.org/MGASA-2017-0200.html
bugs.mageia.org/show_bug.cgi?id=20226
ubuntu.com/security/CVE-2016-10188
cve.org/CVERecord?id=CVE-2016-10188
ubuntu.com/security/notices/USN-8977-1
ubuntu.com/security/CVE-2016-10189