CVE-2016-1231
Directory traversal vulnerability in the HTTP file-serving module (mod_http_files) in Prosody 0.9...
Directory traversal vulnerability in the HTTP file-serving module (mod_http_files) in Prosody 0.9.x before 0.9.9 allows remote attackers to read arbitrary files via a .. (dot dot) in an unspecified path.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.9
Directory traversal vulnerability in the HTTP file-serving module (mod_http_files) in Prosody 0.9.x before 0.9.9 allows remote attackers to read arbitrary files via a .. (dot dot) in an unspecified path.
- Record
CVE-2016-1231- CVSS 3.0
- 5.9 Medium
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:P/I:N/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
CVE List No score
Directory traversal vulnerability in the HTTP file-serving module (mod_http_files) in Prosody 0.9.x before 0.9.9 allows remote attackers to read arbitrary files via a .. (dot dot) in an unspecified path.
- Record
CVE-2016-1231- Updated
- 2026-11-02
EUVDEUVD-2016-2332 No score
Directory traversal vulnerability in the HTTP file-serving module (mod_http_files) in Prosody 0.9.x before 0.9.9 allows remote attackers to read arbitrary files via a .. (dot dot) in an unspecified path.
- Record
EUVD-2016-2332- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-8q2g-4r27-6vpc
5.9
Directory traversal vulnerability in the HTTP file-serving module (mod_http_files) in Prosody 0.9...
Directory traversal vulnerability in the HTTP file-serving module (mod_http_files) in Prosody 0.9.x before 0.9.9 allows remote attackers to read arbitrary files via a .. (dot dot) in an unspecified path.
- Record
GHSA-8q2g-4r27-6vpc- CVSS 3.0
- 5.9 Medium
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
OSV
5.9
Directory traversal vulnerability in the HTTP file-serving module (mod_http_files) in Prosody 0.9.x before 0.9.9 allows remote attackers to read arbitrary files via a .. (dot dot) in an unspecified path.
- Record
CVE-2016-1231- CVSS 3.0
- 5.9 Medium
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2016-1231
5.9
Directory traversal vulnerability in the HTTP file-serving module (mod_http_files) in Prosody 0.9.x before 0.9.9 allows remote attackers to read arbitrary files via a .. (dot dot) in an unspecified path.
- Record
DEBIAN-CVE-2016-1231- CVSS 3.0
- 5.9 Medium
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-1231
5.9
Directory traversal vulnerability in the HTTP file-serving module (mod_http_files) in Prosody 0.9.x before 0.9.9 allows remote attackers to read arbitrary files via a .. (dot dot) in an unspecified path.
- Record
UBUNTU-CVE-2016-1231- CVSS 3.0
- 5.9 Medium
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10489-1 No score
prosody-0.9.11-1.1 on GA media
These are all security issues fixed in the prosody-0.9.11-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10489-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
prosodyDebian:12 |
before 0.9.9-1 | 0.9.9-1 |
prosodyDebian:13 |
before 0.9.9-1 | 0.9.9-1 |
prosodyDebian:14 |
before 0.9.9-1 | 0.9.9-1 |
prosodyDebian:7 |
before 0.8.2-4+deb7u3, plus listed versions 0.8.2-40.8.2-4+deb7u10.8.2-4+deb7u2 |
0.8.2-4+deb7u3 |
prosodyDebian:8 |
before 0.9.7-2+deb8u2, plus listed versions 0.9.7-20.9.7-2+deb8u1 |
0.9.7-2+deb8u2 |
prosodyUbuntu:14.04:LTS |
before 0.9.1-1ubuntu0.1, plus listed versions 0.8.2-40.9.1-1 |
0.9.1-1ubuntu0.1 |
prosodyopenSUSE:Tumbleweed |
before 0.9.11-1.1 | 0.9.11-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-1231 is a medium vulnerability (CVSS 5.9) in Prosody, published January 10, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.87%, the 86th percentile. Fixed in prosody 0.9.9-1.
References
lists.fedoraproject.org/pipermail/package-announce/2016-January/175868.html
prosody.im/issues/issue/520
lists.fedoraproject.org/pipermail/package-announce/2016-January/175829.html
debian.org/security/2016/dsa-3439
blog.prosody.im/prosody-0-9-9-security-release
prosody.im/security/advisory_20160108-1
Show 9 moreShow less
openwall.com/lists/oss-security/2016/01/08/5
nvd.nist.gov/vuln/detail/CVE-2016-1231
github.com/advisories/GHSA-8q2g-4r27-6vpc
security-tracker.debian.org/tracker/CVE-2016-1231
ubuntu.com/security/CVE-2016-1231
cve.org/CVERecord?id=CVE-2016-1231
suse.com/security/cve/CVE-2016-0756
suse.com/security/cve/CVE-2016-1231
suse.com/security/cve/CVE-2016-1232