Every CVE Search/ Get API key

CVE-2016-1232

The mod_dialback module in Prosody before 0.9.9 does not properly generate random values for the...

7.5 HighFix available

The mod_dialback module in Prosody before 0.9.9 does not properly generate random values for the secret token for server-to-server dialback authentication, which makes it easier for attackers to spoof servers via a brute force attack.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

2.18%Up 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

The mod_dialback module in Prosody before 0.9.9 does not properly generate random values for the secret token for server-to-server dialback authentication, which makes it easier for attackers to spoof servers via a brute force attack.

Record
CVE-2016-1232
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Updated
2026-11-02
CVE List No score

The mod_dialback module in Prosody before 0.9.9 does not properly generate random values for the secret token for server-to-server dialback authentication, which makes it easier for attackers to spoof servers via a brute force attack.

Record
CVE-2016-1232
Updated
2026-11-02
EUVDEUVD-2016-2333 No score

The mod_dialback module in Prosody before 0.9.9 does not properly generate random values for the secret token for server-to-server dialback authentication, which makes it easier for attackers to spoof servers via a brute force attack.

Record
EUVD-2016-2333
Updated
2026-11-03
GitHub AdvisoriesGHSA-qwj6-64m3-hwxr 7.5

The mod_dialback module in Prosody before 0.9.9 does not properly generate random values for the...

The mod_dialback module in Prosody before 0.9.9 does not properly generate random values for the secret token for server-to-server dialback authentication, which makes it easier for attackers to spoof servers via a brute force attack.

Record
GHSA-qwj6-64m3-hwxr
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSV 7.5

The mod_dialback module in Prosody before 0.9.9 does not properly generate random values for the secret token for server-to-server dialback authentication, which makes it easier for attackers to spoof servers via a brute force attack.

Record
CVE-2016-1232
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2016-1232 7.5

The mod_dialback module in Prosody before 0.9.9 does not properly generate random values for the secret token for server-to-server dialback authentication, which makes it easier for attackers to spoof servers via a brute force attack.

Record
DEBIAN-CVE-2016-1232
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2016-1232 7.5

The mod_dialback module in Prosody before 0.9.9 does not properly generate random values for the secret token for server-to-server dialback authentication, which makes it easier for attackers to spoof servers via a brute force attack.

Record
UBUNTU-CVE-2016-1232
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVopenSUSE-SU-2024:10489-1 No score

prosody-0.9.11-1.1 on GA media

These are all security issues fixed in the prosody-0.9.11-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10489-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
prosody
Debian:12
before 0.9.9-1
0.9.9-1
prosody
Debian:13
before 0.9.9-1
0.9.9-1
prosody
Debian:14
before 0.9.9-1
0.9.9-1
prosody
Debian:6.0
before 0.7.0-1squeeze1+deb6u1, plus listed versions
0.7.0-10.7.0-1squeeze1
0.7.0-1squeeze1+deb6u1
prosody
Debian:7
before 0.8.2-4+deb7u3, plus listed versions
0.8.2-40.8.2-4+deb7u10.8.2-4+deb7u2
0.8.2-4+deb7u3
prosody
Debian:8
before 0.9.7-2+deb8u2, plus listed versions
0.9.7-20.9.7-2+deb8u1
0.9.7-2+deb8u2
prosody
Ubuntu:14.04:LTS
before 0.9.1-1ubuntu0.1, plus listed versions
0.8.2-40.9.1-1
0.9.1-1ubuntu0.1
prosody
openSUSE:Tumbleweed
before 0.9.11-1.1
0.9.11-1.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-1232 is a high vulnerability (CVSS 7.5) in Prosody, published January 10, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.18%, the 82nd percentile. Fixed in prosody 0.9.9-1.

References

Show 9 moreShow less
MoveEnter Open