CVE-2016-1907
The ssh_packet_read_poll2 function in packet.c in OpenSSH before 7.1p2 allows remote attackers to...
CVE-2016-1907 is a medium vulnerability (CVSS 5.3) in Openbsd Openssh, published January 19, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 14.3%, the 96th percentile. Fixed in openssh 6.8_p1-r10.
The ssh_packet_read_poll2 function in packet.c in OpenSSH before 7.1p2 allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via crafted network traffic.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- Low
Exploit likelihood
What each source reports
NVD Score used
5.3
The ssh_packet_read_poll2 function in packet.c in OpenSSH before 7.1p2 allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via crafted network traffic.
- Record
CVE-2016-1907- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
The ssh_packet_read_poll2 function in packet.c in OpenSSH before 7.1p2 allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via crafted network traffic.
- Record
CVE-2016-1907- Updated
- 2026-11-02
EUVDEUVD-2016-2998 No score
The ssh_packet_read_poll2 function in packet.c in OpenSSH before 7.1p2 allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via crafted network traffic.
- Record
EUVD-2016-2998- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3xwc-hv27-5fhw
5.3
The ssh_packet_read_poll2 function in packet.c in OpenSSH before 7.1p2 allows remote attackers to...
The ssh_packet_read_poll2 function in packet.c in OpenSSH before 7.1p2 allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via crafted network traffic.
- Record
GHSA-3xwc-hv27-5fhw- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-119
- Updated
- 2026-11-02
OSVALPINE-CVE-2016-1907
5.3
The ssh_packet_read_poll2 function in packet.c in OpenSSH before 7.1p2 allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via crafted network traffic.
- Record
ALPINE-CVE-2016-1907- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
OSV
5.3
The ssh_packet_read_poll2 function in packet.c in OpenSSH before 7.1p2 allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via crafted network traffic.
- Record
CVE-2016-1907- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
OSVDEBIAN-CVE-2016-1907
5.3
The ssh_packet_read_poll2 function in packet.c in OpenSSH before 7.1p2 allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via crafted network traffic.
- Record
DEBIAN-CVE-2016-1907- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-1907
5.3
The ssh_packet_read_poll2 function in packet.c in OpenSSH before 7.1p2 allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via crafted network traffic.
- Record
UBUNTU-CVE-2016-1907- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
OSVUSN-2966-1 No score
openssh vulnerabilities
Shayan Sadigh discovered that OpenSSH incorrectly handled environment files when the UseLogin feature is enabled. A local attacker could use this issue to gain privileges. (CVE-2015-8325)
Ben Hawkes discovered that OpenSSH incorrectly handled certain network traffic. A remote attacker could possibly use this issue to cause OpenSSH to crash, resulting in a denial of service. This issue only applied to Ubuntu 15.10. (CVE-2016-1907)
Thomas Hoger discovered that OpenSSH incorrectly handled untrusted X11 forwarding when the SECURITY extension is disabled. A connection configured as being untrusted could get switched to trusted in certain scenarios, contrary to expectations. (CVE-2016-1908)
It was discovered that OpenSSH incorrectly handled certain X11 forwarding data. A remote authenticated attacker could possibly use this issue to bypass certain intended command restrictions. (CVE-2016-3115)
- Record
USN-2966-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
opensshAlpine:v3.2 |
before 6.8_p1-r10 | 6.8_p1-r10 |
opensshDebian:12 |
before 1:7.1p2-1 | 1:7.1p2-1 |
opensshDebian:13 |
before 1:7.1p2-1 | 1:7.1p2-1 |
opensshDebian:14 |
before 1:7.1p2-1 | 1:7.1p2-1 |
opensshUbuntu:14.04:LTS |
before 1:6.6p1-2ubuntu2.7, plus listed versions 1:6.2p2-61:6.2p2-6ubuntu11:6.4p1-11:6.4p1-21:6.5p1-1 Show 12 moreShow less1:6.5p1-21:6.5p1-31:6.5p1-41:6.5p1-61:6.6p1-11:6.6p1-21:6.6p1-2ubuntu11:6.6p1-2ubuntu21:6.6p1-2ubuntu2.21:6.6p1-2ubuntu2.31:6.6p1-2ubuntu2.41:6.6p1-2ubuntu2.6 |
1:6.6p1-2ubuntu2.7 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | affected | |
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
securityfocus.com/bid/81293
lists.fedoraproject.org/pipermail/package-announce/2016-January/176349.html
h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05385680
lists.fedoraproject.org/pipermail/package-announce/2016-January/175676.html
openssh.com/txt/release-7.1p2
lists.fedoraproject.org/pipermail/package-announce/2016-February/176516.html
Show 16 moreShow less
bto.bluecoat.com/security-advisory/sa109
h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05390722
h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05356388
anongit.mindrot.org/openssh.git/commit?id=2fecfd486bdba9f51b3a789277bb0733ca36e1c0
cert-portal.siemens.com/productcert/pdf/ssa-412672.pdf
nvd.nist.gov/vuln/detail/CVE-2016-1907
github.com/advisories/GHSA-3xwc-hv27-5fhw
security.alpinelinux.org/vuln/CVE-2016-1907
security-tracker.debian.org/tracker/CVE-2016-1907
ubuntu.com/security/CVE-2016-1907
seclists.org/oss-sec/2016/q1/112
ubuntu.com/security/notices/USN-2966-1
cve.org/CVERecord?id=CVE-2016-1907
ubuntu.com/security/CVE-2015-8325
ubuntu.com/security/CVE-2016-1908
ubuntu.com/security/CVE-2016-3115