Every CVE Search/ Get API key

CVE-2016-3065

The (1) brin_page_type and (2) brin_metapage_info functions in the pageinspect extension in...

9.1 Critical

The (1) brin_page_type and (2) brin_metapage_info functions in the pageinspect extension in PostgreSQL before 9.5.x before 9.5.2 allows attackers to bypass intended access restrictions and consequently obtain sensitive server memory information or cause a denial of service (server crash) via a crafted bytea value in a BRIN index page.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
High

Exploit likelihood

4.05%Up 3.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.1

The (1) brin_page_type and (2) brin_metapage_info functions in the pageinspect extension in PostgreSQL before 9.5.x before 9.5.2 allows attackers to bypass intended access restrictions and consequently obtain sensitive server memory information or cause a denial of service (server crash) via a crafted bytea value in a BRIN index page.

Record
CVE-2016-3065
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
CVSS 2.0
8.5 HighAV:N/AC:L/Au:N/C:P/I:N/A:C
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

The (1) brin_page_type and (2) brin_metapage_info functions in the pageinspect extension in PostgreSQL before 9.5.x before 9.5.2 allows attackers to bypass intended access restrictions and consequently obtain sensitive server memory information or cause a denial of service (server crash) via a crafted bytea value in a BRIN index page.

Record
CVE-2016-3065
Updated
2026-11-02
EUVDEUVD-2016-4138 No score

The (1) brin_page_type and (2) brin_metapage_info functions in the pageinspect extension in PostgreSQL before 9.5.x before 9.5.2 allows attackers to bypass intended access restrictions and consequently obtain sensitive server memory information or cause a denial of service (server crash) via a crafted bytea value in a BRIN index page.

Record
EUVD-2016-4138
Updated
2026-11-03
GitHub AdvisoriesGHSA-8v7w-4wg8-q7v4 9.1

The (1) brin_page_type and (2) brin_metapage_info functions in the pageinspect extension in...

The (1) brin_page_type and (2) brin_metapage_info functions in the pageinspect extension in PostgreSQL before 9.5.x before 9.5.2 allows attackers to bypass intended access restrictions and consequently obtain sensitive server memory information or cause a denial of service (server crash) via a crafted bytea value in a BRIN index page.

Record
GHSA-8v7w-4wg8-q7v4
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVBELL-CVE-2016-3065 9.1

CVE-2016-3065 does not affect BellSoft software

Record
BELL-CVE-2016-3065
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVMGASA-2016-0136 No score

Updated postgresql packages fix security vulnerabilities

Updated postgresql packages fix security vulnerabilities:

A vulnerability in PostgreSQL 9.3.x before 9.3.12 and 9.4.x before 9.4.7 leads to potentially incorrect policies being applied in cases where role-specific policies are used and a given query is planned under one role and then executed under other roles, which could happen under security definer functions or when a common user and query is planned initially and then re-used across multiple SET ROLEs. Applying an incorrect policy may permit a user to complete otherwise-forbidden reads and modifications. This affects only databases that have used CREATE POLICY to define a row security policy (CVE-2016-2193).

A vulnerability was found in a way PostgreSQL 9.3.x before 9.3.12 and 9.4.x before 9.4.7 uses pageinspect functions. Certain function arguments crashed the server or disclosed a few bytes of server memory. The viability of attacks that arrange for presence of confidential information in the disclosed bytes was not ruled out. This affects only databases that have used "CREATE EXTENSION pageinspect" (CVE-2016-3065).

Record
MGASA-2016-0136
Updated
2026-11-02
OSVopenSUSE-SU-2024:10273-1 No score

libecpg6-32bit-9.5.4-1.2 on GA media

These are all security issues fixed in the libecpg6-32bit-9.5.4-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10273-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
postgresql9.3
Mageia:5
From an advisory covering 2 CVEs
before 9.3.12-1.mga5
9.3.12-1.mga5
postgresql9.4
Mageia:5
From an advisory covering 2 CVEs
before 9.4.7-1.mga5
9.4.7-1.mga5
postgresql95
openSUSE:Tumbleweed
From an advisory covering 37 CVEs
before 9.5.4-1.2
9.5.4-1.2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-3065 is a critical vulnerability (CVSS 9.1) in Postgresql, published April 11, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.05%, the 90th percentile. No source names a fixed version.

References

Show 43 moreShow less
MoveEnter Open