postgresql9.4 vulnerabilities (Mageia)
26 vulnerabilities.
-
postgresql9.4Mageia Postgresql, versions 11.x before 11.5, is vulnerable to a memory disclosure in cross-type... 3.1 Low -
postgresql9.4Mageia A flaw was discovered in postgresql where arbitrary SQL statements can be executed given a... 7.5 High -
postgresql9.4Mageia A vulnerability was found in postgresql versions 11.x prior to 11.3. Using a purpose-crafted... 6.5 Medium -
postgresql9.4Mageia A vulnerability was found in PostgreSQL versions 11.x up to excluding 11.3, 10.x up to excluding... 3.1 Low -
postgresql9.4Mageia It was discovered that PostgreSQL versions before 10.5, 9.6.10, 9.5.14, 9.4.19, and 9.3.24 failed... 7.1 High -
postgresql9.4Mageia A vulnerability was found in libpq, the default PostgreSQL client library where libpq failed to... 8.5 High -
postgresql9.4Mageia postgresql before versions 10.4, 9.6.9 is vulnerable in the adminpack extension, the pg_catalog... 4.2 Medium -
postgresql9.4Mageia A flaw was found in the way Postgresql allowed a user to modify the behavior of a query for other... 8.8 High -
postgresql9.4Mageia In postgresql 9.3.x before 9.3.21, 9.4.x before 9.4.16, 9.5.x before 9.5.11, 9.6.x before 9.6.7... 7.0 High -
postgresql9.4Mageia PostgreSQL 10.x before 10.1, 9.6.x before 9.6.6, 9.5.x before 9.5.10, 9.4.x before 9.4.15, 9.3.x... 6.7 Medium -
postgresql9.4Mageia INSERT ... ON CONFLICT DO UPDATE commands in PostgreSQL 10.x before 10.1, 9.6.x before 9.6.6, and... 6.5 Medium -
postgresql9.4Mageia Invalid json_populate_recordset or jsonb_populate_recordset function calls in PostgreSQL 10.x... 8.1 High -
postgresql9.4Mageia PostgreSQL versions before 9.4.13, 9.5.8 and 9.6.4 are vulnerable to authorization flaw allowing... 7.5 High -
postgresql9.4Mageia PostgreSQL versions before 9.2.22, 9.3.18, 9.4.13, 9.5.8 and 9.6.4 are vulnerable to... 8.8 High -
postgresql9.4Mageia PostgreSQL versions before 9.2.22, 9.3.18, 9.4.13, 9.5.8 and 9.6.4 are vulnerable to incorrect... 9.8 Critical -
postgresql9.4Mageia PostgreSQL versions 8.4 - 9.6 are vulnerable to information leak in pg_user_mappings view which... 7.5 High -
postgresql9.4Mageia In PostgreSQL 9.3.x before 9.3.17, 9.4.x before 9.4.12, 9.5.x before 9.5.7, and 9.6.x before 9.6... 5.9 Medium -
postgresql9.4Mageia It was found that some selectivity estimation functions in PostgreSQL before 9.2.21, 9.3.x before... 7.5 High -
postgresql9.4Mageia PostgreSQL before 9.1.23, 9.2.x before 9.2.18, 9.3.x before 9.3.14, 9.4.x before 9.4.9, and 9.5.x... 7.1 High -
postgresql9.4Mageia PostgreSQL before 9.1.23, 9.2.x before 9.2.18, 9.3.x before 9.3.14, 9.4.x before 9.4.9, and 9.5.x... 8.3 High -
postgresql9.4Mageia The (1) brin_page_type and (2) brin_metapage_info functions in the pageinspect extension in... 9.1 Critical -
postgresql9.4Mageia PostgreSQL before 9.5.x before 9.5.2 does not properly maintain row-security status in cached... 7.5 High -
postgresql9.4Mageia PostgreSQL before 9.1.20, 9.2.x before 9.2.15, 9.3.x before 9.3.11, 9.4.x before 9.4.6, and 9.5.x... 7.5 High -
postgresql9.4Mageia PostgreSQL before 9.1.20, 9.2.x before 9.2.15, 9.3.x before 9.3.11, 9.4.x before 9.4.6, and 9.5.x... 8.8 High -
postgresql9.4Mageia Multiple stack-based buffer overflows in json parsing in PostgreSQL before 9.3.x before 9.3.10... 6.4 Medium -
postgresql9.4Mageia The crypt function in contrib/pgcrypto in PostgreSQL before 9.0.23, 9.1.x before 9.1.19, 9.2.x... 6.4 Medium