Every CVE Search/ Get API key

CVE-2019-10209

Postgresql, versions 11.x before 11.5, is vulnerable to a memory disclosure in cross-type...

3.1 LowFix available

CVE-2019-10209 is a low vulnerability (CVSS 3.1) in Postgresql, published August 8, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.08%, the 65th percentile. Fixed in postgresql 11.5-r0.

Postgresql, versions 11.x before 11.5, is vulnerable to a memory disclosure in cross-type comparison for hashed subplan.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
None

Exploit likelihood

1.08%Up 0.5 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 3.1

Postgresql, versions 11.x before 11.5, is vulnerable to a memory disclosure in cross-type comparison for hashed subplan.

Record
CVE-2019-10209
CVSS 3.0
3.1 LowCVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-125, CWE-200
Updated
2026-11-02
EUVDEUVD-2019-2226 3.1

Postgresql, versions 11.x before 11.5, is vulnerable to a memory disclosure in cross-type comparison for hashed subplan.

Record
EUVD-2019-2226
CVSS 3.0
3.1 LowCVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-w4g8-53rg-h648 2.2

Postgresql, versions 11.x before 11.5, is vulnerable to a memory disclosure in cross-type...

Postgresql, versions 11.x before 11.5, is vulnerable to a memory disclosure in cross-type comparison for hashed subplan.

Record
GHSA-w4g8-53rg-h648
CVSS 3.1
2.2 LowCVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-125
Updated
2026-11-02
NVD 2.2

Postgresql, versions 11.x before 11.5, is vulnerable to a memory disclosure in cross-type comparison for hashed subplan.

Record
CVE-2019-10209
CVSS 3.1
2.2 LowCVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:N/A:N
CVSS 3.0
3.1 LowCVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:P/I:N/A:N
Weakness
CWE-125, CWE-200
Updated
2026-11-02
OSVALPINE-CVE-2019-10209 2.2

Postgresql, versions 11.x before 11.5, is vulnerable to a memory disclosure in cross-type comparison for hashed subplan.

Record
ALPINE-CVE-2019-10209
CVSS 3.1
2.2 LowCVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-03
OSVBELL-CVE-2019-10209 2.2

CVE-2019-10209 does not affect BellSoft software

Record
BELL-CVE-2019-10209
CVSS 3.1
2.2 LowCVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
OSV 2.2

Postgresql, versions 11.x before 11.5, is vulnerable to a memory disclosure in cross-type comparison for hashed subplan.

Record
CVE-2019-10209
CVSS 3.1
2.2 LowCVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
OSVMGASA-2019-0225 No score

Updated postgresql packages fix security vulnerabilities

Updated postgresql packages fix security vulnerabilities:

Given a suitable SECURITY DEFINER function, an attacker can execute arbitrary SQL under the identity of the function owner. An attack requires EXECUTE permission on the function, which must itself contain a function call having inexact argument type match. For example, length('foo'::varchar) and length('foo') are inexact, while length('foo'::text) is exact (CVE-2019-10208).

In a database containing hypothetical, user-defined hash equality operators, an attacker could read arbitrary bytes of server memory. For an attack to become possible, a superuser would need to create unusual operators. It is possible for operators not purpose-crafted for attack to have the properties that enable an attack, but we are not aware of specific examples (CVE-2019-10209).

This update also fixes over 40 bugs that were reported in the last several months. See the upstream release notes for details.

Record
MGASA-2019-0225
Updated
2026-11-02
OSVopenSUSE-SU-2024:11185-1 No score

postgresql11-11.13-1.3 on GA media

These are all security issues fixed in the postgresql11-11.13-1.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11185-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
postgresql
Alpine:v3.10
11.0 up to 11.5-r0
11.5-r0
postgresql
Alpine:v3.11
11.0 up to 11.5-r0
11.5-r0
postgresql
Alpine:v3.12
11.0 up to 11.5-r0
11.5-r0
postgresql
Alpine:v3.13
11.0 up to 11.5-r0
11.5-r0
postgresql
Alpine:v3.14
11.0 up to 11.5-r0
11.5-r0
postgresql
Alpine:v3.9
11.0 up to 11.5-r0
11.5-r0
postgresql14
Alpine:v3.15
before 11.5-r0
11.5-r0
postgresql14
Alpine:v3.16
before 11.5-r0
11.5-r0
postgresql14
Alpine:v3.17
before 11.5-r0
11.5-r0
postgresql14
Alpine:v3.18
before 11.5-r0
11.5-r0
Show 12 moreShow less
Affected packages
PackageAffectedFixed
postgresql14
Alpine:v3.19
before 11.5-r0
11.5-r0
postgresql14
Alpine:v3.20
before 11.5-r0
11.5-r0
postgresql15
Alpine:v3.17
before 11.5-r0
11.5-r0
postgresql15
Alpine:v3.18
before 11.5-r0
11.5-r0
postgresql15
Alpine:v3.19
before 11.5-r0
11.5-r0
postgresql15
Alpine:v3.20
before 11.5-r0
11.5-r0
postgresql-11
Debian:10
before 11.5-1+deb10u1, plus listed versions
11.4-111.5-1
11.5-1+deb10u1
postgresql9.4
Mageia:6
before 9.4.24-1.mga6
9.4.24-1.mga6
postgresql9.6
Mageia:6
before 9.6.15-1.mga6
9.6.15-1.mga6
postgresql9.6
Mageia:7
before 9.6.15-1.mga7
9.6.15-1.mga7
postgresql11
Mageia:7
before 11.5-1.mga7
11.5-1.mga7
postgresql11
openSUSE:Tumbleweed
before 11.13-1.3
11.13-1.3

History

History
WhenChangedSources
2026-11-03affectedOSV
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 23 moreShow less
MoveEnter Open