postgresql11 vulnerabilities (openSUSE)
28 vulnerabilities.
-
postgresql11openSUSE Postgresql: role pg_signal_backend can signal certain superuser processes. 2.2 Low -
postgresql11openSUSE Postgresql: buffer overrun from integer overflow in array modification 8.8 High -
postgresql11openSUSE Postgresql: memory disclosure in aggregate function calls 4.3 Medium -
postgresql11openSUSE Postgresql: extension script @substitutions@ within quoting allow sql injection 7.5 High -
postgresql11openSUSE Row security policies disregard user ID changes after inlining; PostgreSQL could permit incorrect... 5.4 Medium -
postgresql11openSUSE schema_element defeats protective search_path changes; It was found that certain database calls... 7.2 High -
postgresql11openSUSE A vulnerability found in postgresql. On this security issue an attack requires permission to... 8.0 High -
postgresql11openSUSE A flaw was found in PostgreSQL. There is an issue with incomplete efforts to operate safely when... 8.8 High -
postgresql11openSUSE A man-in-the-middle attacker can inject false responses to the client's first few queries,... 5.9 Medium -
postgresql11openSUSE When the server is configured to use trust authentication with a clientcert requirement or to use... 8.1 High -
postgresql11openSUSE A flaw was found in postgresql. A purpose-crafted query can read arbitrary bytes of server memory... 6.5 Medium -
postgresql11openSUSE A flaw was found in postgresql. Using an UPDATE ... RETURNING command on a purpose-crafted table,... 6.5 Medium -
postgresql11openSUSE A flaw was found in postgresql. Using an INSERT ... ON CONFLICT ... DO UPDATE command on a... 6.5 Medium -
postgresql11openSUSE A flaw was found in postgresql in versions before 13.3, before 12.7, before 11.12, before 10.17... 8.8 High -
postgresql11openSUSE Generation of Error Message Containing Sensitive Information in postgresql 4.3 Medium -
postgresql11openSUSE Incorrect Comparison, Permissive List of Allowed Inputs, and Privilege Context Switching Error in PostgreSQL 7.5 High -
postgresql11openSUSE SQL Injection 8.8 High -
postgresql11openSUSE Use of a Broken or Risky Cryptographic Algorithm in PostgreSQL 8.1 High -
postgresql11openSUSE Untrusted Search Path in PostgreSQL 7.3 High -
postgresql11openSUSE It was found that PostgreSQL versions before 12.4, before 11.9 and before 10.14 did not properly... 7.1 High -
postgresql11openSUSE A flaw was found in PostgreSQL's "ALTER ... DEPENDS ON EXTENSION", where sub... 3.1 Low -
postgresql11openSUSE Postgresql, versions 11.x before 11.5, is vulnerable to a memory disclosure in cross-type... 3.1 Low -
postgresql11openSUSE A flaw was discovered in postgresql where arbitrary SQL statements can be executed given a... 7.5 High -
postgresql11openSUSE PostgreSQL versions 10.x before 10.9 and versions 11.x before 11.4 are vulnerable to a stack... 7.5 High -
postgresql11openSUSE A vulnerability was found in postgresql versions 11.x prior to 11.3. Using a purpose-crafted... 6.5 Medium -
postgresql11openSUSE A vulnerability was found in PostgreSQL versions 11.x up to excluding 11.3, 10.x up to excluding... 3.1 Low -
postgresql11openSUSE postgresql before versions 11.1, 10.6 is vulnerable to a to SQL injection in pg_upgrade and... 8.0 High -
postgresql11openSUSE It was discovered that PostgreSQL versions before 10.5, 9.6.10, 9.5.14, 9.4.19, and 9.3.24 failed... 7.1 High