Every CVE Search/ Get API key

CVE-2019-10129

A vulnerability was found in postgresql versions 11.x prior to 11.3. Using a purpose-crafted...

6.5 MediumFix available

CVE-2019-10129 is a medium vulnerability (CVSS 6.5) in Postgresql, published June 10, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.63%, the 76th percentile. Fixed in postgresql 11.3-r0.

A vulnerability was found in postgresql versions 11.x prior to 11.3. Using a purpose-crafted insert to a partitioned table, an attacker can read arbitrary bytes of server memory. In the default configuration, any user can create a partitioned table suitable for this attack. (Exploit prerequisites are the same as for CVE-2018-1052).

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

1.63%Up 0.8 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 6.5

A vulnerability was found in postgresql versions 11.x prior to 11.3. Using a purpose-crafted insert to a partitioned table, an attacker can read arbitrary bytes of server memory. In the default configuration, any user can create a partitioned table suitable for this attack. (Exploit prerequisites are the same as for CVE-2018-1052).

Record
CVE-2019-10129
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-125
Updated
2026-11-02
EUVDEUVD-2019-2171 6.5

A vulnerability was found in postgresql versions 11.x prior to 11.3. Using a purpose-crafted insert to a partitioned table, an attacker can read arbitrary bytes of server memory. In the default configuration, any user can create a partitioned table suitable for this attack. (Exploit prerequisites are the same as for CVE-2018-1052).

Record
EUVD-2019-2171
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-8f7w-x9j5-q7c8 6.5

A vulnerability was found in postgresql versions 11.x prior to 11.3. Using a purpose-crafted...

A vulnerability was found in postgresql versions 11.x prior to 11.3. Using a purpose-crafted insert to a partitioned table, an attacker can read arbitrary bytes of server memory. In the default configuration, any user can create a partitioned table suitable for this attack. (Exploit prerequisites are the same as for CVE-2018-1052).

Record
GHSA-8f7w-x9j5-q7c8
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-125
Updated
2026-11-02
NVD 6.5

A vulnerability was found in postgresql versions 11.x prior to 11.3. Using a purpose-crafted insert to a partitioned table, an attacker can read arbitrary bytes of server memory. In the default configuration, any user can create a partitioned table suitable for this attack. (Exploit prerequisites are the same as for CVE-2018-1052).

Record
CVE-2019-10129
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:P/I:N/A:N
Weakness
CWE-125
Updated
2026-11-02
OSVALPINE-CVE-2019-10129 6.5

A vulnerability was found in postgresql versions 11.x prior to 11.3. Using a purpose-crafted insert to a partitioned table, an attacker can read arbitrary bytes of server memory. In the default configuration, any user can create a partitioned table suitable for this attack. (Exploit prerequisites are the same as for CVE-2018-1052).

Record
ALPINE-CVE-2019-10129
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-03
OSVBELL-CVE-2019-10129 6.5

CVE-2019-10129 does not affect BellSoft software

Record
BELL-CVE-2019-10129
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSV 6.5

A vulnerability was found in postgresql versions 11.x prior to 11.3. Using a purpose-crafted insert to a partitioned table, an attacker can read arbitrary bytes of server memory. In the default configuration, any user can create a partitioned table suitable for this attack. (Exploit prerequisites are the same as for CVE-2018-1052).

Record
CVE-2019-10129
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVMGASA-2019-0189 No score

Updated postgresql packages fix security vulnerabilities

Updated postgresql packages fix security vulnerabilities

CVE-2019-10129: Memory disclosure in partition routing Prior to this release, a user running PostgreSQL 11 can read arbitrary bytes of server memory by executing a purpose-crafted INSERT statement to a partitioned table.

CVE-2019-10130: Selectivity estimators bypass row security policies PostgreSQL maintains statistics for tables by sampling data available in columns; this data is consulted during the query planning process. Prior to this release, a user able to execute SQL queries with permissions to read a given column could craft a leaky operator that could read whatever data had been sampled from that column. If this happened to include values from rows that the user is forbidden to see by a row security policy, the user could effectively bypass the policy. This is fixed by only allowing a non-leakproof operator to use this data if there are no relevant row security policies for the table.

Record
MGASA-2019-0189
Updated
2026-11-02
OSVopenSUSE-SU-2024:11185-1 No score

postgresql11-11.13-1.3 on GA media

These are all security issues fixed in the postgresql11-11.13-1.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11185-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
postgresql
Alpine:v3.10
11.0 up to 11.3-r0
11.3-r0
postgresql
Alpine:v3.11
11.0 up to 11.3-r0
11.3-r0
postgresql
Alpine:v3.12
11.0 up to 11.3-r0
11.3-r0
postgresql
Alpine:v3.13
11.0 up to 11.3-r0
11.3-r0
postgresql
Alpine:v3.14
11.0 up to 11.3-r0
11.3-r0
postgresql
Alpine:v3.6
11.0 up to 9.6.13-r0
9.6.13-r0
postgresql
Alpine:v3.7
11.0 up to 10.8-r0
10.8-r0
postgresql
Alpine:v3.8
11.0 up to 10.8-r0
10.8-r0
postgresql
Alpine:v3.9
11.0 up to 11.3-r0
11.3-r0
postgresql14
Alpine:v3.15
before 11.3-r0
11.3-r0
Show 12 moreShow less
Affected packages
PackageAffectedFixed
postgresql14
Alpine:v3.16
before 11.3-r0
11.3-r0
postgresql14
Alpine:v3.17
before 11.3-r0
11.3-r0
postgresql14
Alpine:v3.18
before 11.3-r0
11.3-r0
postgresql14
Alpine:v3.19
before 11.3-r0
11.3-r0
postgresql14
Alpine:v3.20
before 11.3-r0
11.3-r0
postgresql15
Alpine:v3.17
before 11.3-r0
11.3-r0
postgresql15
Alpine:v3.18
before 11.3-r0
11.3-r0
postgresql15
Alpine:v3.19
before 11.3-r0
11.3-r0
postgresql15
Alpine:v3.20
before 11.3-r0
11.3-r0
postgresql9.4
Mageia:6
before 9.4.22-1.mga6
9.4.22-1.mga6
postgresql9.6
Mageia:6
before 9.6.13-3.mga6
9.6.13-3.mga6
postgresql11
openSUSE:Tumbleweed
before 11.13-1.3
11.13-1.3

History

History
WhenChangedSources
2026-11-03affectedOSV
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 21 moreShow less
MoveEnter Open