postgresql14 vulnerabilities (Alpine)
52 vulnerabilities.
-
postgresql14Alpine PostgreSQL GB18030 encoding validation can read one byte past end of allocation for text that fails validation 5.9 Medium -
postgresql14Alpine PostgreSQL quoting APIs miss neutralizing quoting syntax in text that fails encoding validation 8.1 High -
postgresql14Alpine PostgreSQL PL/Perl environment variable changes execute arbitrary code 8.8 High -
postgresql14Alpine PostgreSQL SET ROLE, SET SESSION AUTHORIZATION reset to wrong user ID 4.2 Medium -
postgresql14Alpine PostgreSQL libpq retains an error message from man-in-the-middle 3.1 Low -
postgresql14Alpine PostgreSQL row security below e.g. subqueries disregards user ID changes 4.2 Medium -
postgresql14Alpine PostgreSQL relation replacement during pg_dump executes arbitrary SQL 8.8 High -
postgresql14Alpine PostgreSQL non-owner REFRESH MATERIALIZED VIEW CONCURRENTLY executes arbitrary SQL 8.0 High -
postgresql14Alpine Postgresql: role pg_signal_backend can signal certain superuser processes. 2.2 Low -
postgresql14Alpine Postgresql: buffer overrun from integer overflow in array modification 8.8 High -
postgresql14Alpine Postgresql: memory disclosure in aggregate function calls 4.3 Medium -
postgresql14Alpine Postgresql: merge fails to enforce update or select row security policies 3.1 Low -
postgresql14Alpine Postgresql: extension script @substitutions@ within quoting allow sql injection 7.5 High -
postgresql14Alpine Row security policies disregard user ID changes after inlining; PostgreSQL could permit incorrect... 5.4 Medium -
postgresql14Alpine schema_element defeats protective search_path changes; It was found that certain database calls... 7.2 High -
postgresql14Alpine In PostgreSQL, a modified, unauthenticated server can send an unterminated string during the... 3.7 Low -
postgresql14Alpine A vulnerability found in postgresql. On this security issue an attack requires permission to... 8.0 High -
postgresql14Alpine A flaw was found in PostgreSQL. There is an issue with incomplete efforts to operate safely when... 8.8 High -
postgresql14Alpine A man-in-the-middle attacker can inject false responses to the client's first few queries,... 5.9 Medium -
postgresql14Alpine When the server is configured to use trust authentication with a clientcert requirement or to use... 8.1 High -
postgresql14Alpine A flaw was found in postgresql. A purpose-crafted query can read arbitrary bytes of server memory... 6.5 Medium -
postgresql14Alpine A flaw was found in postgresql. Using an UPDATE ... RETURNING command on a purpose-crafted table,... 6.5 Medium -
postgresql14Alpine A flaw was found in postgresql. Using an INSERT ... ON CONFLICT ... DO UPDATE command on a... 6.5 Medium -
postgresql14Alpine A flaw was found in postgresql in versions before 13.3, before 12.7, before 11.12, before 10.17... 8.8 High -
postgresql14Alpine Incorrect Authorization in PostgreSQL 4.3 Medium -
postgresql14Alpine Generation of Error Message Containing Sensitive Information in postgresql 4.3 Medium -
postgresql14Alpine Incorrect Comparison, Permissive List of Allowed Inputs, and Privilege Context Switching Error in PostgreSQL 7.5 High -
postgresql14Alpine SQL Injection 8.8 High -
postgresql14Alpine Use of a Broken or Risky Cryptographic Algorithm in PostgreSQL 8.1 High -
postgresql14Alpine Untrusted Search Path in PostgreSQL 7.3 High -
postgresql14Alpine It was found that PostgreSQL versions before 12.4, before 11.9 and before 10.14 did not properly... 7.1 High -
postgresql14Alpine A flaw was found in PostgreSQL's "ALTER ... DEPENDS ON EXTENSION", where sub... 3.1 Low -
postgresql14Alpine Postgresql, versions 11.x before 11.5, is vulnerable to a memory disclosure in cross-type... 3.1 Low -
postgresql14Alpine A flaw was discovered in postgresql where arbitrary SQL statements can be executed given a... 7.5 High -
postgresql14Alpine PostgreSQL versions 10.x before 10.9 and versions 11.x before 11.4 are vulnerable to a stack... 7.5 High -
postgresql14Alpine A vulnerability was found in postgresql versions 11.x prior to 11.3. Using a purpose-crafted... 6.5 Medium -
postgresql14Alpine A vulnerability was found in PostgreSQL versions 11.x up to excluding 11.3, 10.x up to excluding... 3.1 Low -
postgresql14Alpine postgresql before versions 11.1, 10.6 is vulnerable to a to SQL injection in pg_upgrade and... 8.0 High -
postgresql14Alpine It was discovered that PostgreSQL versions before 10.5, 9.6.10, 9.5.14, 9.4.19, and 9.3.24 failed... 7.1 High -
postgresql14Alpine A vulnerability was found in libpq, the default PostgreSQL client library where libpq failed to... 8.5 High -
postgresql14Alpine postgresql before versions 10.4, 9.6.9 is vulnerable in the adminpack extension, the pg_catalog... 4.2 Medium -
postgresql14Alpine A flaw was found in the way Postgresql allowed a user to modify the behavior of a query for other... 8.8 High -
postgresql14Alpine Memory disclosure vulnerability in table partitioning was found in postgresql 10.x before 10.2,... 6.5 Medium -
postgresql14Alpine In postgresql 9.3.x before 9.3.21, 9.4.x before 9.4.16, 9.5.x before 9.5.11, 9.6.x before 9.6.7... 7.0 High -
postgresql14Alpine INSERT ... ON CONFLICT DO UPDATE commands in PostgreSQL 10.x before 10.1, 9.6.x before 9.6.6, and... 6.5 Medium -
postgresql14Alpine Invalid json_populate_recordset or jsonb_populate_recordset function calls in PostgreSQL 10.x... 8.1 High -
postgresql14Alpine PostgreSQL versions before 9.4.13, 9.5.8 and 9.6.4 are vulnerable to authorization flaw allowing... 7.5 High -
postgresql14Alpine PostgreSQL versions before 9.2.22, 9.3.18, 9.4.13, 9.5.8 and 9.6.4 are vulnerable to... 8.8 High -
postgresql14Alpine PostgreSQL versions before 9.2.22, 9.3.18, 9.4.13, 9.5.8 and 9.6.4 are vulnerable to incorrect... 9.8 Critical -
postgresql14Alpine PostgreSQL versions 8.4 - 9.6 are vulnerable to information leak in pg_user_mappings view which... 7.5 High - Show olderLoading…