CVE-2016-4657
WebKit in Apple iOS before 9.3.5 allows remote attackers to execute arbitrary code or cause a...
WebKit in Apple iOS before 9.3.5 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
WebKit in Apple iOS before 9.3.5 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site.
- Record
CVE-2016-4657- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-787
- Updated
- 2026-11-02
CVE List
8.8
WebKit in Apple iOS before 9.3.5 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site.
- Record
CVE-2016-4657- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
EUVDEUVD-2016-5643
8.8
WebKit in Apple iOS before 9.3.5 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site.
- Record
EUVD-2016-5643- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-99xm-29ff-vvqm
8.8
WebKit in Apple iOS before 9.3.5 allows remote attackers to execute arbitrary code or cause a...
WebKit in Apple iOS before 9.3.5 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site.
- Record
GHSA-99xm-29ff-vvqm- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-119, CWE-787
- Updated
- 2026-11-02
CISA KEV No score
Apple iOS Webkit Memory Corruption Vulnerability
Apple iOS WebKit contains a memory corruption vulnerability that allows attackers to execute remote code or cause a denial-of-service (DoS) via a crafted web site. This vulnerability could impact HTML parsers that use WebKit, including but not limited to Apple Safari and non-Apple products which rely on WebKit for HTML processing.
- Record
CVE-2016-4657- Weakness
- CWE-119
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-4657
8.8
WebKit in Apple iOS before 9.3.5 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site.
- Record
UBUNTU-CVE-2016-4657- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2017-0069 No score
Updated webkit2 packages fix security vulnerabilities
The webkit2 package has been updated to version 2.14.5, fixing several security issues and other bugs.
- Record
MGASA-2017-0069- Updated
- 2026-11-02
OSVUSN-3166-1 No score
webkit2gtk vulnerabilities
A large number of security issues were discovered in the WebKitGTK+ Web and JavaScript engines. If a user were tricked into viewing a malicious website, a remote attacker could exploit a variety of issues related to web browser security, including cross-site scripting attacks, denial of service attacks, and arbitrary code execution.
- Record
USN-3166-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
webkit2Mageia:5 From an advisory covering 60 CVEs |
before 2.14.5-1.mga5 | 2.14.5-1.mga5 |
webkit2gtkUbuntu:16.04:LTS |
before 2.14.2-0ubuntu0.16.04.1, plus listed versions 2.8.5+dfsg1-32.10.3+dfsg1-12.10.4+dfsg1-12.10.5-12.10.6-1 Show 4 moreShow less2.10.6-1ubuntu12.10.8-1ubuntu12.10.9-1ubuntu12.12.5-0ubuntu0.16.04.1 |
2.14.2-0ubuntu0.16.04.1 |
qtwebkit-opensource-srcUbuntu:16.04:LTS |
All versions, plus listed versions 5.4.2+dfsg-1ubuntu2.15.5.1+dfsg-2ubuntu1 |
None known |
qtwebkit-sourceUbuntu:16.04:LTS |
All versions, plus listed versions 2.3.2-0ubuntu102.3.2-0ubuntu11 |
None known |
webkitgtkUbuntu:16.04:LTS |
All versions, plus listed versions 2.4.9-2ubuntu22.4.10-0ubuntu12.4.11-0ubuntu0.1 |
None known |
webkit2gtkUbuntu:16.04:LTS From an advisory covering 18 CVEs |
before 2.14.2-0ubuntu0.16.04.1, plus listed versions 2.8.5+dfsg1-32.10.3+dfsg1-12.10.4+dfsg1-12.10.5-12.10.6-1 Show 4 moreShow less2.10.6-1ubuntu12.10.8-1ubuntu12.10.9-1ubuntu12.12.5-0ubuntu0.16.04.1 |
2.14.2-0ubuntu0.16.04.1 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Metasploit | WebKit not_number defineProperties UAF | 2016-08-25 |
| Exploit-DB | Nintendo Switch - WebKit Code Execution (PoC) | 2017-03-12 |
| PoC in GitHub | Mimoja/CVE-2016-4657-NintendoSwitch | 2017-03-13 |
| PoC in GitHub | iDaN5x/Switcheroo | 2017-06-02 |
| Exploit-DB | WebKit - not_number defineProperties UAF (Metasploit) | 2018-06-05 |
| PoC in GitHub | viai957/webkit-vulnerability | 2018-11-11 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| exploitation, exploits | ||
| first indexed | CVE List, EUVD, Exploit-DB, GitHub Advisories, CISA KEV, Metasploit, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-4657 is a high vulnerability (CVSS 8.8) in Apple Ios, published August 25, 2016. CISA lists it as known to be exploited, since May 24, 2022. EUVD reports exploitation since May 24, 2022. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 66.8%, the 99th percentile. Fixed in webkit2gtk 2.14.2-0ubuntu0.16.04.1.
References
blog.lookout.com/blog/2016/08/25/trident-pegasus
youtube.com/watch?v=xkdPjbaLngE
exploit-db.com/exploits/44836
securityfocus.com/bid/92653
support.apple.com/HT207107
lists.apple.com/archives/security-announce/2016/Aug/msg00000.html
Show 37 moreShow less
securitytracker.com/id/1036694
cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2016-4657
nvd.nist.gov/vuln/detail/CVE-2016-4657
github.com/advisories/GHSA-99xm-29ff-vvqm
advisories.mageia.org/MGASA-2017-0069.html
bugs.mageia.org/show_bug.cgi?id=19721
webkitgtk.org/security/WSA-2016-0006.html
webkitgtk.org/security/WSA-2017-0001.html
webkitgtk.org/security/WSA-2017-0002.html
webkitgtk.org/2016/09/05/webkitgtk2.12.5-released.html
webkitgtk.org/2016/09/20/webkitgtk2.14.0-released.html
webkitgtk.org/2016/10/11/webkitgtk2.14.1-released.html
webkitgtk.org/2016/11/03/webkitgtk2.14.2-released.html
webkitgtk.org/2017/01/17/webkitgtk2.14.3-released.html
webkitgtk.org/2017/02/10/webkitgtk2.14.4-released.html
webkitgtk.org/2017/02/15/webkitgtk2.14.5-released.html
ubuntu.com/security/CVE-2016-4657
ubuntu.com/security/notices/USN-3166-1
cve.org/CVERecord?id=CVE-2016-4657
cisa.gov/known-exploited-vulnerabilities-catalog
ubuntu.com/security/CVE-2016-4613
ubuntu.com/security/CVE-2016-4666
ubuntu.com/security/CVE-2016-4707
ubuntu.com/security/CVE-2016-4728
ubuntu.com/security/CVE-2016-4733
ubuntu.com/security/CVE-2016-4734
ubuntu.com/security/CVE-2016-4735
ubuntu.com/security/CVE-2016-4759
ubuntu.com/security/CVE-2016-4760
ubuntu.com/security/CVE-2016-4761
ubuntu.com/security/CVE-2016-4762
ubuntu.com/security/CVE-2016-4764
ubuntu.com/security/CVE-2016-4765
ubuntu.com/security/CVE-2016-4767
ubuntu.com/security/CVE-2016-4768
ubuntu.com/security/CVE-2016-4769
ubuntu.com/security/CVE-2016-7578