Every CVE Search/ Get API key

CVE-2016-4657

WebKit in Apple iOS before 9.3.5 allows remote attackers to execute arbitrary code or cause a...

8.8 HighIn KEVPublic exploitFix available

WebKit in Apple iOS before 9.3.5 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

66.8%Up 27.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 8.8

WebKit in Apple iOS before 9.3.5 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site.

Record
CVE-2016-4657
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-787
Updated
2026-11-02
CVE List 8.8

WebKit in Apple iOS before 9.3.5 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site.

Record
CVE-2016-4657
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-787
Updated
2026-11-02
EUVDEUVD-2016-5643 8.8

WebKit in Apple iOS before 9.3.5 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site.

Record
EUVD-2016-5643
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-99xm-29ff-vvqm 8.8

WebKit in Apple iOS before 9.3.5 allows remote attackers to execute arbitrary code or cause a...

WebKit in Apple iOS before 9.3.5 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site.

Record
GHSA-99xm-29ff-vvqm
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-119, CWE-787
Updated
2026-11-02
CISA KEV No score

Apple iOS Webkit Memory Corruption Vulnerability

Apple iOS WebKit contains a memory corruption vulnerability that allows attackers to execute remote code or cause a denial-of-service (DoS) via a crafted web site. This vulnerability could impact HTML parsers that use WebKit, including but not limited to Apple Safari and non-Apple products which rely on WebKit for HTML processing.

Record
CVE-2016-4657
Weakness
CWE-119
Updated
2026-11-02
OSVUBUNTU-CVE-2016-4657 8.8

WebKit in Apple iOS before 9.3.5 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site.

Record
UBUNTU-CVE-2016-4657
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2017-0069 No score

Updated webkit2 packages fix security vulnerabilities

The webkit2 package has been updated to version 2.14.5, fixing several security issues and other bugs.

Record
MGASA-2017-0069
Updated
2026-11-02
OSVUSN-3166-1 No score

webkit2gtk vulnerabilities

A large number of security issues were discovered in the WebKitGTK+ Web and JavaScript engines. If a user were tricked into viewing a malicious website, a remote attacker could exploit a variety of issues related to web browser security, including cross-site scripting attacks, denial of service attacks, and arbitrary code execution.

Record
USN-3166-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
webkit2
Mageia:5
From an advisory covering 60 CVEs
before 2.14.5-1.mga5
2.14.5-1.mga5
webkit2gtk
Ubuntu:16.04:LTS
before 2.14.2-0ubuntu0.16.04.1, plus listed versions
2.8.5+dfsg1-32.10.3+dfsg1-12.10.4+dfsg1-12.10.5-12.10.6-1
Show 4 moreShow less
2.10.6-1ubuntu12.10.8-1ubuntu12.10.9-1ubuntu12.12.5-0ubuntu0.16.04.1
2.14.2-0ubuntu0.16.04.1
qtwebkit-opensource-src
Ubuntu:16.04:LTS
All versions, plus listed versions
5.4.2+dfsg-1ubuntu2.15.5.1+dfsg-2ubuntu1
None known
qtwebkit-source
Ubuntu:16.04:LTS
All versions, plus listed versions
2.3.2-0ubuntu102.3.2-0ubuntu11
None known
webkitgtk
Ubuntu:16.04:LTS
All versions, plus listed versions
2.4.9-2ubuntu22.4.10-0ubuntu12.4.11-0ubuntu0.1
None known
webkit2gtk
Ubuntu:16.04:LTS
From an advisory covering 18 CVEs
before 2.14.2-0ubuntu0.16.04.1, plus listed versions
2.8.5+dfsg1-32.10.3+dfsg1-12.10.4+dfsg1-12.10.5-12.10.6-1
Show 4 moreShow less
2.10.6-1ubuntu12.10.8-1ubuntu12.10.9-1ubuntu12.12.5-0ubuntu0.16.04.1
2.14.2-0ubuntu0.16.04.1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
MetasploitWebKit not_number defineProperties UAF2016-08-25
Exploit-DBNintendo Switch - WebKit Code Execution (PoC)2017-03-12
PoC in GitHubMimoja/CVE-2016-4657-NintendoSwitch2017-03-13
PoC in GitHubiDaN5x/Switcheroo2017-06-02
Exploit-DBWebKit - not_number defineProperties UAF (Metasploit)2018-06-05
PoC in GitHubviai957/webkit-vulnerability2018-11-11

History

History
RecordedChangedSources
affected
exploitation, exploits
first indexedCVE List, EUVD, Exploit-DB, GitHub Advisories, CISA KEV, Metasploit, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-4657 is a high vulnerability (CVSS 8.8) in Apple Ios, published August 25, 2016. CISA lists it as known to be exploited, since May 24, 2022. EUVD reports exploitation since May 24, 2022. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 66.8%, the 99th percentile. Fixed in webkit2gtk 2.14.2-0ubuntu0.16.04.1.

References

Show 37 moreShow less
MoveEnter Open