Every CVE Search/ Get API key

CVE-2016-6810

Improper Neutralization of Input During Web Page Generation Apache ActiveMQ

6.1 MediumFix available

In Apache ActiveMQ 5.x before 5.14.2, an instance of a cross-site scripting vulnerability was identified to be present in the web based administration console. The root cause of this issue is improper user data output validation.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

6.09%Up 4.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.1

In Apache ActiveMQ 5.x before 5.14.2, an instance of a cross-site scripting vulnerability was identified to be present in the web based administration console. The root cause of this issue is improper user data output validation.

Record
CVE-2016-6810
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

In Apache ActiveMQ 5.x before 5.14.2, an instance of a cross-site scripting vulnerability was identified to be present in the web based administration console. The root cause of this issue is improper user data output validation.

Record
CVE-2016-6810
Updated
2026-11-02
EUVDEUVD-2022-2610 No score

In Apache ActiveMQ 5.x before 5.14.2, an instance of a cross-site scripting vulnerability was identified to be present in the web based administration console. The root cause of this issue is improper user data output validation.

Record
EUVD-2022-2610
Updated
2026-11-03
GitHub AdvisoriesGHSA-5jg4-p78r-p5j3 6.1

Improper Neutralization of Input During Web Page Generation Apache ActiveMQ

In Apache ActiveMQ 5.x before 5.14.2, an instance of a cross-site scripting vulnerability was identified to be present in the web based administration console. The root cause of this issue is improper user data output validation.

Record
GHSA-5jg4-p78r-p5j3
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

In Apache ActiveMQ 5.x before 5.14.2, an instance of a cross-site scripting vulnerability was identified to be present in the web based administration console. The root cause of this issue is improper user data output validation.

Record
CVE-2016-6810
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2016-6810 6.1

In Apache ActiveMQ 5.x before 5.14.2, an instance of a cross-site scripting vulnerability was identified to be present in the web based administration console. The root cause of this issue is improper user data output validation.

Record
DEBIAN-CVE-2016-6810
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-5jg4-p78r-p5j3 6.1

Improper Neutralization of Input During Web Page Generation Apache ActiveMQ

In Apache ActiveMQ 5.x before 5.14.2, an instance of a cross-site scripting vulnerability was identified to be present in the web based administration console. The root cause of this issue is improper user data output validation.

Record
GHSA-5jg4-p78r-p5j3
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVUBUNTU-CVE-2016-6810 6.1

In Apache ActiveMQ 5.x before 5.14.2, an instance of a cross-site scripting vulnerability was identified to be present in the web based administration console. The root cause of this issue is improper user data output validation.

Record
UBUNTU-CVE-2016-6810
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.activemq:activemq-client
Maven
5.0.0 to 5.14.1
5.14.2
activemq
Debian:12
before 5.14.2+dfsg-1
5.14.2+dfsg-1
activemq
Debian:13
before 5.14.2+dfsg-1
5.14.2+dfsg-1
org.apache.activemq:activemq-client
Maven
5.0.0 up to 5.14.2, plus listed versions
5.10.05.10.15.10.25.11.05.11.1
Show 18 moreShow less
5.11.25.11.35.11.45.12.05.12.15.12.25.12.35.13.05.13.15.13.25.13.35.13.45.13.55.14.05.14.15.8.05.9.05.9.1
5.14.2
activemq
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
5.6.0+dfsg1-4+deb8u1ubuntu15.6.0+dfsg1-55.13.2+dfsg-25.13.2+dfsg-2ubuntu0.1~esm1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-6810 is a medium vulnerability (CVSS 6.1) in Apache Activemq, published January 10, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.09%, the 93rd percentile. Fixed in org.apache.activemq:activemq-client 5.14.2.

References

Show 11 moreShow less
MoveEnter Open