Every CVE Search/ Get API key

CVE-2016-7398

A type confusion vulnerability in the merge_param() function of php_http_params.c in PHP's pecl...

9.8 CriticalFix available

A type confusion vulnerability in the merge_param() function of php_http_params.c in PHP's pecl-http extension 3.1.0beta2 (PHP 7) and earlier as well as 2.6.0beta2 (PHP 5) and earlier allows attackers to crash PHP and possibly execute arbitrary code via crafted HTTP requests.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

6.80%Up 4.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

A type confusion vulnerability in the merge_param() function of php_http_params.c in PHP's pecl-http extension 3.1.0beta2 (PHP 7) and earlier as well as 2.6.0beta2 (PHP 5) and earlier allows attackers to crash PHP and possibly execute arbitrary code via crafted HTTP requests.

Record
CVE-2016-7398
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-704
Updated
2026-11-02
CVE List No score

A type confusion vulnerability in the merge_param() function of php_http_params.c in PHP's pecl-http extension 3.1.0beta2 (PHP 7) and earlier as well as 2.6.0beta2 (PHP 5) and earlier allows attackers to crash PHP and possibly execute arbitrary code via crafted HTTP requests.

Record
CVE-2016-7398
Updated
2026-11-02
EUVDEUVD-2016-8254 No score

A type confusion vulnerability in the merge_param() function of php_http_params.c in PHP's pecl-http extension 3.1.0beta2 (PHP 7) and earlier as well as 2.6.0beta2 (PHP 5) and earlier allows attackers to crash PHP and possibly execute arbitrary code via crafted HTTP requests.

Record
EUVD-2016-8254
Updated
2026-11-03
GitHub AdvisoriesGHSA-jx2x-3hjr-6vp8 9.8

A type confusion vulnerability in the merge_param() function of php_http_params.c in PHP's pecl...

A type confusion vulnerability in the merge_param() function of php_http_params.c in PHP's pecl-http extension 3.1.0beta2 (PHP 7) and earlier as well as 2.6.0beta2 (PHP 5) and earlier allows attackers to crash PHP and possibly execute arbitrary code via crafted HTTP requests.

Record
GHSA-jx2x-3hjr-6vp8
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-704
Updated
2026-11-02
OSV 9.8

A type confusion vulnerability in the merge_param() function of php_http_params.c in PHP's pecl-http extension 3.1.0beta2 (PHP 7) and earlier as well as 2.6.0beta2 (PHP 5) and earlier allows attackers to crash PHP and possibly execute arbitrary code via crafted HTTP requests.

Record
CVE-2016-7398
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-7398 9.8

A type confusion vulnerability in the merge_param() function of php_http_params.c in PHP's pecl-http extension 3.1.0beta2 (PHP 7) and earlier as well as 2.6.0beta2 (PHP 5) and earlier allows attackers to crash PHP and possibly execute arbitrary code via crafted HTTP requests.

Record
DEBIAN-CVE-2016-7398
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-7398 9.8

A type confusion vulnerability in the merge_param() function of php_http_params.c in PHP's pecl-http extension 3.1.0beta2 (PHP 7) and earlier as well as 2.6.0beta2 (PHP 5) and earlier allows attackers to crash PHP and possibly execute arbitrary code via crafted HTTP requests.

Record
UBUNTU-CVE-2016-7398
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
php-pecl-http
Debian:12
before 3.1.0+2.6.0-1
3.1.0+2.6.0-1
php-pecl-http
Debian:13
before 3.1.0+2.6.0-1
3.1.0+2.6.0-1
php-pecl-http
Debian:14
before 3.1.0+2.6.0-1
3.1.0+2.6.0-1
php-pecl-http
Debian:8
before 2.0.4-1+deb8u1, plus listed versions
2.0.4-1
2.0.4-1+deb8u1
php-pecl-http
Ubuntu:16.04:LTS
All versions, plus listed versions
2.0.4-1build13.0.1-0ubuntu23.0.1-0ubuntu33.0.1-0ubuntu43.0.1-0ubuntu5
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-7398 is a critical vulnerability (CVSS 9.8) in Php Ext-http, published September 6, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.80%, the 94th percentile. Fixed in php-pecl-http 3.1.0+2.6.0-1.

References

MoveEnter Open