CVE-2016-7398
A type confusion vulnerability in the merge_param() function of php_http_params.c in PHP's pecl...
A type confusion vulnerability in the merge_param() function of php_http_params.c in PHP's pecl-http extension 3.1.0beta2 (PHP 7) and earlier as well as 2.6.0beta2 (PHP 5) and earlier allows attackers to crash PHP and possibly execute arbitrary code via crafted HTTP requests.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
A type confusion vulnerability in the merge_param() function of php_http_params.c in PHP's pecl-http extension 3.1.0beta2 (PHP 7) and earlier as well as 2.6.0beta2 (PHP 5) and earlier allows attackers to crash PHP and possibly execute arbitrary code via crafted HTTP requests.
- Record
CVE-2016-7398- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-704
- Updated
- 2026-11-02
CVE List No score
A type confusion vulnerability in the merge_param() function of php_http_params.c in PHP's pecl-http extension 3.1.0beta2 (PHP 7) and earlier as well as 2.6.0beta2 (PHP 5) and earlier allows attackers to crash PHP and possibly execute arbitrary code via crafted HTTP requests.
- Record
CVE-2016-7398- Updated
- 2026-11-02
EUVDEUVD-2016-8254 No score
A type confusion vulnerability in the merge_param() function of php_http_params.c in PHP's pecl-http extension 3.1.0beta2 (PHP 7) and earlier as well as 2.6.0beta2 (PHP 5) and earlier allows attackers to crash PHP and possibly execute arbitrary code via crafted HTTP requests.
- Record
EUVD-2016-8254- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-jx2x-3hjr-6vp8
9.8
A type confusion vulnerability in the merge_param() function of php_http_params.c in PHP's pecl...
A type confusion vulnerability in the merge_param() function of php_http_params.c in PHP's pecl-http extension 3.1.0beta2 (PHP 7) and earlier as well as 2.6.0beta2 (PHP 5) and earlier allows attackers to crash PHP and possibly execute arbitrary code via crafted HTTP requests.
- Record
GHSA-jx2x-3hjr-6vp8- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-704
- Updated
- 2026-11-02
OSV
9.8
A type confusion vulnerability in the merge_param() function of php_http_params.c in PHP's pecl-http extension 3.1.0beta2 (PHP 7) and earlier as well as 2.6.0beta2 (PHP 5) and earlier allows attackers to crash PHP and possibly execute arbitrary code via crafted HTTP requests.
- Record
CVE-2016-7398- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2016-7398
9.8
A type confusion vulnerability in the merge_param() function of php_http_params.c in PHP's pecl-http extension 3.1.0beta2 (PHP 7) and earlier as well as 2.6.0beta2 (PHP 5) and earlier allows attackers to crash PHP and possibly execute arbitrary code via crafted HTTP requests.
- Record
DEBIAN-CVE-2016-7398- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-7398
9.8
A type confusion vulnerability in the merge_param() function of php_http_params.c in PHP's pecl-http extension 3.1.0beta2 (PHP 7) and earlier as well as 2.6.0beta2 (PHP 5) and earlier allows attackers to crash PHP and possibly execute arbitrary code via crafted HTTP requests.
- Record
UBUNTU-CVE-2016-7398- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
php-pecl-httpDebian:12 |
before 3.1.0+2.6.0-1 | 3.1.0+2.6.0-1 |
php-pecl-httpDebian:13 |
before 3.1.0+2.6.0-1 | 3.1.0+2.6.0-1 |
php-pecl-httpDebian:14 |
before 3.1.0+2.6.0-1 | 3.1.0+2.6.0-1 |
php-pecl-httpDebian:8 |
before 2.0.4-1+deb8u1, plus listed versions 2.0.4-1 |
2.0.4-1+deb8u1 |
php-pecl-httpUbuntu:16.04:LTS |
All versions, plus listed versions 2.0.4-1build13.0.1-0ubuntu23.0.1-0ubuntu33.0.1-0ubuntu43.0.1-0ubuntu5 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-7398 is a critical vulnerability (CVSS 9.8) in Php Ext-http, published September 6, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.80%, the 94th percentile. Fixed in php-pecl-http 3.1.0+2.6.0-1.
References
bugs.php.net/bug.php?id=73055
github.com/m6w6/ext-http/commit/17137d4ab1ce81a2cee0fae842340a344ef3da83
bugs.php.net/bug.php?id=73055&edit=1
lists.debian.org/debian-lts-announce/2019/09/msg00022.html
nvd.nist.gov/vuln/detail/CVE-2016-7398
github.com/advisories/GHSA-jx2x-3hjr-6vp8
security-tracker.debian.org/tracker/CVE-2016-7398
ubuntu.com/security/CVE-2016-7398
cve.org/CVERecord?id=CVE-2016-7398