CVE-2017-1000427
Marked vulnerable to XSS from data URIs
CVE-2017-1000427 is a medium vulnerability (CVSS 6.1) in Marked Project Marked, published January 2, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.51%, the 74th percentile. Fixed in marked 0.3.7.
marked version 0.3.6 and earlier is vulnerable to an XSS attack in the data: URI parser.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
marked version 0.3.6 and earlier is vulnerable to an XSS attack in the data: URI parser.
- Record
CVE-2017-1000427- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
marked version 0.3.6 and earlier is vulnerable to an XSS attack in the data: URI parser.
- Record
CVE-2017-1000427- Updated
- 2026-11-02
EUVDEUVD-2018-0154 No score
marked version 0.3.6 and earlier is vulnerable to an XSS attack in the data: URI parser.
- Record
EUVD-2018-0154- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-7px7-7xjx-hxm8
6.1
Marked vulnerable to XSS from data URIs
marked version 0.3.6 and earlier is vulnerable to an XSS attack in the data: URI parser.
- Record
GHSA-7px7-7xjx-hxm8- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
marked version 0.3.6 and earlier is vulnerable to an XSS attack in the data: URI parser.
- Record
CVE-2017-1000427- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-1000427
6.1
marked version 0.3.6 and earlier is vulnerable to an XSS attack in the data: URI parser.
- Record
DEBIAN-CVE-2017-1000427- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-7px7-7xjx-hxm8
6.1
Marked vulnerable to XSS from data URIs
marked version 0.3.6 and earlier is vulnerable to an XSS attack in the data: URI parser.
- Record
GHSA-7px7-7xjx-hxm8- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-1000427
6.1
marked version 0.3.6 and earlier is vulnerable to an XSS attack in the data: URI parser.
- Record
UBUNTU-CVE-2017-1000427- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVCLSA-2026-1773188128 No score
TuxCare security update for marked (8 CVEs)
TuxCare rebuilt marked to address 8 CVEs. Fixed in 0.2.10-tuxcare.1.
- Record
CLSA-2026-1773188128- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
markednpm |
before 0.3.7 | 0.3.7 |
markedTuxCare:npm |
0.2.10-tuxcare.0 up to 0.2.10-tuxcare.1, plus listed versions 0.2.10 |
0.2.10-tuxcare.1 |
node-markedDebian:12 |
before 0.3.9+dfsg-1 | 0.3.9+dfsg-1 |
node-markedDebian:13 |
before 0.3.9+dfsg-1 | 0.3.9+dfsg-1 |
node-markedDebian:14 |
before 0.3.9+dfsg-1 | 0.3.9+dfsg-1 |
node-markedUbuntu:16.04:LTS |
All versions, plus listed versions 0.3.2+dfsg-1 |
None known |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
snyk.io/vuln/npm:marked:20170112
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BO2RMVVZVV6NFTU46B5RYRK7ZCXYARZS
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/M6BJG6RGDH7ZWVVAUFBFI5L32RSMQN2S
nvd.nist.gov/vuln/detail/CVE-2017-1000427
github.com/advisories/GHSA-7px7-7xjx-hxm8
lists.fedoraproject.org/archives/list/[email protected]/message/BO2RMVVZVV6NFTU46B5RYRK7ZCXYARZS