Every CVE Search/ Get API key

CVE-2017-1000488

Inline JS XSS vulnerability in Mautic

6.1 MediumFix available

Mautic version 2.1.0 - 2.11.0 is vulnerable to an inline JS XSS attack when using Mautic forms on a Mautic landing page using GET parameters to pre-populate the form.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.84%Up 0.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.1

Mautic version 2.1.0 - 2.11.0 is vulnerable to an inline JS XSS attack when using Mautic forms on a Mautic landing page using GET parameters to pre-populate the form.

Record
CVE-2017-1000488
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Mautic version 2.1.0 - 2.11.0 is vulnerable to an inline JS XSS attack when using Mautic forms on a Mautic landing page using GET parameters to pre-populate the form.

Record
CVE-2017-1000488
Updated
2026-11-02
EUVDEUVD-2021-0512 No score

Mautic version 2.1.0 - 2.11.0 is vulnerable to an inline JS XSS attack when using Mautic forms on a Mautic landing page using GET parameters to pre-populate the form.

Record
EUVD-2021-0512
Updated
2026-11-03
GitHub AdvisoriesGHSA-qjhr-c23f-w76q 6.1

Inline JS XSS vulnerability in Mautic

Impact

Mautic version 2.1.0 - 2.11.0 is vulnerable to an inline JS XSS attack when using Mautic forms on a Mautic landing page using GET parameters to pre-populate the form.

Patches

Upgrade to 2.12.0 or later.

Workarounds

None

References

https://github.com/mautic/mautic/releases/tag/2.12.0

For more information

If you have any questions or comments about this advisory:

Record
GHSA-qjhr-c23f-w76q
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

Mautic version 2.1.0 - 2.11.0 is vulnerable to an inline JS XSS attack when using Mautic forms on a Mautic landing page using GET parameters to pre-populate the form.

Record
CVE-2017-1000488
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-qjhr-c23f-w76q 6.1

Inline JS XSS vulnerability in Mautic

Impact

Mautic version 2.1.0 - 2.11.0 is vulnerable to an inline JS XSS attack when using Mautic forms on a Mautic landing page using GET parameters to pre-populate the form.

Patches

Upgrade to 2.12.0 or later.

Workarounds

None

References

https://github.com/mautic/mautic/releases/tag/2.12.0

For more information

If you have any questions or comments about this advisory:

Record
GHSA-qjhr-c23f-w76q
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mautic/core
Packagist
2.1.0 up to 2.12.0
2.12.0
mautic/core
Packagist
2.1.0 up to 2.12.0, plus listed versions
2.1.12.10.02.10.0-beta2.10.12.11.0
Show 19 moreShow less
2.11.0-beta2.12.0-beta2.2.02.2.12.3.02.4.02.5.02.5.12.6.02.6.12.7.02.7.12.8.02.8.12.8.22.9.02.9.0-beta2.9.12.9.2
2.12.0

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-1000488 is a medium vulnerability (CVSS 6.1) in Acquia Mautic, published January 3, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.84%, the 58th percentile. Fixed in mautic/core 2.12.0.

References

MoveEnter Open