CVE-2017-1000489
Disabled users able to log in with third party SSO plugin
Mautic versions 2.0.0 - 2.11.0 with a SSO plugin installed could allow a disabled user to still login using email address
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.1
Mautic versions 2.0.0 - 2.11.0 with a SSO plugin installed could allow a disabled user to still login using email address
- Record
CVE-2017-1000489- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-287
- Updated
- 2026-11-02
CVE List No score
Mautic versions 2.0.0 - 2.11.0 with a SSO plugin installed could allow a disabled user to still login using email address
- Record
CVE-2017-1000489- Updated
- 2026-11-02
EUVDEUVD-2021-0495 No score
Mautic versions 2.0.0 - 2.11.0 with a SSO plugin installed could allow a disabled user to still login using email address
- Record
EUVD-2021-0495- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6x98-fx9j-7c78
8.1
Disabled users able to log in with third party SSO plugin
Impact
Mautic versions 2.0.0 - 2.11.0 with a SSO plugin installed could allow a disabled user to still login using email address
Patches
Upgrade to 2.12.0 or later.
Workarounds
None.
For more information
If you have any questions or comments about this advisory:
- Email us at [email protected]
- Record
GHSA-6x98-fx9j-7c78- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-287
- Updated
- 2026-11-02
OSV
8.1
Mautic versions 2.0.0 - 2.11.0 with a SSO plugin installed could allow a disabled user to still login using email address
- Record
CVE-2017-1000489- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-6x98-fx9j-7c78
8.1
Disabled users able to log in with third party SSO plugin
Impact
Mautic versions 2.0.0 - 2.11.0 with a SSO plugin installed could allow a disabled user to still login using email address
Patches
Upgrade to 2.12.0 or later.
Workarounds
None.
For more information
If you have any questions or comments about this advisory:
- Email us at [email protected]
- Record
GHSA-6x98-fx9j-7c78- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-287
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mautic/corePackagist |
2.0.0 up to 2.12.0 | 2.12.0 |
mautic/corePackagist |
2.0.0 up to 2.12.0, plus listed versions 2.0.12.1.02.1.12.10.02.10.0-beta Show 21 moreShow less2.10.12.11.02.11.0-beta2.12.0-beta2.2.02.2.12.3.02.4.02.5.02.5.12.6.02.6.12.7.02.7.12.8.02.8.12.8.22.9.02.9.0-beta2.9.12.9.2 |
2.12.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-1000489 is a high vulnerability (CVSS 8.1) in Acquia Mautic, published January 3, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.12%, the 66th percentile. Fixed in mautic/core 2.12.0.